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Welcome to MicroEJ developer documentation. Browse the following chapters to familiarize yourself with MicroEJ
Technology and understand the principles of app and platform development with MicroEJ.

The Glossary chapter describes MicroEJ terminology.

The Overview chapter introduces MicroEJ products and technology.

The SDK User Guide chapter presents the MicroEJ Software Development Kit.
The Application Developer Guide presents how to develop a Java application.

The Platform Developer Guide teaches you how to integrate a C Board Support as well as simulation config-
urations.

The Kernel Developer Guide introduces you to advanced concepts, such as partial updates and dynamic app
life cycle workflows.

The Tutorials chapter covers a variety of topics related to developing with the MicroEJ ecosystem.
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CHAPTER

ONE

MICROEJ GLOSSARY

This glossary defines the technical terms upon which the MICROEJ VEE (Virtual Execution Environment) is built.

Add-On Library A MicroEJ Add-On Libraryis a pure managed code (Java) library. It runs over one or more MicroEJ
Foundation Libraries.

Abstraction Layer An Abstraction Layer is the C code that implements a Foundation Library’s low-level APIs over
a board support package (BSP) or a C library.

Application A MicroEJ Application is a software program that runs on a Powered by MicroEJ device.

Standalone Application MicroEJ Standalone Application is a MicroEJ Application that is directly
linked to the C code to produce a MicroEJ Mono-Sandbox Firmware. Itis edited using MicroEJ
SDK.

Sandboxed Application A MicroEJ Sandboxed Application is a MicroEJ Application that can run
over a MicrokEJ Multi-Sandbox Firmware. It can be linked either statically or dynamically.

System Application A MicroEJ System Application (formerly called a Resident Application) is a
MicroEJ Sandboxed Application that is statically linked to a MicroEJ Multi-Sandbox Firmware,
as itis part of the initial image and cannot be removed.

Kernel Application A MicroEJ Kernel Application is a MicroEJ Standalone Application that imple-
ments the ability to be extended to produce a MicroEJ Multi-Sandbox Firmware.

Architecture A MicroEJ Architecture is a software package that includes the MicroEJ Core Engine port to a target
instruction set and a C compiler, core Foundation Libraries (/EDC], [BON], [SNI], [KF]) and the MicroEJ Simu-
lator. MicroEJ Architectures are distributed either as evaluation or production version.

Core Engine, also named “MEJ32” MicroEJ Core Engine, also named MEJ32, is a scalable 32-bit core for
resource-constrained embedded devices. It is delivered in various flavors, mostly as a binary software pack-
age. MicroEJ Core Engine allows applications written in various languages to run in a safe container.

Firmware A MicroEJ Firmware is the result of the binary link of a MicroEJ Standalone Application with a MicroEJ
Platform. The firmware is a binary program that can be programmed into the flash memory of a device.

Mono-Sandbox Firmware A MicroEJ Mono-Sandbox Firmware is a MicroEJ Firmware thatimple-
ments an unmodifiable set of functions. (previously MicroEJ Single-app Firmware)

Multi-Sandbox Firmware A MicroEJ Multi-Sandbox Firmware is a MicroEJ Firmware that imple-
ments the ability to be extended, by exposing a set of APIs and a memory space to link MicroEJ
Sandboxed Applications. (previously MicroEJ Multi-app Firmware)

Foundation Library AMicroEJ Foundation Libraryis a library that provides core or hardware-dependent function-
alities. A Foundation Library combines managed code (Java) and low-level APIs (C) implemented by one or
more Abstraction Layers through a native interface (SNV/).

Mock A MicroEJ Mock is a mockup of a Board Support Package capability that mimics an hardware functionality
for the MicroEJ Simulator.
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Module Manager MicroEJ Module Manager downloads, installs and controls the consistency of all the dependen-
cies and versions required to build and publish a MicroEJ asset. It is based on Semantic Versioning specifi-
cation.

Platform A MicroEJ Platform integrates a MICROEJ VEE, a MicroEJ Architecture, one or more Foundation Libraries
with their respective Abstraction Layers, and the board support package (BSP) for the target Device. It also
includes associated MicroEJ Mocks for the MicroEJ Simulator.

SDK MicroEJ SDK allows MicroEJ Firmware developers to build a MicroEJ-ready device, by integrating a MicroEJ
Architecture with both Java and C software on their device.

Simulator MicroEJ Simulator allows running MicroEJ Applications on a target hardware simulator on the devel-
oper’s desktop computer. The MicroEJ Simulator runs one or more MicrokEJ mock that mimics the hardware
functionality. It enables developers to develop their MicroEJ Applications without the need of hardware.

Studio MicroEJ Studio is the part of the SDK that can be rebranded by customers for their specific ecosystem. It
allows application developers to write a MicroEJ Sandboxed Application, run it on a Virtual Device, deploy it
on a MicroEJ-ready device, and publish it to a MicroEJ Forge instance.

VEE MICROEJVEE is an applications container. VEE stands for Virtual Execution Environment, and refers to the first
implementation that embeds a virtual 32-bit processor, hence the term “Virtual”. MICROEJ VEE runs on any
OS/RTOS commonly used in embedded systems (FreeRTOS, QP/C, uc/0S, ThreadX, embOS, Mbed OS, Zephyr
0S, VxWorks, PikeOS, Integrity, Linux, QNX, ...) and can also run without RTOS (bare-metal) or proprietary
RTOS. MICROEJ VEE includes the small MEJ32, along with a wide range of libraries (Add-On Libraries and
Foundation Libraries).

Virtual Device A MicroEJ Virtual Device is a software package that includes the simulation part of a MicroEJ
Firmware: runtime, libraries and application(s). It can be run on any PC without the need of the SDK. In
case a MicroEJ Multi-Sandbox Firmware, it is also used for developing a MicroEJ Sandboxed Application in
the SDK.
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CHAPTER

TWO

OVERVIEW

The MicroEJ product line offers profitable solutions to device manufacturers, application developers and service
providers for:

« Device software development at lower cost and effort,
+ Application development and deployment for generating extra revenue streams with services and data.

MicroEJ solutions enable delivery of user experience and business models similar to mobile Internet (smartphones
and tablets) for embedded devices with strong cost constraints and strict resource limitations (processor perfor-
mance, RAM and flash memory footprint, low-power). It also combines the techniques, methods and tools that
drove the PC and mobile Internet software industry, with the complex technical foundations of embedded systems
(fragmented processor architectures and diverse hardware-dependent software).

With MicroEJ solutions, you will use proven methods that cut software development time and cost. You will create
software that delivers incredible user experience and adjusts to the needs of your business.

2.1 Getting Started

MicroEJ Getting Started is available on https://developer.microej.com/get-started/.
Starting from scratch, the steps to go through the whole process are:

« Download and install the latest SDK Distribution;

+ Select between one of the available boards;

« Import a demo Application;

« Download and install the corresponding Platform for the target hardware;

+ Run the Application on Simulator with a Virtual Device;

« Build the Application for the target hardware to produce a Firmware;

« Deploy the Firmware on the board.

The following figure gives an overview of the SDK workflow:
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Fig. 1: SDK Workflow Overview

2.2 MICROEJ VEE

MicroEJ VEE (Virtual Execution Environment) is an applications container for resource-constrained embedded de-
vices running on microcontrollers or microprocessors. It allows devices to run multiple and mixed managed code
(Java, JavaScript) and C software applications.

MicroEJ VEE provides a fully configurable set of services that can be expanded, including:
» asecure multi-application framework,
+ aGUI framework (includes widgets),
« anetwork connection with security (SSL/TLS, HTTPS, REST, MQTT, ...),
« astorage framework (file system)

« aJava Cryptography Architecture (JCA) implementation.

2.2. MICROEJ VEE 5
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Fig. 2: MICROEJ VEE Overview

2.3 MICROEJ SDK

MICROEJ SDK offers a comprehensive toolset to build the embedded software of a device. The SDK covers two
levels in device software development:

« Device Firmware development
+ Application development

The firmware will generally be produced by the device OEM, it includes all device drivers and a specific set of Mi-
croEJ functionalities useful for application developers targeting this device.

2.3. MICROEJ SDK 6
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Fig. 3: SDK Workflow Overview

Using the SDK, a firmware developer will produce two versions of the MicroEJ binary, each one able to run appli-
cations:

« A Firmware binary to be flashed on OEM devices;
« AVirtual Device which will be used as a device simulator by application developers.
Using the SDK, an application developer will be able to:

« Import Virtual Devices matching his target hardware in order to develop and test applications on the Simu-
lator;

+ Deploy the application locally on an hardware device equipped with the Firmware;

« Package and publish the application on a MicroEJ Forge Instance, enabling remote end users to install it on
their devices. For more information about MicroEJ Forge, please consult https://www.microej.com/product/
forge.

The following diagram outlines the SDK content. Please refer to the SDK User Guide chapter for more details on the
SDK and its usage.

2.3. MICROEJ SDK 7
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SDK USER GUIDE

MICROEJ SDK is an integrated environment to create software applications for MicroEJ-ready devices. The SDK
provides tools to write applications and run them on a virtual (simulated) or real device. The capability to execute
an application in a simulated environment allows to quickly test changes done in the application code and hence
provide a short development feedback loop.

Since the purpose of the SDK is to develop for targeted MCU/MPU computers (IoT, wearable, etc.), it is a cross-
development tool. But unlike standard low-level cross-development tools, the SDK offers unique services like
hardware simulation and local deployment to the target hardware.

MS.- Simulator
|
: Test
MlCROEJSDK MICROEJ
APPLICATION Target
@) | Publish el

MICROEJ, Forge

Fig. 1: MicroEJ Application Development Overview

The SDK is composed of the following main elements:

+ SDK Version 5.x, an Integrated Development Environment (IDE) for writing Applications and building
Firmware. It is based on Eclipse Java edition and relies on the integrated Java compiler (JDT).

Itis also packaged with Eclipse to produce a SDK Distribution.

+ MicroEJ Module Manager, the module and build manager used to compile and package any kind of MicroEJ
modules natures. It provides a Command Line Interface to build modules, especially used in a Continuous
Integration environment. See MicroEJ Module Manager section for more details.

+ Architecture, the software package that includes the MEJ32 port to a target instruction set and a C compiler,
SOAR, core libraries and Simulator. See MicroEJ Architecture section for more details.

The SDK allows to connect repositories hosting software modules in source and binary form. By default, it is con-
figured with the repositories provided MicroEJ Corp.:
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+ Centraland Developer Repository, the modules repositories containing all the libraries required to develop
an Application. See Module Repositories section for more details.

« Github Repositories, source repositories with examples and demos. See GitHub Repositories section for
more details.

The SDK is licensed under the SDK End User License Agreement (EULA). The following figure shows a detailed view
of the elements.

D . .
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- FontDesigner * Runtime Foundation Libraries . Demo Applications Modules
o EDC, BON, SNI, KF . Demo Platform Modules
O . ELF tools for C Toolchain linking . Demo Firmware & Virtual Devices
Module Manager Efl‘? +  Build & Link Scripts
Li Check
Module Dependencies Resolver fcense thee . .
Build Tools (including Java Compiler) GitHub Rep05|tory
Command Line Interface . Libraries Usage Examples
Module Natur(.es ) . Demo Applications Sources
(skeletons, build types, plugins) . Demo Platform Sources
Ecosystem Tools
Abstraction Layer Implementations

. J

Fig. 2: SDK Detailed View

3.1 Download and Install

The SDK is available for download at https://developer.microej.com/get-started. Check the System Requirements
page for the list of supported environments.

Once downloaded, execute the installer and follow the installation process.

3.2 System Requirements

+ Intel x64 PC with minimum :
- Dual-core Core i5 processor
- 4GB RAM
- 2GB Disk
+ Operating Systems :
- Windows 10, Windows 8.1 or Windows 8
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- Linux distributions (tested on Ubuntu 18.04 and 20.04) - As of SDK Distribution 20.10 (based on
Eclipse 2020-06), Ubuntu 16.04 is not supported.

- macOS (tested on version 10.13 High Sierra, 10.14 Mojave)

« Java:

- JRE or JDK 8 (Oracle JDK or other OpenJDK build: tested on AdoptOpenJDK/Eclipse Adoptium)

Warning: When installing the AdoptOpenJDK build on Windows, the option JavaSoft (Oracle) registry
keys must be enabled:

ﬁ AdoptOpen)DK JDK with Hotspot 8u282-b08 (x64) Setup — X

Custom Setup

Select the way you want features to be installed.

Click the icons in the tree below to change the way features will be installed.

AdoptOpen]DK Development Kit with
......... =3~| Add to PATH Hotspot

......... =3 -| Associate .jar

--------- X_-| Set JAVA HOME variable

--------- gl JavaSoft (Oracle) registry keys

B EI e eV This feature requires 186MB on your

hard drive. It has 3 of 5 subfeatures

selected. The subfeatures require 4KB

on your hard drive.

Location: C:\Program Files\AdoptOpen]DK\jdk-8.0.282.8-hotspot), Browse...

Reset Disk Usage Back Mext Cancel

Without this option, the SDK installer cannot find the JRE/JDK and the message The application requires
a Java Runtime Environment 1.8.0 isdisplayed.

3.3 Licenses

3.3.1 SDKEULA

MICROEJ SDK is licensed under the SDK End User License Agreement (EULA), which covers the following elements:
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+ SDK Tools & Plugins packaged in the SDK 5.x Version,
« Architectures,

» Modules published to the Central Repository with the SDK EULA license, such as GUI or Networking Pack (see
Central Repository Licensing for more details).

& MICROEJ 5D« @) Module Repositories
SDK Distribution YY.MM (@5 eclipse MICROEJ SDK EULA Central Repository o
(End User License Agreement) Various Licenses including SDK EULA
SDK Version 5.m.p > Developer Repository @

Architecture

Module Manager Ef@ ) )
o GitHub Repository

Fig. 3: SDK EULA Coverage

3.3.2 License Manager Overview

Architectures are distributed in two different versions:

« Evaluation Architectures, associated with a software license key. They can be downloaded at https://
repository.microej.com/modules/com/microej/architecture/.

» Production Architectures, associated with a hardware license key stored on a USB dongle. They can be re-
quested to our support team.

The license manager is provided with Architectures and then integrated into Platforms, consequently:

« Evaluation licenses will be shown only if at least one Evaluation Architecture or Platform built from an Eval-
uation Architecture has been imported in the SDK.

+ Production licenses will be shown only if at least one Production Architecture or Platform built from a Pro-
duction Architecture has been imported in the SDK.

Thelist ofinstalled licensesis availablein the SDK preferences dialog pagein Window > Preferences > MicroEJ

3.3. Licenses 12


https://repository.microej.com/modules/com/microej/architecture/
https://repository.microej.com/modules/com/microej/architecture/

MicroEJ Documentation, Revision c72145fb

S Preferences (0
type filter text MicroEJ f=e e
Checkstyl -
£ .st)re General settings for MicroE) development:
Copyright
- Data Management MicroEl repository
EasyantdEclipse - -
Help CAPyruntime-Mew_configuration\repo Browse... Refresh
- IceTea .
> Install/Update =| Efeenssy
instantMessaglng LicenseId Edition License Tags Expiration Date Packs Add...
& !.XFRYS -J2MSN-Y3MAS-RBK46 | STD 152T_J8F5C o 2020-12-31 e

» Java

4 Microkl
Architectures

Maming Convention

Platforms
Platforms in workspace
Updates . [Re;tore Defaultsl [ Apply ]
'f?;' [ oK ] I Cancel I
Fig. 4: License Manager View
3.3.3 License Check
The table below summarizes where the license is checked.
Application Run on | Build on De- | Documentation Link
Simulator vice
(Virtual
Device)
Standalone Application or Kernel Application | NO YES Run on the Device
Sandboxed Application NO NO Application Linking

3.3.4 Evaluation Licenses

This section should be considered when using Evaluation Architectures, which use software license keys. Amachine
UID needs to be provided to activate an Evaluation license on the MicroEJ Licenses Server. The machine UID isa 16
hexadecimal digits number.

Get your Machine UID

Retrieving the machine UID depends on the kind of MicroEJ Platform being evaluated.

If your MicroEJ Platform is already imported in Package Explorer and built with MicroEJ Module Manager, the Archi-
tecture has been automatically imported. The machine UID will be displayed when building a MicroEJ Standalone
Application on device.

[INFO ] Launching in Evaluation mode. Your UID is XXXXXXXXXXXXXXXX.
[ERROR] Invalid license check (No license found).

Otherwise, an Architecture or Platform should have been manually imported from the SDK preferences page. The
machine UID can be retrieved as follows:

« Goto Window > Preferences > MicroEJ ,
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« Select either Architectures or Platforms ,
« Click on one of the available Architectures or Platforms,

« Pressthe GetUID button to getthe machine UID.

Note: To accessthis GetUID option, at least one Evaluation Architecture or Platform must have been imported
before (see License Manager Overview).

Copy the UID. It will be needed when requesting a license.

& UID successfully generated @

f OB Your UID was successfully generated.
w

Your UID is:  |A856470297673E28

Fig. 5: Machine UID for Evaluation License

Request your Activation Key

« Go to MicroEJ Licenses Server https://license.microej.com.
+ Clickon Create anew account link.

« Create your account with a valid email address. You will receive a confirmation email a few minutes after.
Click on the confirmation link in the email and log in with your new account.

+ Clickon Activate a License .
« Set Product P/N: to 9PEVNLDBU6IJ.
« Set UID: to the machine UID you copied before.

« Clickon Activate .

« The license is being activated. You should receive your activation by email in less than 5 minutes. If not,
please contact our support team.

« Once received by email, save the attached zip file that contains your activation key.
Install the License Key

If your MicroEJ Platform is already imported in Package Explorer and built with MicroEJ Module Manager, the license
key zip file must be simply dropped to the ~/.microej/licenses/ directory (create it if it doesn’t exist).
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» ThisPC » Local Disk (C:) » Users » user » .microgj » licenses
MName Date modified Type Size
RBW2Z-X57RL-5ZYUE-K33DC.zip 30/09/2020 12:27 Compressed (zipp... 1 KB

Fig. 6: MicroEJ Shared Licenses Directory

Note: The SDK Preferences page will be automatically refreshed when building a MicroEJ Standalone Application
n devi

Otherwise, the license key must be installed as follows:
+ Go back to the SDK.

o Selectthe Window > Preferences > MicroEJ menu.

+ Press Add... .

« Browse the previously downloaded activation key archive file.

+ Press OK. A new license is successfully installed.

+ Go to Architectures sub-menu and check that all Architectures are now activated (green check).
« Your SDK is successfully activated.

If an error message appears, the license key could not be installed. (see section Troubleshooting). A license key can
be removed from the key-store by selecting it and by clickingon Remove button.

Troubleshooting
Consider this section when an error message appears while adding the Evaluation license key. Before contacting
our support team, please check the following conditions:

+ Key is corrupted (wrong copy/paste, missing characters, or extra characters)

+ Key has not been generated for the installed environment

+ Key has not been generated with the machine UID

+ Machine UID has changed since submitting license request and no longer matches license key

+ Keyhasnotbeen generated for one of the installed Architectures (no license manager able to load this license)
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= Invalid activation key w

The key could not be installed in this environment. Possible reasons are:

- key is corrupted,

- key is valid but does not match any available license manager(s), (Works for an
other edition),

- key has not been generated for this machine,

- old key version.

Fig. 7: Invalid License Key Error Message

3.3.5 Production Licenses

This section should be considered when using Production Architectures, which use hardware license keys stored
on a USB dongle.

= 12345678

Fig. 8: MicroEJ USB Dongle

Note: If your USB dongle has been provided to you by your sales representative and you don’t have received an
activation certificate by email, it may be a pre-activated dongle. Then you can skip the activation steps and directly
jump to the Check Activation on SDK section.

Request your Activation Key

+ Goto license.microej.com.
« Clickon Create a new account link.

« Create your account with a valid email address. You will receive a confirmation email a few minutes after.
Click on the confirmation link in the email and login with your new account.

« Clickon Activate a License .

« Set Product P/N: to The P/N on the activation certificate.
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« Enter your UID: serial number printed on the USB dongle label (8 alphanumeric char.).
+ Clickon Activate and check the confirmation message.

+ Click on Confirm your registration .

+ Enter the Registration Code provided on the activation certificate.

o Clickon Submit .

« Your Activation Key will be sent to you by email as soon as it is available (12 business hours max.).

Note: You can check the My Products page to verify your product registration status, the Activation Key avail-
ability, and download the Activation Key when available.

Once the Activation Key is available, download and save the Activation Key ZIP file to a local directory.

Activate your USB Dongle

This section contains instructions that will allow you to flash your USB dongle with the proper activation key.
You shall ensure that the following prerequisites are met :

« Your operating system is Windows

+ The USB dongle is plugged and recognized by your operating system (see Troubleshooting section)

« No more than one USB dongle is plugged into the computer while running the update tool

« The update tool is not launched from a network drive or a USB key

The activation key you downloaded is the one for the dongle UID on the sticker attached to the dongle (each
activation key is tied to the unique hardware ID of the dongle).

You can then proceed to the USB dongle update:
« Unzip the Activation Key file to a local directory
« Enter the directory just created by your ZIP extraction tool.
« Launch the executable program.

« Accept running the unsigned software if requested (Windows 10)
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update.exe

Publisher: Unknown
File origin: Hard drive on this computer

Show more details

« Clickonthe - button (no password needed)

[#] Update Tool

F.en[character string)

k.ey

Cancel

Fig. 9: Dongle Update Tool

+ On success, an Update successfully message shall appear. On failure, an Error key or no proper
rockey message may appear.
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update_E24C0785

l L Update successfully

oK

Fig. 10: Successful Dongle Update

Check Activation on SDK

Note: Production licenses will be shown only if at least one Production Architecture or Platform has been imported

before (see License Manager Overview).

» Go back to the SDK,

« Goto Window > Preferences > MicroEJ ,

« Goto Architectures or Platforms sub-menuand checkthatall Production Architectures or Platforms are

now activated (green check).

type filter text Platforms
EasyantdEclipse . Add or remove platforms.
> Help
. lceTea Platforms, Virtual Devices and Architectures:
> Install/Update . MName Version | Lic..
::;ta"tmessag'"g 143 FROM-KL46Z Jakarta Kickstart 135
. lava g LPG_ P\rchi‘tect:.'re:CMD
4 MicroEl [C14F 5TM: Hardware Part Number: Jakarta

14 5TM: Compilation Toolchain: CMO_ARMCC

Architectures mE=ul Name: KickStart

MNaming Conventior | Provider: 152T
Eg gm Version: 1.3.5
Platfarms in worksp 7 Core Engine Architecture: 14
Updates [f= STM:‘ Usage Level:[fev"]
[1€¥ STM: Technology Version: 1.6
-+ bm 143 vicr License Tag{S2T JeF5C]
Planning 63 vicp Build Label: 20TS0407-T647
» Plug-in Development Path: .microgrepositories\Full\1.64sd002
Fig. 11: Platform License Status OK
Troubleshooting

Select All
Deselect All
Import...
Uninstall

Get UID

This section contains instructions to check that your operating system correctly recognizes your USB dongle.

GNU/Linux Troubleshooting

For GNU/Linux Users (Ubuntu at least), by default, the dongle access has not been granted to the user, you have to

modify udev rules. Please create a /etc/udev/rules.d/91-usbhdongle.rules file with the following contents:
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ACTION!="add", GOTO="usbdongle_end"
SUBSYSTEM=="usb"”, GOTO="usbdongle_start”
SUBSYSTEMS=="usb", GOTO="usbdongle_start"”
GOTO="usbdongle_end"

LABEL="usbdongle_start"
ATTRS{idVendor}=="096e" , ATTRS{idProduct}=="0006" , MODE="0666"
LABEL="usbdongle_end"

Then, restart udev: /etc/init.d/udev restart

You can check that the device is recognized by running the 1susb command. The output of the command should
contain a line similar to the one below for each dongle: Bus 002 Device 003: ID 096e:0006 Feitian
Technologies, Inc.

Windows Troubleshooting

« If the dongle activation failed with No rockey message, check there is one and only one dongle recognized
with the following hardware ID :

HID\VID_Q96E&PID_0006&REV_0201

Go tothe Device Manager > Human Interface Devices and check amongthe USB InputDevice entries

thatthe Details > Hardwarelds property match the ID mentioned before.

« Ifthe dongle activation was successful with Update successfully message butthe license does not appear
in the SDK or is not updated, try to activate again by starting the executable with administrator privileges:

»  GF2N-HMLPM-94M55-Te3KG

s

Mame Date modified
Mj licensexml 18/03/2020 14:16

EY update.exe T
Open

m Run as administrator I

« If the following error message is thrown when building a MicroEJ Firmware, either the dongle plugged is a
verbatim dongle or it has not been successfully activated:

Invalid license check (Dongle found is not compatible).

VirtualBox Troubleshooting
In a VirtualBox virtual machine, USB drives must be enabled to be recognized correctly. Make sure to enable the
USB dongle by clicking on it in the VirtualBox menu Devices > USB .

To make this setting persistent, go to Devices > USB > USB Settings... and add the USB dongle in the
USB Devices Filters list.

3.3. Licenses 20



MicroEJ Documentation, Revision c72145fb

Remote USB Dongle Connection

When the dongle cannot be physically plugged to the machine running the SDK (cloud builds, virtualization, miss-
ing permissions, ...), it can be configured using USB redirection over IP network.

There are many hardware and software solutions available on the market. Among others, this has been tested with
https://www.net-usb.com/. Please contact our support team for more details.

3.4 Module Repositories

This chapter describes the module repositories provided by MicroEJ Corp.

3.4.1 Central Repository

The Central Repository is the module repository distributed and maintained by MicroEJ Corp. It contains a selection
of production-grade modules such as Libraries and Packs.

Use

By default, the SDK is configured to import modules from the online Central Repository.
You can manually browse the repository at https://repository.microej.com/modules/.

Before starting to develop production code, it is strongly recommended to import the repository to your local en-
vironment. Please follow the steps described at https://developer.microej.com/central-repository/.

Licensing

The Central Repository is a set of modules distributed under various software licenses, including the SDK EULA for
some of them. Please consult the LICENSE. txt file attached to each module.

Changelog
The Central Repository content is versioned. The overall changelog is available at https://repository.microej.com/

and describes modules additions or removals. For module content changes, please consult the CHANGELOG. md file
attached to each module.

Javadoc

To consult the APIs documentation (Javadoc) of all libraries available in the repository, please visit https://
repository.microej.com/javadoc/microej_5.x/apis/.

3.4.2 Developer Repository

The developer repository is an online repository hosted by MicrokJ Corp., contains community modules provided
“as-is”. It is similar to what Maven Central Repository are for hosting Java standard modules.

MicroEJ Corp. contributes to the developer repository in the following cases:

« Demos (Platforms, Firmware, Virtual Devices, Applications),
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+ Incubating Libraries,
« Former Central Repository versions,

« Hardware specific modules.

Use

By default, the SDK is configured to import modules from the developer repository'.

You can also manually browse the repository at https://forge.microej.com/artifactory/
microej-developer-repository-release/.

Before starting to develop production code, it is strongly recommended to transfer the desired modules to your
local environment by creating your own module repository copy.

Licensing

The developer repository is a set of modules distributed under various software licenses. Please consult the
LICENSE. txt file attached to each module.

Changelog

The developer repository is populated from multiple sources, thus there is no changelog for the whole repository
content as it is the case of the Central Repository.

Please consult the CHANGELOG.md file attached to each module.
Javadoc

To consult the APIs documentation (Javadoc) of libraries available in the developer repository, please consult the
javadoc attached to each module.

Community

The developer repository can host modules developed by the community. If your organization plan to develop
such module, please contact our support team to get dedicated credentials for publication.

3.4.3 Content Organization

The following table describes how are organized the modules natures within the repository.

1 Require SDK version 5.4.0 or higher.
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Table 1: Modules Organization

Organization Module Nature
Foundation Library API

ej.api, com.microej.api

) ) ) Architecture
com.microej.architecture -

Pack

com.microej.pack

Tool or Add-On processor
ej.tool, com.microej.tool

Any other Add-On Library

3.5 GitHub Repositories

Alarge number of examples, libraries, demos and tools are shared on MicroEJ GitHub account: https://github.com/
MicroEJ.

Most of these GitHub repositories contain projects ready to be imported in MicroEJ SDK.

3.5.1 Repository Import

This section explains the steps to import a Github repository in MicroEJ SDK, illustrated with the MWT Examples
repository.

Note: MicroEJ SDK Distribution includes the Eclipse plugin for Git.

First, from the GitHub page, copy the repository URI (HTTP address) from the dedicated field in the right menu
(highlighted in red):

O Why GitHub? Team Enterprise Explore Marketplace Pricing Search Sign in
B MicroEJ / Exam pleJava-MWT @ Watch | 2 Yrstar 1 % Fork | 0
<> Code Issues Pull requests Actions Projects Security Insights

% master = P 1branch  © 2 tags Go to file About

These projects provide examples
Q‘ privron Merge branch ‘develop’ into 'master’ .. BJ Clone @ for MWT

HTTPS  GitHub CLI
: - . o (5 [0 Readme
com.microej.example.mwt.basic ix api minor version @igne https://github.com/MicroEl/Exampleda | [9)
com.microej.example.mwt.butt...  Fix api minor version @ignc  Use Git or checkout with SVN using the web URL. s View license
com.microej.example.mwt.hello...  Fix api minor version @ignc
) Open with GitHub Desktop
. o ) ] Releases
com.microej.example.mwt.mvec Fix api minor version @ignc
com.microej.example.mwt.slidi...  Fix api minor version @ignc [ Download ZIP © 2tecs
[ .gh-copyright.template Move mwt example from foundation libraries @ignore_branc... 3 years ago
N e AR E A e e Forn o Packages
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In MicroEJ SDK, to clone and import the project from the remote Git repository into the MicroEJ workspace, select
File > Import > Git > Projectsfrom Git wizard.

= Import

Select

Import one or more projects from a Git Repository. @

Select an import wizard:

type filter text

= General

= C/C++

[= CV5
v [= Git

&1, Projects from Git

= Install
= MicroEl
= Plug-in Development
= Run/Debug
= Tasks
= Teamn
= XML

@ = Back Finish Cancel

Click Next , select CloneURI ,click Next and paste the remote repository address in the URI field. For
this repository, the address is https://github.com/MicroEJ/ExampleJava-MWT.git. If the HTTP address is a valid
repository, the other fields are filed automatically.
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® |mport Projects from Git
Source Git Repository GIT
Enter the location of the source repository. :_‘:n‘
Location
URJ: ?| https:.-"fgithul:l.cum.-"MicrDElexampI&lava-M‘."H"T.giﬂ | Lacal File...
Host: | github.com |
Repository path: | /Microbl/Examplelava-MWT.git |
Connection
Protocol: | https
Authentication
User | |
Password: | |
[ ]5tore in Secure Store
® = Back Finish Cancel

Click Next , selectthe master branch, click Next and acceptthe proposed Local Destination by clicking Next

once again.

3.5. GitHub Repositories
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® |mport Projects from Git

Local Destination

GIT

Configure the local storage location for Examplelava-MWT. E‘
Destination

Directory: | IC:\Users\user\git\Examplelava-MWT | Browse
Initial branch: K master v

[]Clene submodules

Configuration

Remote name: | crigin

® < Back Finish Cancel

Click Next once more and finally Finish . The Package Explorer view now contains the imported projects.

£ Package Explorer &2 ‘Eg Type Hierarchy % ™

w '[c‘.gl- com.microgj.example.mwt.basic [Examplelava-MWT master]
& src/main/java
B\ Module Dependencies module.ivy [*]
[ src
[%} CHANGELOG.md
5 LICEMSE.txt
ke moduleivy
[#} README.md
'[c".gl- com.microgj.example.mwt.button [Examplelava-MWT master]
'_,fé com.microg).example.rmwt.helloworld [Examplelava-MWT master]
'[;_—'é com.microgj.example.mwt.mve [Examplelava-MWT master]

1—.;‘- com.microg).example.mwt.slidingwidget [Examplelava-MWT master]
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If you want to import projects from another (GitHub) repository, you simply have to do the same procedure using
the Git URL of the desired repository.

3.5.2 MicroEJ GitHub Badges

MicroEJ GitHub Badges are badges embedded in a README at the root of the repository. They highlight the com-
patibilities of the repository at a quick glance with MicroEJ Architecture, MicroEJ SDK and Graphical User Interface
versions.

The color of the badge has the following meaning:
« Green means a current supported version:

+ Orange means a still supported version that will be deprecated in the future:

3.6 Workspaces and MicroEJ Repositories

When starting the SDK, it prompts you to select the last used workspace or a default workspace on the first run. A
workspace is a main folder where to find a set of projects containing MicroEJ source code.

When loading a new workspace, the SDK prompts for the location of the MicroEJ repository, where Architectures,
Platforms or Virtual Devices will be imported. By default, the SDK suggests to point to the default MicroEJ reposi-
tory on your operating system, located at ${user.home}/.microej/repositories/[version].You can selectan
alternative location. Another common practice is to define a local repository relative to the workspace, so that the
workspace is self-contained, without external file system links and can be shared within a zip file.

3.7 SDKVersion

In the SDK, go to Help > About MicroEJ SDK menu.

In case of SDK 4.1.x,the SDK version is directly displayed, suchas 4.1.5:
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o About MicroE) ® SDK

MicroEl® SDE

Version 4.1.5

Copyright ©2016-2018 1527 5.A. All Rights Reserved.

Use of this program is subject to Microk License Agreement.

MicroB)® SDK is built on Eclipse, licensed under the terms of the Commen Public
r License (CPL).

MicroB)® 50K and the MicreE) logos are tradernarks of MicroE) 5.4,

CSPZIOP I BB DFH

® Installation Details

In case of SDK 5. x, the value displayed is the SDK distribution, such as 19.05 or 20.07:

= phout MicroE)® SDE

MicroEl® SDK

Dist. 20.07

Copyright ©2012-2020 Microk) Cerp. All Rights Reserved.

Use of this program is subject to MicroB) License Agreement.

MicroEl® 50K is built on Eclipse, licensed under the terms of the Common
Public License (CPL).

MicroEl® 5DK and the MicrokEl logos are trademarks of MicroBl Corp.

CSCSEOF oI & w

® Installation Details

To retrieve the SDK version that is currently installed in this distribution, proceed with the following steps:
 Clickonthe Installation Details button,
« Clickonthe Installed Software tab,

« Retrieve the version of entry named MicroEJ SDK.
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‘& MicroE) ® SDK Installation Details

Installed Software  |nstallation History Features Plug-ins Configuration

MNarne Version Id Provider
[ C/C++ Development Toeols 5DK 0.4,3.201802261533  org.eclipse.cdt.sdk.feature.group Eclipse COT
@; C/C++ GCC Cross Compiler Support 0.4.3.201802261533  erg.eclipse.cdt.build.crossgec.feature.group  Eclipse COT
@: C/C++ GDB Hardware Debugging 0.4.3.201802261533  erg.eclipse.cdt.debug.gdbijtag feature.gro...  Eclipse CDT
(- Eclipse Checkstyle Plug-in 6.8.0.201507251301  net.sf.eclipsecs.feature.group http://eclipse-cs.sf.
@: Eclipse Runner Feature 134 com.eclipserunnerfeature.feature.group Eclipse Runner Tean
EE: Eclipse SDK 4.7.3.M20180330-06... org.eclipse.sdk.ide Eclipse.org
Eﬁ Eclipse XML Editors and Tools 3.9.2.:201803221834  erg.eclipse.wstxml_uifeaturefeature.group Eclipse Web Tools P
[{f- Git integration for Eclipse 4.9.2.201712130930-r  org.eclipse.eqgit.feature.group Eclipse EGit
[{f- JAutodoc 1.13.0 net.sf jautodec.feature feature.group Martin Kesting
@ Markdown Editor 0.2.3 markdown.editor.feature.feature.group Winterwell
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3.8 MicroEJ Module Manager

3.8.1 Introduction

Modern electronic device design involves many parts and teams to collaborate to finally obtain a product to be sold
on its market. MicroEJ encourages modular design which involves various stake holders: hardware engineers, UX
designers, graphic designers, drivers/BSP engineers, software engineers, etc.

Modular design is a design technique that emphasizes separating the functionality of an application into inde-
pendent, interchangeable modules. Each module contains everything necessary to execute only one aspect of
the desired functionality. In order to have team members collaborate internally within their team and with other
teams, MicroEJ provides a powerful modular design concept, with smart module dependencies, controlled by the
MicroEJ Module Manager (MMM). MMM frees engineers from the difficult task of computing module dependencies.
Engineers specify the bare minimum description of the module requirements.

The following schema introduces the main concepts detailed in this chapter.
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Fig.12: MMM Overview

MMM is based on the following tools:
« Apache lvy (http://ant.apache.org/ivy) for dependencies resolution and module publication;

« Apache EasyAnt (https://ant.apache.org/easyant/history/trunk/reference.html) for module build from
source code.

3.8.2 Specification

MMM provides a non ambiguous semantic for dependencies resolution. Please consult the MMM specification
available on https://developer.microej.com/packages/documentation/TLT-0831-SPE-MicroEJModuleManager-2.
0-E.pdf.

3.8.3 Module Project Skeleton

In the SDK, a new MicroEJ module project is created as follows:

+ Select File > New > Project... ,

« Select MicroEJ > Module Project ',

« Fill the module information (project name, module organization, name and revision),

+ Select one of the suggested skeletons depending on the desired module nature,

« Clickon Finish .

11f using SDK versions lower than 5.2.0, please refer to the following section.
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The project is created and a set of files and directories are generated from the selected skeleton.

Note: When an empty Eclipse project already exists or when the skeleton has to be created within an existing
directory, the MicroEJ module is created as follows:

« In the Package Explorer, click on the parent project or directory,

« Select File > New > Other... ,

+ Select EasyAnt > EasyAnt Skeleton .

3.8.4 Module Description File

Amodule descriptionfileis an Ivy configuration file named module. ivy, located at the root of each MicroEJ module
project. It describes the module nature (also called build type) and dependencies to other modules.

<ivy-module version="2.0" xmlns:ea="http://www.easyant.org” xmlns:m="http://ant.apache.org/ivy/extra”
xmlns:ej="https://developer.microej.com” ej:version="2.0.0">
<info organisation="[organisation]” module="[name]" status="integration” revision="[version]">
<ea:build organisation="com.is2t.easyant.buildtypes” module="[buildtype_name]” revision=
—"[buildtype_version]">
<ea:property name="[buildoption_name]"” value="[buildoption_value]"/>
</ea:build>
</info>

<configurations defaultconfmapping="default->default;provided->provided">
<conf name="default” visibility="public"/>
<conf name="provided" visibility="public"/>
<conf name="documentation” visibility="public"/>
<conf name="source" visibility="public"/>
<conf name="dist"” visibility="public"/>
<conf name="test"” visibility="private"/>
</configurations>

<publications>
</publications>

<dependencies>
<dependency org="[dep_organisation]” name="[dep_name]” rev="[dep_version]"/>

</dependencies>
</ivy-module>

Enable MMM Semantic

The MMM semantic is enabled in a module by adding the MicroEJ XML namespace and the ej:version attribute
inthe ivy-module node:

<ivy-module xmlns:ej="https://developer.microej.com” ej:version="2.0.0">

Note: Multiple namespaces can be declared in the ivy-module node.

MMM semantic is enabled in the module created with the Module Project Skeleton.
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Module Dependencies

Module dependencies are added to the dependencies node as follow:

<dependencies>
<dependency org="[dep_organisation]” name="[dep_name]"” rev="[dep_version]"/>
</dependencies>

When no matching rule is specified, the default matching rule is compatible.

Dependency Matching Rule

The following matching rules are specified by MMM:

Name Range Notation Semantic

compatible [M.m.p-RC, (M+1).0.0-RC][ Equal or up to next major version. Default if
not set.

equivalent [M.m.p-RC, M.(m+1).0-RC [ Equal or up to next minor version

greaterOrEqual [M.m.p-RC, oo Equal or greater versions

perfect [M.m.p-RC, M.m.(p+1)-RC[ Exact match (strong dependency)

Set the matching rule of a given dependency with ej:match="matching rule”.Forexample:

<dependency org="[dep_organisation]” name="[dep_name]” rev="[dep_version]" ej:match="perfect” />

Dependency Visibility

« Adependency declared public is transitively resolved by upper modules. The default when not set.
« Adependency declared private isonly used by the module itself, typically for:

- Bundling the content into the module

- Testing the module

The visibility is set by the configurations declared in the configurations node. For example:

<configurations defaultconfmapping="default->default;provided->provided">
<conf name="[conf_name]” visibility="private"/>
</configurations>

The configuration of a dependency is specified by setting the conf attribute, for example:

<dependency org="[dep_organisation]” name="[dep_name]"” rev="[dep_version]"” conf="[conf_name]->x" />

Automatic Update Before Resolution

The Easyant plugin ivy-update can be used to automatically update the version (attribute rev ) of every module
dependencies declared.

<info organisation="[organisation]” module="[name]"” status="integration” revision="[version]">
<ea:plugin org="com.is2t.easyant.plugins” name="ivy-update"” revision="1.+" />
</info>
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When the plugin is enabled, for each module dependency, MMM will check the version declared in the module file
and update it to the highest version available which satisfies the matching rule of the dependency.

Build Options

MMM build options can be set with:

<ea:property name="[buildoption_name]” value="[buildoption_value]"/>

The following build options are globally available:

Table 2: Build Options

Property | Description Default Value
Name

Path of the build directory target~.
target ${basedir}/target~

Refer to the documentation of Module Natures for specific build options.

3.8.5 MicroEJ Module Manager Configuration

By default, when starting an empty workspace, the SDK is configured to import dependencies from MicroEJ Central
Repository and to publish built modules to a local directory. The repository configuration is stored in a settings file (
ivysettings.xml), and the default oneis located at $USER_HOME\ .microej\microej-ivysettings-[VERSION].
xml

Preferences Page

The MMM preferences page in the SDK is available at Window > Preferences > MicroEJ > Module Manager
1
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Fig. 13: MMM Preferences Page

This page allows to configure the following elements:

1.
2.
3.

Settings File: the file describing how to connect module repositories. See the settings file section.

Options: files declaring MMM options. See the Options section.

Use Module repository as Build repository : the settings file for connecting the build repository in
place of the one bundled in the SDK. This option shall not be enabled by default and is reserved for advanced
configuration.

Build repository Settings File:the settings file for connecting the build repository in place of the one
bundled in the SDK. This option is automatically initialized the first time the SDK is launched. It shall not be
modified by default and is reserved for advanced configuration.

Set verbose mode : to enable advanced debug traces when building a module.

Runtime JRE :the Java Runtime Environment that executes the build process.

Max build history size:the maximum number of previous builds available in Build Module shortcut
list:

® workspaceRepository -

File Edit Source Refactor Mavigate Search Project  Run

cruoiv[@]Jeis-0-a-i@e-

4 Package Explorer 33 | ) Build Selected Module (Ctrl+Alt-C, E)
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Settings File

The settings file is an XML file that describes how MMM connects local or online module repositories. The file format
is described in Apache lvy documentation.

To configure MMM to a custom settings file (usually from an offline repository):

1. Set Settings file toacustom ivysettings.xml settings file',

2. Clickon Apply and Close button

If the workspace is not empty, it is recommended to trigger a full resolution and rebuild all the projects using this
new repository configuration:

1. Clean caches

« In the Package Explorer, right-click on a project;
« Select Ivy > Cleanallcaches .
2. Resolve projects using the new repository

To resolve all the workspace projects, click on the Resolve All button in the toolbar:

'® workspaceRepository -

File Edit Source Refactor Mavigate Searc

A | B4~ (

To only resolve a subset of the workspace projects:

« In the Package Explorer, select the desired projects,
+ Right-click on a project and select lvy > Clean all caches .
3. Trigger Add-On Library processors for automatically generated source code

+ Select Project > Clean... ,
+ Select Clean all projects |,

o Clickon Clean button.

Options

Options can be used to parameterize a module description file or a settings file. Options are declared as key/value
pairsin a standard Java properties file, and are expanded using the ${my_property} notation.

Atypical usage in a settings file is for extracting repository server credentials, such as HTTP Basic access authenti-
cation:

1. Declare options in a properties file
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[E| credentials.properties &

1# User specific credentials
2 artifactory.username=myusername
3 artifactory.password=AKCKLzp2JHRLDyFvmTPMXocXiiU1Cnad7eidUcCO1ERSUdgIrIu24ZTYieXaCwuMaIWykjCD9

4

2. Register this property file to MMM options

Options

Property files: | Sfworkspace_loctest/credentials.properties}

3. Usethis option in a settings file

38
39 <credentials host="artifactory.corp” realm="Artifactory Realm” username="${artifactory.username}” passwd="$§{artifactory.password}” />
4/

Atypical usage in a module description file is for factorizing dependency versions across multiple modules projects:

1. Declare an option in a properties file

=| versions.properties &3

=l
14# Specify the EDC wersion used in this workspace
2 edc.version=1.3.8

pu

2. Register this property file to MMM options

Options

Property files: | S{workspace_loc:test/versions.properties)

3. Use this option in a module description file

22 <dependencies:

23 ol--

24 Use the EDC version defined by MMM configuration

25 -

26 <dependency org="ej.api" name="edc" rev="%{edc.version}" /»
27 </dependencies:

28 ¢/ivy-module:
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Resolution Logs

Resolution logs of module projects imported in the workspace are available from the console view:
« Select Windows > ShowView > Console ,
« In the Console view, click on the console window icon and select vy console :

Bl Consale 532

Mo consoles to display at this time.

4

Omfle © ol
i
0

1 New Console View

2 Addon Processor Console
3 C/C++ Build Console
4 Host 05G1 Console

5 vy Console

b Java Stack Trace Console

7 SenarLint Conscle

'

To enable the verbose mode:

« Inthe Ivyconsole view, click on the debugicon and select debug instead of info (defaults):

& Console i3 ﬂ#;gv| =NE =

vy Error
| found ej.api#edc;1.3.3 in aaaa-ivyde-workspace-chain-resclver (@-server)

[1.3.3] ej.apiftedc;[1.3.3-RC,1.3.4-RC[ warning
:: resclution report :: resclve 821ms :: artifacts dl 9ms » info
_____________________________________________________________________ .
[ | modules || artifacts | verhosE
| conf | number| search|dwnlded|evicted|| number|dwnlded| | debug
| default | » | e | & | @ || © | @& | IvyDE error
| provided | | e | @ | e || 1 | @ | lvyDE warning
| platform | & | e | & | e || e | e | ]
Py +  |wyDE info
IvyDE verbose
IvyDE debug

This triggers the full workspace resolution with verbose mode enabled.

3.8.6 Module Build

In the SDK, the build of a MicroEJ module project can be started as follows:

« In the Package Explorer, right-click on the project,

« Select Build Module .
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Fig. 14: Module Build

The build of a module can take time depending on
« the module nature to build,
« the number and the size of module dependencies to download,
« the repository connection bandwidth, ...

The module build logs are redirected to the integrated console.

Alternatively, the build of a MicroEJ module project can be started from the build history:
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Fig. 15: Module Build History

3.8.7 Build Kit

The Module Manager Build Kit is a consistent set of tools, scripts, configuration and artifacts required for build-
ing modules in command-line mode. Starting from SDK 5.4.0, it also contains a Command Line Interface (CLI).
The Build Kit allows to work in headless mode (e.g. in a terminal) and to build your modules using a Continuous
Integration tool.

The Build Kit is bundled with the SDK and can be exported using the following steps:*

+ Select File > Export > MicroEJ > Module Manager Build Kit ,
+ Choose an empty Target directory ,

+ Clickonthe Finish button.
Once the Build Kit is fully exported, the directory content shall look like:

/
— bin
F mmm
L mmm.bat
— conf
— lib
— microej-build-repository
F ant-contrib
F com
t ivysettings.xml
— microej-module-repository
L ivysettings.xml
- release.properties

« Add the bin directory of the Build Kit directory to the PATH environment variable of your machine.

« Make sure the JAVA_HOME environment variable is set and points to a JRE/JDK installation or that java
executable isin the PATH environment variable (Java 8 is required)

+ Confirm that the installation works fine by executing the command mmm --version . The result should
display the MMM CLI version.

The mmm tool can run on any supported Operating Systems:

2 |If using SDK versions lower than 5. 4.0, please refer to the following section.

3.8. MicroEJ Module Manager 39



MicroEJ Documentation, Revision c72145fb

+ on Windows, either in the command prompt using the Windows batch script mmm.bat orin MinGW environ-
ments such as Git BASH using the bash script mmm .

» on macOS and Linux distributions using the bash script mmm.

The build repository (microej-build-repository directory) contains scripts and tools for building modules. It is
specific to a SDK version and shall not be modified by default.

The module repository ( microej-module-repository directory) contains a default Settings File for importing
modules from Central Repository and this local repository (modules that are locally built will be published to this
directory). You can override with custom settings or by extracting an offline repository.

To go further with headless builds, please consult the next chapter for command line builds, and this tutorial to
setup MicroEJ modules build in continuous integration environments.

3.8.8 Command Line Interface
Starting from version 5.4.0, the SDK provides a Command Line Interface (CLI). Please refer to the Build Kit section
for installation details.
The following operations are supported by the MMM CLI:
« creating a module project
« cleaning a module project
+ building a module project
« running a MicroEJ Application project on the Simulator

+ publishing a module in a module repository

Usage

In order to use the MMM CLI for your project:
+ go to the root directory of your project

+ run the following command

mmm [OPTION]... [COMMAND]

where COMMAND is the command to execute (for example mmm build). The available commands are:
« help:display help information about the specified command
« init:create a new project
« clean: clean the project
« build: build the project
+ publish: build the project and publish the module
« run: run the MicroEJ Application project on the Simulator
The available options are:
+ ——help (-h): show the help message and exit
« —-version (-V): printversion information and exit

o —-build-repository-settings-file (-b): path of the lvy settings file for build scripts and tools. Defaults
to ${CLI_HOME}/microej-build-repository/ivysettings.xml.
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« ——module-repository-settings-file ( -r ): path of the Ivy settings file for modules. Defaults to
${CLI_HOME}/microej-module-repository/ivysettings.xml.

« ——ivy-file (-f): path of the project’s vy file. Defaults to ./module.ivy.
« ——verbose (-v): verbose mode. Disabled by default. Add this option to enable verbose mode.
« -Dxxx=yyy : any additional option passed as system properties.

When no command is specified, MMM CLI executes Easyant with custom targets using the --targets (-t ) option
(defaults to clean,package).

Shared configuration

In order to share configuration across several projects, these parameters can be defined in the file ${user.home}/
.microej/.mmmconfig . This file uses the TOML format. Parameters names are the same than the ones passed
as system properties, except the character _ is used as a separator instead of - . The parameters defined in the
[options] section are passed as system properties. Here is an example:

build_repository_settings_file = "/home/johndoe/ivy-configuration/ivysettings.xml”
module_repository_settings_file = "/home/johndoe/ivy-configuration/ivysettings.xml”
ivy_file = "ivy.xml”
[options]
my.first.property = "valuel”
my.second.property = "value2”

Warning:

« TOML values must be surrounded with double quotes

« Backslash characters ( \ ) must be doubled (for example a Windows path
C:\\Users\\johndoe\\ivysettings.xml)

Command line options take precedence over those defined in the configuration file. So if the same option is defined
in both locations, the value defined in the command line is used.

Commands
init
Thecommand init creates a new project (executes Easyant with skeleton:generate target). The skeleton and
project information must be passed with the following system properties:
+ skeleton.org: organisation of the skeleton module. Defaults to com.is2t.easyant.skeletons.
« skeleton.module : name of the skeleton module. Mandatory, defaults to microej-javalib.

+ skeleton.rev : revision of the skeleton module. Mandatory, defaults to + (meaning the latest released
version).

« project.org: organisation of the project module. Mandatory, defaults to com.mycompany .
« project.module : name of the project module. Mandatory, defaults to myproject.
« project.rev: revision of the project module. Defaultsto 0.1.0.

« skeleton.target.dir: relative path of the projectdirectory (created ifit does not exist). Mandatory, defaults
to the current directory.
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For example

mmm init -Dskeleton.org=com.is2t.easyant.skeletons -Dskeleton.module=microej-javalib -Dskeleton.rev=4.2.
—8 -Dproject.org=com.mycompany -Dproject.module=myproject -Dproject.rev=1.0.0 -Dskeleton.target.
—dir=myproject

If one of these properties is missing, it will be asked in interactive mode:

$ mmm init -Dskeleton.org=com.is2t.easyant.skeletons -Dskeleton.module=microej-javalib -Dskeleton.rev=4.
2.8 -Dproject.org=com.mycompany -Dproject.module=myproject -Dproject.rev=1.0.0

-skeleton:check-generate:

[input] skipping input as property skeleton.org has already been set.

[input] skipping input as property skeleton.module has already been set.

[input] skipping input as property skeleton.rev has already been set.

[input] The path where the skeleton project will be unzipped [/home/tdelhomenie/microej/working/
—skeleton]

To force the non-interactive mode, the property skeleton.interactive.mode must be setto false. In non-
interactive mode the default values are used for missing non-mandatory properties, and the creation fails if manda-
tory properties are missing.

$ mmm init -Dskeleton.org=com.is2t.easyant.skeletons -Dskeleton.module=microej-javalib -Dskeleton.rev=4.
2.8 -Dproject.org=com.mycompany -Dskeleton.target.dir=myproject -Dskeleton.interactive.mode=false

* Problem Report:

expected property 'project.module': Module name of YOUR project

clean

The command clean cleans the project (executes Easyant with clean target). For example

mmm clean

cleans the project.
build

The command build builds the project (executes Easyant with clean,package targets). For example

mmm build -f ivy.xml -v

builds the project with the Ivy file ivy.xml and in verbose mode.
publish

The command publish buildsthe project and publishes the module. This command accepts the publication target
as a parameter, amongst these values:

+ local (defaultvalue): executesthe clean,publish-local Easyanttarget, which publishes the project with
the resolver referenced by the property local.resolver inthe Settings File.

+ shared: executesthe clean,publish-shared Easyant target, which publishes the project with the resolver
referenced by the property shared.resolver inthe Settings File.
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+ release: executesthe clean,release Easyant target, which publishes the project with the resolver refer-
enced by the property release.resolver the Settings File.

For example

mmm publish local

builds the project and publishes the module using the local resolver.
run

The command run runs the application on the Simulator (executes Easyant with compile,simulator:run tar-
gets). It has the following requirements:

« to run on the Simulator, the project must be configured with one of the following Module Natures:

- Sandboxed Application

- Standalone Application

- Add-On Library

the property application.main.class must be set to the Fully Qualified Name of the application main
class (for example com.mycompany.Main)

a MicroEJ Platform must be provided (see Platform Selection section)

Application Options must be defined using properties file underin the build directory (see Using a Properties
File section)

the module must have been built once before running the Simulator. So the mmm build command must be
executed before running the Simulator the first time or after a project clean (mmm clean command).

Note: The next times, it is not required to rebuild the module if source code files have been modified. The
contentof src/main/java and src/main/resources folders are automatically compiled by mmm run com-
mand before running the Simulator.

For example

mmm run -D"platform-loader.target.platform.file"="/path/to/the/platform.zip”

runs the application on the given platform.

The Simulator can be launched in debug mode by setting the property execution.mode of the application file
build/commons.properties to debug:

execution.mode=debug

The debug port can be defined with the property debug.port. Go to Simulator Debug options section for more
details.

help

The command help displays the help for acommand. For example

mmm help run

displays the help of the command run.
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3.8.9 Troubleshooting

Unresolved Dependency

If the following message appears when resolving module dependencies:

:: problems summary ::
;. WARNINGS
module not found: com.mycompany#mymodule;[M.m.p-RC,M.m. (p+1)-RC[

First, check that either a released module com.mycompany/mymodule/M.m.p or a snapshot module com.
mycompany/mymodule/M.m.p-RCYYYYMMDD-HHMM exists in your module repository.

« If the module does not exist,

- ifitis declared as a direct dependency, the module repository is not compatible with your source code.
You can either check if an other module version is available in the repository or add the missing module
to the repository.

- otherwise, this is likely a missing transitive module dependency. The module repository is not consis-
tent. Check the module repository settings file and that consistency check has been enabled during the
module repository build (see Configure Consistency Check).

« If the module exists, this may be either a configuration issue or a network connection error. We have to find
the cause in the resolution logs.

Note:
The activation of the verbose mode depends on how the resolution has been launched:
- if the error occurs during workspace resolution, configure the verbose mode of resolution logs,

- if the error occurs while building a module from workspace, check the verbose mode option in prefer-
ences page,

- if the error occurs while building a module from command line, set the verbose mode option in com-
mand line options.

For URL repositories, find:

trying https://[MY_REPOSITORY_URL]/[MY_REPOSITORY_NAME]/com.mycompany/mymodule/
tried https://[MY_REPOSITORY_URL]/[MY_REPOSITORY_NAME]/com.mycompany/mymodule/

For filesystem repository, find:

trying [MY_REPOSITORY_PATHJ]/com.mycompany/mymodule/
tried [MY_REPOSITORY_PATH]/com.mycompany/mymodule/
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If your module repository URL or filesystem path does not appear, check your settings file. This is likely a
missing resolver.

Otherwise, if your module repository is an URL, this may be a network connection error between MMM (the
client) and the module repository (the server). First, check for Invalid Certificate issue.

Otherwise, the next step is to debug at the HTTP level:

HTTP response status: [RESPONSE_CODE] url=https://[MY_REPOSITORY_URL]/com.mycompany/mymodule/
CLIENT ERROR: Not Found url=https://[MY_REPOSITORY_URL]/com.mycompany/mymodule/
Depending on the HTTP error code:

- 4071 Unauthorized: check your settings file credentials configuration.

- 404 Not Found: add the following options to log raw HTTP traffic:

-Dorg.apache.commons. logging.Log=org.apache.commons.logging.impl.SimplelLog -Dorg.apache.
—commons. logging.simplelog.showdatetime=true -Dorg.apache.commons.logging.simplelog.log.org.
—apache.http=DEBUG -Dorg.apache.commons.logging.simplelog.log.org.apache.http.wire=ERROR

Particularly, vy requires the HTTP HEAD request which may be disabled by some servers.

Invalid Certificate

If the following message appears when resolving module dependencies:

HttpClientHandler: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.
—provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested.
—target url=[artifactory address]

The server may use a self-signed certificate that has to be added to the JRE trust store that is running MicroEJ
Module Manager. Here is a way to do it:
1. Install Keystore Explorer,

2. Start Keystore Explorer, and open file [JRE_HOME]/lib/security/cacerts or [JDK_HOME]/jre/lib/
security/cacerts with the password changeit . You may not have the right to modify this file. Edit rights
if needed before opening it,

3. Clickon Tools ,then Import Trusted Certificate ,

4. Select your certificate,
5. Savethe cacerts file.

If the problem still occurs, add the following option to enable SSL protocol traces:

-Djavax.net.debug=all

This is useful to detect advanced errors such as:
« invalid certificate chain: one of root or intermediate certificate may be missing in the JRE/JDK truststore.
+ TLS protocol negotiation issues.

Target “simulator:run” does not exist

If the following message appears when executing the mmm run command:
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* Problem Report:

Target "simulator:run” does not exist in the project "my-app”.

it means that the command run is not supported by the build type declared by your module project. Make sure it
is one of the following ones:

« build-application,withversion 7.1.0 or higher
« build-microej-javalib, with version 4.2.0 or higher

« build-firmware-singleapp, with version 1.3.0 or higher

3.8.10 Meta Build

A Meta Build is a module allowing to build other modules. It is typically used in a project containing multiple mod-
ules. The Meta Build module serves as an entry point to build all the modules of the project.

Meta Build creation

« Inthe SDK, select File > New > Module Project .

File Edit Mavigate Search Project Run Window Help

MNew Alt+Shift+N > 2% Sandboxed Application Project
Open File.. % Standalone Application Project !
£ Open Projects from File System... £ Add-On Library Project
Recent Files > ™ Module Project
B Platform Project
<llzzz i Sy @ Front Panel Project [
Close All Editors Ctrl+Shift+W =i Project..

Fig. 16: New Meta Build Project

« Fillin the fields Project name, Organization, Module and Revision,then select the Skeleton named
microej-meta-build

« Clickon Finish . Atemplate project is automatically created and ready to use.

Meta Build configuration
The main element to configure in a meta build is the list of modules to build. This is done in 2 files, located at the
root folder:

« public.modules.list which contains the list of the modules relative paths to build and publish.

« private.modules.list which contains the list of the modules relative paths to build. These modules are
not published but only stored in a private and local repository in order to be fetched by the public modules.

The format of these files is a plain text file with one module path by line, for example:
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modulel
module2
module3

These paths are relative to the meta build root folder, which is set by default to the parent folder of the meta build
module ( .. ). For this reason, a meta build module is generally created at the same level of the other modules to
build. Here is a typical structure of a meta build:

/
— modulel

': module.ivy

— module?

': module.ivy

— module3

': module.ivy

. metabuild

E private.modules.list

public.modules.list
module.ivy

The modaules build order is calculated based on the dependency information. If a module is a dependency of an-
other module, it is built first.

For a complete list of configuration options, please refer to Meta Build Module Nature section.

3.8.11 Former SDK Versions (lower than 5.2.0)

This section describes MMM configuration elements for SDK versions lower than 5.2.0.

New MicroEJ Module Project

The New MicroEJ Module Project wizard is availableat File > New > Project... , EasyAnt > EasyAnt Project

Preferences Pages

MMM Preferences Pages are located in two dedicated pages. The following pictures show the options mapping
using the same options numbers declared in Preferences Page.

lvy Preferences Page

The lvy Preferences Page is available at Window > Preferences > Ivy > Settings .
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® preferences

type filter text Settings le=T 4 - -
General A
Ant [ reload the settings only on demand
C/C++
Checkstyle
Copyright Default | Workspace... | | File System... | Variables...
EasyantdEclipse

(l) Ivy settings path: | CA\Users\user\. microgj\microej-ivysettings-3xml |

Help Ivy user dir: ‘ |
lceTea
Install/Update

Workspace... | | File System... | Variables...

Instant Messaging .
v vy (2) Property files: | S{workspace_loc:easyant-build-component/ivy/ivyDE.properties} Edit
Ad d S{workspace_loc:easyant-build-component/ivy/ivyDE_windows.properties}
vancet
Add
Classpath Container
Security Remove
Settings
Source/Javadoc Map Up
Workspace Resolver
D
XML Editor o
Java
JavaScript
< i > v Restore Defaults Apply

@ Apply and Close Cancel

Easyant Preferences Page

The Easyant Preferences Page is available at Window > Preferences > EasyAnt4Eclipse .

® Preferences

type filter text EasyantdEclipse &~ .-
f\:: erel Set preferences for EasyAnt4Eclipse.
C/Crr (5) [ Set verbose mode
Checkstyle (3) |:| Use lvyDE preferences for lvy settings path
Copyright (4) Ivy settings path: | C:\Program Files\MicroENMicroEJ-SDK-19.05\rcp\configuration\org.eclipse.osgi\ 54610\ cp\repositorieshivysettings.xml Browse...
Easyant4Eclipse
Help (7) Max build history size: I 5
IceTea (6) Runtime JRE jre1.8.0_221 .

Install/Update
Instant Messaging

v vy
Advanced
Classpath Container
Security
Settings
< 2 > ’ Restore Defaults Apply

@ Apply and Close Cancel

Build Kit

+ Create an empty directory (e.g. mmm_sdk_[version]_build_kit),

+ Locate your SDK installation plugins directory (by default, C:\Program Files\MicroEJ\MicroEJ
SDK-[version]\rcp\plugins on Windows OS),

» Openthefile com.is2t.eclipse.plugin.easyant4e_[version]. jar with an archive manager,
« Extract the directory 1ib to the target directory,

« Openthefile com.is2t.eclipse.plugin.easyant4e.offlinerepo_[version].jar with an archive man-
ager,

+ Navigate to directory repositories,
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« Extract the file named microej-build-repository.zip for SDK 5.x or is2t_repo.zip for SDK 4.1.x to
the target directory.

3.8.12 Former SDK Versions (from 5.2.0 to 5.3.x)
Build Kit

The Build Kit is bundled with the SDK and can be exported using the following steps:

+ Select File > Export > MicroEJ > Module Manager Build Kit ,
+ Choose an empty Target directory ,

+ Clickonthe Finish button.
Once the Build Kit is fully exported, the directory content shall look like:
w = sdk_5.2.0 build_kit
w [~ ant

= lib
microej-build-repository.zip

3.9 Release Notes

Starting from SDK version 5.0.0, Architectures are distributed separately from the Integrated Development Envi-
ronment. Evaluation Architectures can be downloaded from the Architectures Repository.

The SDK is now packaged into an Eclipse P2 repository (https://repository.microej.com/p2/sdk), allowing partial
updates and installation on any compatible Eclipse version. The historical version ( 5 ) of MicroEJ is reused for the
P2 repository delivery.

MicroEJ Corp. continues to regularly build all-in-one packages, called Distributions, including the SDK and ded-
icated OS installers. This distribution has a separate versioning, which follows modern convention: [YY].[MM]

3.10 SDK Distribution Changelog

3.10.1 [21.11] - 2021-11-15
NOTE: This release prepares for a future JRE 11 support. However, the only officially supported JRE version is still
JRE 8. Please refer to System Requirements for more details.

« Included SDK 5.5.0.

« Updated installer to accept both JRE 8 and JRE 11.

« Fixed error Error while loading manipulator when installing SDK updates on MacOS.

+ Updated End User License Agreement.
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3.10.2 [21.03] - 2021-03-25

+ Included SDK 5.4.0.
« Updated End User License Agreement.
KNOWN ISSUES:

+ The following error occurs when installing an SDK update on MacOS:

IMESSAGE Error while loading manipulator.
ISTACK @
java.lang.IllegalStateException: Error while loading manipulator.

at org.eclipse.equinox.internal.p2.touchpoint.eclipse.LazyManipulator.
—loadDelegate(LazyManipulator. java:64)

at org.eclipse.equinox.internal.p2.touchpoint.eclipse.LazyManipulator.
—getConfigData(LazyManipulator. java:117)

at org.eclipse.equinox.internal.p2.touchpoint.eclipse.actions.UninstallBundleAction.
—uninstallBundle(UninstallBundleAction. java:57)

at org.eclipse.equinox.internal.p2.touchpoint.eclipse.actions.UninstallBundleAction.
—execute(UninstallBundleAction. java:33)

at org.eclipse.equinox.internal.p2.engine.ParameterizedProvisioningAction.
—execute(ParameterizedProvisioningAction. java:42)

at org.eclipse.equinox.internal.p2.engine.Phase.mainPerform(Phase. java:186)

at org.eclipse.equinox.internal.p2.engine.Phase.perform(Phase. java:99)

at org.eclipse.equinox.internal.p2.engine.PhaseSet.perform(PhaseSet. java:50)

at org.eclipse.equinox.internal.p2.engine.Engine.perform(Engine.java:80)

at org.eclipse.equinox.internal.p2.engine.Engine.perform(Engine. java:48)

at org.eclipse.equinox.p2.operations.ProvisioningSession.
—performProvisioningPlan(ProvisioningSession. java:181)

at org.eclipse.equinox.p2.operations.ProfileModificationJob.
—runModal (ProfileModificationJob. java:76)

at org.eclipse.equinox.p2.operations.ProvisioningJob.run(ProvisioningJob. java:190)

at org.eclipse.core.internal. jobs.Worker.run(Worker. java:63)

The workaround is to replace /eclipse/plugins/ by /Eclipse/plugins/ (capital E ) in
MicroEJ-SDK-21.03.app\Contents\Eclipse\eclipse.ini.

o See SDK 5.4.0 Known Issues section

3.10.3 [20.12] - 2020-12-11

« Included SDK 5.3.1

« Disabled Java version check when updating SDK (see known issues of SDK Distribution 20.10)

3.10.4 [20.10] - 2020-10-30

« Included SDK5.3.0
« Updated to Eclipse version 2020-06
« Fixed low quality MacOS SDK icons

NOTE: Starting with this release, only 64bits JRE are supported because 32bits JRE support has been removed
since Eclipse version 2018-12. See this link for more details.

KNOWN ISSUES:
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« Projects configured with Null Analysis must be updated to import EDC API1.3.3 or higher in order to avoid an
Eclipse JDT builder error (see also this link for more details).

« The default settings file for connecting MicroEJ Central Repository is not automatically installed. To connect
to the MicroEJ Central Repository, follow the procedure:

For Windows, create the folder: C:\Users\%USERNAME%\ .microej .

For Linux, create the folder: /home/$USER/.microej.

For macos, create the folder: /Users/$USER/.microej.

Download and save this file microej-ivysettings-5.xml to the previously created .microej folder.

+ By default, a check is done on the JRE version required by the plugins on install/update. Since CDT
requires JRE 11, it prevents to install/update a newer SDK version. The CDT documentation explains

that this can be bypassed by disabling the option Windows > Preferences > Install/Update >

Verify provisioning operation is compatible with currently running JRE .

3.10.5 [20.07] - 2020-07-28

« Included MicroEJ SDK5.2.0
« Updated the default microej repository folder name (replaced SDK version by the distribution number)

» Added Dist. prefixininstaller name (e.g. MicroEJ SDK Dist. 20.07)to avoid confusion between SDK
distribution vs SDK version

« Updated SDK End User License Agreement

+ Disabled popup window when installing a SDK update site (allow to install unsigned content by default)

3.10.6 [19.05] - 2019-05-17

« Included SDK version 5.1.0
« Updated MicroEJ icons ( 16x16 and 32x32)
« Updated the publisher of Windows executables (MicroEJ instead of I1S2T SA.)

« Updated the JRE link to download in case the default JRE is not compatible. ( https://www.java.com is
deprecated)

3.10.7 [19.02] - 2019-02-22

« Updated to Eclipse Oxygen version 4.7.2
« Included SDK version 5.0.1

« Included Sonarlint version 4.0.0

3.11 SDK Changelog

3.11.1 [5.5.3] - 2022-05-03
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MicroEJ Module Manager

« Fixed error Can't parse module descriptor when building a Module on Windows with a JDK 8.0.331+.

3.11.2 [5.5.2] - 2021-12-22

General

+ Fixed Addon Processors of a project in a workspace being applied to others projects.
MicroEJ Module Manager
Build Plugins

+ Updated Log4j in Artifact Checker and Cobertura plugins to version 2.17.0.

3.11.3 [5.5.1] - 2021-12-02

General

+ Fixed wrong category name in New Project wizard.

3.11.4 [5.5.0] - 2021-11-15

NOTE: This release prepares for a future JRE 11 support. However, the only officially supported JRE version is still
JRE 8. Please refer to System Requirements for more details.

General

Added Add-On Processor resolution in workspace.
« Updated tools for both JRE 8 and JRE 11 compatibility.
« Fixed corrupted font file created by the Font designer when importing large number of glyphs.

+ Updated Architecture version check during Pack import ( greaterOrEqual instead of compatible ). This
allows to import Architecture Specific Pack and Legacy Generic Pack on future Architecture versions 8. x .

« Updated End User License Agreement.

MicroEJ Module Manager

+ Added bin folderto .gitignore file of module natures Java project skeleton.

+ Added Null Analysis configuration to artifact-checker.When building a module repository, null analysis
configuration is only checked on the highest module version included in the repository.

« Added Eclipse Public License v2.0 to the list of default licenses allowed for artifact-checker.
« Clarified input messages of mmm init command.

« Updated artifact-checker plugin bindingto target verify. This allow module checks to be executed on
builds triggered by a pull request (no publication).
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+ Fixed missing artifact-checker plugin to some module natures ( custom , firmware-multiapp ,
firmware-singleapp, microej-javaimpl, microej-mock, microej-testsuite, product-java).

« Fixed mmm run executionona firmware-singleapp module (do not trigger the Firmware build).

+ Fixed kf-testsuite plugin test project build.

Added support of branch analysis with Sonar.

Added ability to package private dependencies to mock module natures (configuration embedded ).
« Added testsuite and javadoc pluginto firmware-singleapp module nature.

+ Added ssh deploymentto microej-kf-testsuite plugin.

« Updated firmware-multiapp toremove the bsp directory in Virtual Devices.

« Updated firmware-multiapp to allow Virtual Devices for launching a specific main class other than the
Kernel main class. This is useful for running JUnit tests using a Virtual Device instead of a Platform.

« Updated firmware-multiapp to allow Virtual Devices for automatically launching a Sandboxed Application
project in the SDK.

« Updated firmware-multiapp to automatically configure the Virtual Device Kernel UID when a Firmware is
built.

« Fixed firmware-multiapp skeleton default dependencies with only modules available in MicroEJ Central
Repository.

« Fixed firmware-multiapp unexpected build error when no declared System Application.

« Fixed firmware-multiapp build which may fail an unexpected Unresolved Dependencies error the first
time, for Kernel APIs module dependencies (configuration kernelapi ) or Virtual Device specific modules
dependencies (configuration default-vd).

« Fixed firmware-multiapp unexpected build error when no Application ( .wpk file) found in the dropins
folder.

+ Fixed firmware-multiapp unexpected build error when no declared System Application.

+ Fixed firmware-singleapp and firmware-multiapp skeletons wrong package name generation for the
default Main class.

Fixed artifact-repository changelogcheck for modules with a snapshot version.

3.11.5 [5.4.1] - 2021-04-16

NOTE: This release is both compatible with Eclipse version 2020-06 and Eclipse Oxygen, so it can still be installed
on a previous SDK Distribution.

MicroEJ Module Manager
+ Fixed missing repository configurationin artifact-repository skeleton (this configuration is required
to include modules bundled in an other module repository)

+ Fixed missing some old build types versions that were removed by error. (introduced in SDK 5.4.0, please
refer to the Known Issues section for more details)

« Fixed wrong version of module built in a meta-build (module was published with the module version instead
of the snapshot version)
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« Fixed code coverage analysis on source code (besides on bytecode) thanks to the property cc.src.folders
(only for architectures in version 7.16.0 and beyond)

3.11.6 [5.4.0] - 2021-03-25

NOTE: This release is both compatible with Eclipse version 2020-06 and Eclipse Oxygen, so it can still be installed
on a previous SDK Distribution.

Known Issues

« Some older build types versions have been removed by error. Consequently, using SDK 5.4.90 , it may be not
possible to build modules that have been created with an older SDK version (For example, MicroEJ GitHub
code). The list of missing build types:

build-application 7.0.2

build-microej-javalib 4.1.1

build-firmware-singleapp 1.2.10

build-microej-extension 1.3.2

General

+ Added MicroEJ Module Manager Command Line Interface in Build Kit
+ Added ignore optional compilation problems in Addon Processor generated source folders

+ Added logs to Standalone Application build indicating the mapping of Foundation Libraries to the Platform

Updated End User License Agreement

+ Added the latest HIL Engine APl to mock-up skeleton (native resources management)

Updated the Architecture import wizard to automatically accept Pack licenses when the Architecture license
is accepted

MicroEJ Module Manager

General

« Added JSCH library to execute MicroEJ test suites on Device through ssh
+ Added pre-compilation phase before executing Addon Processor to have compiled classes available

«+ Updated the default settings file to import modules from MicroEJ Developer repository (located at ${user.
dir}\.microej\microej-ivysettings-5.4.xml)

Build Types

« Updated all relevant build types to load the Platform using the platform configuration instead of the test
configuration:

- Sandboxed Application (application)

- Foundation Library Implementation ( javaimpl)
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- Addon Library ( javalib)
- MicroEJ Testsuite ( testsuite)
+ Updated Module Repository to allow to partially include an Architecture module (eval and/or prod)

« Fixed potential Addon Processor error NoClassDefFoundError: ej/tool/addon/util/Message depend-
ing on the resolution order

+ Removed javadoc generation for microej-extension

Build Plugins

+ Updated Addon Processor to fail the build when an error is detected. Error messages are dumped to the build
logs.

« Updated Platform Loader to handle Platform module ( . zip file)

« Updated Platform Loader to handle Virtual Device module ( . vde file) declared as a dependency. It worked
before only by using the dropins folder.

« Updated Platform Loader to list the Platforms locations when too many Platform modules are detected

Skeletons

» Fixed wrong README.md generation for artifact-repository skeleton

« Removed uselessfilesin microej-javaapi, microej-javaimpl and microej-extension skeletons (intern
changelogand .dbk file)

3.11.7 [5.3.1] - 2020-12-11

NOTE: This release is both compatible with Eclipse version 2020-06 and Eclipse Oxygen, so it can still be installed
on a previous SDK Distribution.

General

+ Fixed missing default settings file for connecting MicroEJ Central Repository when starting a fresh install
(introducedin 5.3.0)

MicroEJ Module Manager
Build Plugins

« Fixed potential build error when computing Sonar classpath from dependencies ( ivy:cachepath task was
sometimes using a wrong cache location)

Skeletons

« Fixed skeleton dependency to EDC-1.3.3 to avoid an Eclipse JDT builder error when Null Analysis is enabled
(see known issues of SDK Distribution 20.10)
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3.11.8 [5.3.0] - 2020-10-30

NOTE: This release is both compatible with Eclipse version 2020-06 and Eclipse Oxygen, so it can still be installed
on a previous SDK Distribution.

Known Issues

« Library module build may lead to unexpected Unresolved Dependencies error in some cases (in
sonar:init target/ ivy:cachepath task). Workaround is to trigger the library build again.

General

« Fixed various plugins for Eclipse version 2020-06 compatibility (icons, project explorer menu entries)
« Fixed closed module.ivy files after an SDK restart that were opened before
+ Removed license check before launching an Application on Device

+ Disabled Activate on new event option of the Error Log view to prevent popup of this view when an
internal error is thrown

+ Removed license check before Platform build
« Updated filter of the Launch Group configuration (exclude the deprecated Eclipse CDT one)
« Fixed inclusion of mock project dependencies in launcher mock classpath

« Enhance error message in Platform editor ( .platform files) when the required Architecture has not been
imported (displays Architecture information)

MicroEJ Module Manager

General

« Fixed workspace default settings file when clicking on the Default button

« First wrong resolved dependency when ChainResolver returnFirst option is enabled and the module to re-
solve is already in the cache

« Fixed potential build module crash (Not comparable issue) when resolving module dependencies across
multiple configurations

Build Types

Exclude packs from artifact checker when building a module repository

+ Merged Foundation & Add-On Libraries javadoc when building a module repository

« Added Module dependency line for each type in module repository javadoc

« Added an option to skip deprecated types, fields, methods in module repository javadoc
+ Allow to include or exclude Java packages in module repository javadoc

+ Added an option skip.publish to skip artifacts publicationin build-custom build type

+ Allow to define Application options from build option using the platform-launcher.inject. prefix
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+ Added generation and publication of code coverage report after a testsuite execution. The report generation
is enabled under the following conditions:

at least one test is executed,

- tests are executed on Simulator,

- build option s3.cc.activated issetto true (default),

- the Platform is based on an Architecture version 7.12.0 or higher

- if testing a Foundation Library (using microej-testsuite ), build option microej.testsuite.cc.
jars.name.regex must be set to match the simple name of the library being covered (e.g. edc-*. jar
or microui-*.jar)

« Fixed sonar false negative Null Analysis detection in some cases

+ Added a better error message for Studio rebrand build when izpack.microej.product.location option
is missing

+ Deprecated build-microej-ri and disabled documentation generation (useless docbook toolchains have
been removed to reduce the bundle size: -150MB)

Skeletons

« Fixed microej-mock content scriptinitialization folder name

3.11.9 [5.2.0] - 2020-07-28

General

» Added Dist. prefixin default workspace and repository name to avoid confusion between SDK distribution
vs SDK version

Replaced Version by Dist. in Help > AboutMicroEJ® SDK menu. The SDK version is available in
Installation Details view.

Replaced IS2T S.A. and MicroEJ S.A. by MicroEJ Corp. in Help > AboutMicroEJ® SDK menu.
« Updated Front Panel plugin to version 6.1.1

+ Removed MicroEJ Copyright in Java class template and skeletons files

Fixed Stopping a MicroEJ launch in the progress view doesn’t stop the launch

MicroEJ Module Manager

General

+ Added a new configuration page ( Window > Preferences > Module Manager ). This page is a merge of
formerly named Easyant4Eclipse preferences pageand Ivy Settings relevant options for MicroEJ.

+ Added Export > MicroEJ > Module Manager Build Kit wizard, to extract the files required for automating
MicroEJ modules builds out of the IDE.

« Added New > MicroEJ > Module Project wizard (formerly named New Easyant Project ), with module
fields content assist and alphabetical sort of the skeletons list
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+ Added Import > MicroEJ > Module Repository wizard to automatically configure workspace with a
module repository (directory or zip file)

+ Added New MicroEJ Add-On Library Project wizard to simplify Add-On Library skeleton project creation

Updated the build repository ( microej-build-repository.zip ) to be self contained with its owns
ivysettings.xml

« Updated Virtual Device Player ( firmware-singleapp ) launcher-windows.bat (use
launcher-windows-verbose.bat to get logs)

Renamed the classpath container to Module Dependencies instead of Ivy

+ Fixed Addon Processor src-adpgenerated folder generation when creating or importing a project with the
same name than a previously deleted one

Fixed implementation of settings ChainResolver returnFirst option

Fixed Ivy module resolution being blocked from time to time

Build Types

Fixed meta build to publish correct snapshot revisions for built dependencies. (Indirectly fixes ADP resolution
issue when an Add-On Library and its associated Addon Processor were built together using a meta build)

« Fixed potential infinite loop when building a Modules Repository with MMM semantic enabled

Fixed javadoc not being generated in artifactory repository build when skip. javadoc issetto false

+ Added the capability to build partial modules repository, by using the user provided ivysettings.xml file
to check the repository consistency

« Added the possibility to partially extend the build repository in a module repository. The build repository
can be referenced by a file system resolver using the property ${microej-build-repository.repo.dir}

+ Added the possibility to include a module repository into an other module repository (using new configura-
tion repository->%)

+ Added the possibility to bundle a set of Virtual Devices when building a branded Studio. They are automati-
cally imported to the MicroEJ repository when booting on a new workspace.

« Added the possibility to bundle a Module Repository when building a branded Studio. It is automatically
imported and settings file is configured when booting on a new workspace.

Build Plugins

« Added variables @MMM_MODULE_ORGANISATION@ , @MMM_MODULE_NAME@ and @MMM_MODULE_VERSIONe for
README.md file

« Fixed microej-kf-testsuite repository accessissue (introduced in SDK 5.0.0).

« Fixed artifact-checker to accept revisions surrounded by brackets (as specified by https:
//keepachangelog.com/en/1.0.0/)

Skeletons

« Updated module.ivy indentation characters with tabs instead of spaces

+ Updated CHANGELOG.md formatting
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« Updated and standardized README.md files

Updated dependenciesin module.ivy to use the latest versions

« Added .gitignore toignorethe target~ and src-adpgenerated folder where the module is built

Added Sandboxed Application WPK dropins folder (META-INF /wpk )
« Removed conf provided in module.ivy forfoundation libraries dependencies

« Remove MicroEJ internal site reference in module.ant file

Fixed corrupted library workbenchExtension-api.jar in microej-extension skeleton

Fixed corrupted library HILEngine. jar in microej-mock skeleton

Fixed javadoc content issue in Main class firmware-singleapp skeleton

Misc

Updated End User License Agreement

Added support for generating Application Options in reStructured Text format

3.11.10 [5.1.2] - 2020-03-09

MicroEJ Module Manager

« Fixed potential build error when generating fixed dependencies file ( fixdeps task was sometimes using a
wrong cache location)

Fixed topogical sort of classpath dependencies when building using Build Module (sameasin IvyDE class-
path sorted view)

Fixed resolution of modules with a version @.m.p when transitively fetched (an error was thrown with the
range [1.m.p-RC,1.m.(p+1)-RC[)

Fixed missing classpath dependencies to prevent an error when building a standard JAR with JUnit tests

3.11.11 [5.1.1] - 2019-09-26

General

« Fixed fileslockedin Platform in workspace projects preventing the Platform from being deleted or rebuilt

3.11.12 [5.1.0] - 2019-05-17
General

+ Updated MicroEJ icons ( 16x16 and 32x32)

» Fixed potential long-blocking operation when launching an application on a Virtual Device on Windows 10
(Windows defender performs a slow analysis on a zip file when it is open for the first time since OS startup)

« Fixed missing ADP resolution on a fresh MicroEJ installation

« Fixed ADP source folders order generation in .classpath (alphabetical sort of the ADP id)
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« Fixed RunAs... > MicroEJ Application automatic launcher creation: when selecting a Platform in
workspace , an other platform of the repository was used instead

+ Fixed Memory Map Analyzer load of mapping scripts from Virtual Devices
+ Fixed MMM and ADP resolution when importing a zip project in a fresh MicroEJ install
« Fixed ADP crash when a project declares dependencies without a source folder

« Fixed inability to debug an application on a Virtual Device if option execution.mode was specified in
firmware build properties (now SDK options cannot be overridden)

+ Updated Front Panel plugin to comply with the new Front Panel engine

- The Front Panel engine has been refactored and moved from Ul Pack to Architecture (Ul pack 12.0.0
requires Architecture version 7.11.0 or higher)

- New Front Panel Project wizard now generates a project skeleton for this new Front Panel engine,
based on MMM

- Legacy Front Panel projects for Ul Pack v11.1.0 or higher are still valid

« Updated Virtual Device builder to speed-up Virtual Device boot time (System Applications are now extracted
at build time)

« Fixed inability to selecta Platform in workspace ina MicroEJ Tool launch configuration
« Fixed broken title in MicroEJ export menu (Platform Export)

MicroEJ Module Manager

Build Plugins

+ Added a new option application.project.dir passed to launch scripts with the workspace project direc-
tory

Updated MMM to throw a non ambiguous error message when a module.ivy configured for MMM declares
versions with legacy lvy range notation

« Updated MicroEJ Central Repository cache directory to ${user.dir}\.microej\caches\repository.
microej.com-[version] instead of ${user.dir}\.ivy2

Updated Update Module Dependencies. .. tobedisabled when module.ivy cannot beloaded. The menu
entry is now grayed when the project does not declare an IvyDE classpath container

« Fixed wrong resolution order when a module is both resolved in the repository and the workspace (the
workspace module must always take precedence to the module resolved in the repository)

Fixed useless unknown resolver trace when cache is used by multiple lvy settings configurations with
different resolver names.

Fixed slow Add-on Processor generation. The classpath passed to ADP modules could contain the same entry
multiple times, which leads each ADP module to process the same classpath multiple times.

Fixed misspelled recommendation message when a build failed

« Fixed Update Module Dependencies... tool: wrong ej:match="perfect” added where it was expected
to be compatible

« Fixed Update Module Dependencies... tool: parse error when module.ivy contains <artifact
type="rip"/> element

Fixed resolution and publication of a module declared with an Ivy branch
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« Fixed character '-' rejected in module organisation (according to MMM specification 2.0-B)
« Fixed ADP resolution error when the Add-on Processor module was only available in the cache

« Fixed potential build crash depending on the build kit classpath order (error was This module requires
easyant [0.9,+])

« Fixed product-java broken skeleton

Build Types

Updated Platform Loader error message when the property platform-loader.target.platform.dir isset
to aninvalid directory

Fixed meta build property substitutionin *.modules.list files

Fixed missing publications for README .md and CHANGELOG.md files

Update skeletons to fetch latest libraries (Wadapps Framework v1.10.0 and Junit v1.5.0)
+ Updated README.md publication to generate MMM usage and the list of Foundation Libraries dependencies
« Added a new build nature for building platform options pages (microej-extension)

« Updated Virtual Device builder to speed-up Virtual Device boot time (System Applications are now extracted
at build time)

Fixed Virtual Device Player builder (dependencies were not exported into the zip file) and updated
firmware-singleapp skeleton with missing configurations

Skeletons

« Updated CHANGELOG.md based on Keep a Changelog specification (https://keepachangelog.com/en/1.0.0/)

+ Updated offline module repository skeleton to fetch in a dedicated cache directory under ${user.dir}/.
microej/caches

3.11.13 [5.0.1] - 2019-02-14

General

Removed Wadapps Code generation (see migration notes below)

Added support for MicroEJ Module Manager semantic (see migration notes below)

Added a dedicated view for Virtual Devices in MicroEJ Preferences

Removed Platform related views and menus in the SDK (Import/Export and Preferences)

Added Studio rebranding capability (product name, icons, splash screen and installer for Windows)

Added a new meta build version, with simplified syntax for multi-projects build (see migration notes below)

Added a skeleton for building offline module repositories

Added support for importing extended characters in Fonts Designer

Allow to import Virtual Devices with .vde extension (*. jpf importstill available for backward compatibility)

Removed legacy selection for Types, Resources and Immutables in MicroEJ Launch Configuration (replaced
by *.1ist files since MicroEJ 4.0)

3.11.

SDK Changelog 61


https://keepachangelog.com/en/1.0.0/

MicroEJ Documentation, Revision c72145fb

Enabled IvyDE workspace dependencies resolution by default
« Enabled MicroEJ workspace Foundation Libraries resolution by default

« Added possibility for Architectures to check for a minimum required version of SDK ( sdk.min.version prop-
erty)

+ Updated New Standalone Application Project wizard to generate a single-app firmware skeleton

«+ Updated Virtual Device Builder to manage Sandboxed Applications (compatible with Architectures Products
*_7.10.0 or newer)

« Updated Virtual Device Builder to include kernel options (now options are automatically filled for the appli-
cation developer on Simulator)

MicroEJ Module Manager

Build Plugins

« Added IvyDE resolution from properties defined in Windows > Preferences > Ant > Runtime >
Properties

« Fixed lllegal character in path error that may occur when running an Add-on Processor

« Fixed IvyDE crash when defining an Ant property file with Eclipse variables

Build Types

Kept only latest build types versions (skeletons updated)
« Updated metabuild to execute tests by default for private module dependencies

« Removed remaining build dependencies to JDK (Java code compiler and Javadoc processors). All MicroEJ
code is now compiled using the JDT compiler

Introduced a new plugin for executing custom testsuite using MicroEJ testsuite engine

Fixed MalformedURLException error in Easyant trace

Fixed Easyant build crash when an vy settings file contains a cache definitions with a wildcard

Updated Platform Builder to keep track in the Platform of the architecture on which it has been built (
architecture.properties)

« Updated Virtual Device Builder to generate with .vde extension

Updated Multi-app Firmware Builder to embed (Sim/Emb) specific modules (Add-on libraries and System
Applications)

Fixed build-microej-ri v1.2.1 missing dependencies (embedded in SDK 4.1.5)

Skeletons

« Updated all skeletons: migrated to latest build types, added more comments, copyright cleanup and config-
uration for MicroEJ Module Manager semantic)

+ Added the latest HIL Engine APl to mock-up skeleton (Start and Stop listeners hooks)

3.11. SDK Changelog 62



MicroEJ Documentation, Revision c72145fb

3.12 Migration Notes

3.12.1 From 5.2.xt0 5.3.x

This section applies if MicroEJ SDK 5. 3. x is started on a workspace that was previously created using MicroEJ SDK
5.2.x%.

Workspace migration warning

Starting with the MicroEJ SDK Distribution 20.10, when opening a workspace which has been created with an older
MicroEJ Distribution, a message is displayed with the following warning:

The workspace was written with an older version. Continue and update workspace which may make it._
—incompatible with older versions?

This is a generic warning from Eclipse which can be safely ignored as long as you don’t intend to open it back with
an older MicroEJ SDK Distribution then.

3.12.2 From 5.1.xt0 5.2.x

This section applies if MicroEJ SDK 5. 2. x is started on a workspace that was previously created using MicroEJ SDK
5.1.x.

Enable New Wizards Shortcuts in MicroEJ Perspective

Eclipse perspective settings are stored in the workspace metadata, so the new wizards shortcuts (
Add-On Library Project and Module Project ) are notvisibleinthe File > New menu.

The MicroEJ perspective must be reset to its default settings as following:

« Clickon Windows > Perspective > Open Perspective > Other... menu

« Select MicroEJ perspective

« Clickon Windows > Perspective > Reset Perspective... menu

« Clickon Yes button to accept to reset the MicroEJ perspective to its defaults.

The new wizards shortcuts are now visible into File > New menu.

Re-enable the vy Preferences Pages (Advanced Use)

Theoriginal Window > Preferences > Ivy pages can be re-enabled as following:
+ Close all running instances of the SDK
« Edit MicroEJ-SDK.ini and add the property -Dorg.apache.ivy.showAdvancedPrefs=true
« Start the SDK again

+ Goto Window > Preferences > Module Manager page

Anew link Ivy settings should appear on the bottom of the page. It opens a popup window with the original Ivy
preferences pages.
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3.12.3 From 4.1.xto 5.x

This section applies if MicroEJ SDK 5. x is started on a workspace that was previously created using MicroEJ SDK
4.1.x.

Wadapps Application Update
The Wadapps code generator has been moved from IDE to an Addon Processor coming with ej. library.wadapps.
framework module (v1.9.0 orhigher is required).

A Wadapps Application Project can be updated as follows:

+ Right-click on the project, then Configure > Remove Sandboxed Application Nature

+ Right-click on the project, then Configure > Add Sandboxed Application Nature

« Update module.ivy dependency to fetch ej.library.wadapps.framework version 1.9.0 (or perform
MicroEJ Module Manager update as defined below)

+ Delete remaining folder src/.generated~ ifany

+ Check that project compiles and folder src-adpgenerated/wadapps is generated

MicroEJ Module Manager Update
It is highly recommended to migrate module.ivy to the MicroEJ Module Manager semantic, since the default Ivy
resolution will be no more maintained in future versions.

The module.ivy can be updated as follows:
» Right-click on module.ivy,then Update Module Dependencies...

This has for effect to both migrate the module.ivy to the MicroEJ Module Manager semantic and also to update
dependencies version to the latest available in the target repository.

Meta build Project Update

A project using microej-meta-build version 1.x can be updated to version 2.x as follows:
« Edit module.ivy
- Replacethe microej-meta-build versionby 2.0.+

- Update all properties declaration to append the metabuild.inject. prefix (e.g. <ea:property
name="skip.test"” value="true"” /> mustbeupdatedto <ea:property name="metabuild.inject.
skip.test” value="true"” />)

- Optionally remove or comment the root folder declaration as it is the default. ( <ea:property
name="metabuild.root” value=".." />)

+ Delete module.properties . It only contains the property easyant.fork.build=true . This property is
now automatically set by easyant-build-component since version 1.12.0. Otherwise it must be explicitly
injected by the build system as an Ant property: easyant.inject.easyant.fork.build=true

+ Extract from override.module.ant the projects declarations lines:

- Extract the project declarations of local.submodule.dirs.id into a new file named private.
modules.list (one project per line)
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- Extract the project declarations of submodule.dirs.id into a new file names public.modules.list
(one project per line)

« Delete override.module.ant

The new file system structure shall look like:

metabuild-project
module.ivy
private.modules.list
public.modules.list

3.13 Troubleshooting

3.13.1 Windows Specifics

If you are using Windows Defender as your default antivirus software, The SDK may be slowed down as it manipu-
lates lots of JAR files (which are ZIP files) that are regularly analyzed.

To improve the SDK experience, please find below a list of folders that should be excluded from Windows Defender
monitoring:

%USERPROFILE%\.eclipse
%USERPROFILE%\.1ivy?2

%USERPROFILE%\ .microej

%USERPROFILE%\ . p2
%USERPROFILE%\AppData\Local\Temp\microej
C:\Program Files\MicroEJ

your workspace(s) folder(s)

The exclusion page is available in the Settings application ( Windows Security > Virus & threat protection >

Manage settings > Exclusions > Add or remove exclusions ).

3.13.

2 Linux Specifics

Starting the SDK on a linux distribution may produce troubles such as missing content pages. This is related to
incomplete Eclipse SWT configuration (see Eclipse GTK wiki page).

One solution is to configure Eclipse as follows:

Add the next lines to MicroEJ-SDK.ini , before -vmargs argument:

--launcher.GTK_Version 2

Ensure GTK is correctly installed ( 1ibwebkitgtk packet)

Configure the following environment variables

MOZILLA_FIVE_HOME=/usr/lib/mozilla
LD_LIBRARY_PATH=${MOZILLA_FIVE_HOME}: ${LD_LIBRARY_PATH}

Restart the SDK
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« Check there is not more SWT/MOZILLA related errors ( Window > Show View > Other... > General >
Error Log )

3.13.3 MacOS Specifics

When launching the SDK using the .app file, you may encounter the following message:

"MicroEJ-SDK-xx.xx" is damaged and can't be opened. You should move it to the Trash.

This is due to MacOS putting applications in quarantine when downloaded with a browser. Use this command to
remove the SDK application from quarantine:

sudo xattr -rd com.apple.quarantine sdk.app

where sdk.app is the SDK file name.
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CHAPTER

FOUR

APPLICATION DEVELOPER GUIDE

4.1 Introduction

The following sections of this document shall prove useful as a reference when developing applications for MicroEJ.
They cover concepts essential to MicroEJ Applications design.

In addition to these sections, by going to https://developer.microej.com/, you can access a number of helpful re-
sources such as:

« Libraries from the MicroEJ Central Repository (https://developer.microej.com/central-repository/);
« Application Examples as source code from MicroEJ Github Repositories (https://github.com/MicroEJ);
« Documentation (HOWTOs, Reference Manuals, APIs javadoc...).

MicroEJ Applications are developed as standard Java applications on Eclipse JDT, using Foundation Libraries. Mi-
croEJ SDK allows you to run / debug / deploy MicroEJ Applications on a MicroEJ Platform.

Two kinds of applications can be developed on MicroEJ: MicroEJ Standalone Applications and MicroEJ Sanboxed
Applications.

A MicroEJ Standalone Application is a MicroEJ Application that is directly linked to the C code to produce a Mi-
croEJ Firmware. Such application must define a main entry point, i.e. a class containing a public static void
main(String[]) method.

A MicroEJ Sandboxed Application is a MicroEJ Application that can run over a Multi-Sandbox Firmware. It can be
linked either statically or dynamically. If it is statically linked, it is then called a System Application as it is part of
theinitial image and cannot be removed.

4.2 Standalone Application

4.2.1 MicroEJ Platform Import

A MicroEJ Platform is required to run a MicroEJ Standalone Application on the Simulator or build the Firmware
binary for the target device.

The Platform Developer Guide describes how to create a MicroEJ Platform from scratch for any kind of device. In
addition, MicroEJ Corp. provides Platforms for various development boards (see https://repository.microej.com/
index.php?resource=JPF).

MicroEJ Platforms are distributed in two packages:

« Source Platform. The source files are imported into the workspace. This is the default case.
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+ Binary Platform. A . jpf fileisimported into the MicroEJ repository. As of MicroEJ SDK 5. 3.0, this package
is deprecated.

Source Platform Import

Import from Folder

This section applies when the Platform files are already available on a local folder. This is likely the case when the
files are checked out from a Version Control System, such as a local git repository clone.

Note: If you are going to import a Platform from MicroEJ Github, you can follow the specific GitHub Repositories
section instead (the projects will be automatically imported).

« Select File > Import... > General > Existing ProjectsintoWorkspace > Selectrootdirectory =
Browse... .

« Select the root directory. The wizard will automatically discover projects to import.

« Clickonthe Finish button.

Import from Zip File

This section applies when the Platform files are packagedina .zip file.

« Select File > Import... > General > Existing Projectsinto Workspace > Select archive file >
Browse... .

+ Select the zip of the project (e.g., x.zip). The wizard will automatically discover projects to import.

« Clickonthe Finish button.

Platform Build

MicroEJ Platforms are usually shared with only the Platform configuration files. Once the projects are imported,
follow the platform-specific documentation to build the Platform.

Once imported or built, a Platform project should be available as follows:
v 2 myDevice-myPlatform-CMdhardfp_|ARS3-1.0.0
% build
= =ource

= .project

Fig. 1: MicroEJ Platform Project

The source folder contains the Platform content which can be set to the target.platform.dir option.
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Binary Platform Import

After downloading the MicroEJ Platform . jpf file, launch MicroEJ SDK and follow these steps to import the MicroEJ

Platform:

« Open the Platform view in MicroEJ SDK, select Window > Preferences > MicroEJ > Platforms . The
view should be empty on a fresh install of the tool.

o
type filter text
. General A
- Ant
- CfC++
Checkstyle
EasyantdEclipse
- Help
- Install/Update
vy
. Java
4 Microk)
Architectures
Maming Conventicon
Platforms in workspace
Updates
+ Mylyn
» Plug-in Development
. PMD

n o

£ >

@

« Press Import... button.

+ Choose SelectFile... andusethe Browse option to navigate to the
Platform, then read and accept the license agreement to proceed.

Preferences

Platforms

Add or remove platforms.

Platforms, Virtual Devices and Architectures:

MName

Fig. 2: MicroEJ Platform Import

o IEN
<::,v v

Version Lic... Select All
Deselect All
Import...
Uninstall

Get UID

.jpf file containing your MicroEJ

4.2. Standalone Application
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- oS

('} Import Platforms, Virtual Devices and Architectures

Import Platforms, ¥irtual Devices and Architectures

Select a directory/file to search for available platforms, virtual devices and architectures.

(") Select directory: Browse...
(®) Select file: Ch\Usersh, MicroEJPlatform jpof Browse...
Platforms, Yirtual Devices and Architectures:
Mame Yersion Select All
L} MicroE Platform 2.1.1 Deselect Al

MICROE) LICEMSE AGREEMENT

PREAMELE

THIS SOFTWARE LICEMNSE AGREEMENT (THE « AGREEMENT ») APPLIES TO PRODUCTS LICEMSE
On purchase of any Licensed Product from 52T or an 52T Partner or an [52T Distributor, the relz
THE LICEMSEE, AS A USER OF THE LICEMSED PRODUCTS REFERRED TO ABOVE AND OM THE REI

1 DEFIMITIONS

€ >

[+]1 agree and accept the above terms and conditions and | want to install the copyrighted Software

Fig. 3: MicroEJ Platform Selection

+ The MicroEJ Platform should now appear in the Platforms view, with a green valid mark.
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ﬂ Preferences
type filter text Platforms
» G | ~
Eners Add or remove platforms.
At
. CIC++ Platforms, Virtual Devices and Architectures:
Checkstyle Name

EasyantdEclipse L) MicroEJ Platform

+ Help

+ Install/Update

> vy

» Java

4 Microk)
Architectures
Maming Conventicon
Platforms in workspace
Updates

» Mylyn

» Plug-in Development

> PMD

n o

£ >

=
?
\‘;/'

o IEN
<::,v v

Version Lic... Select All
211 v
v Deselect All
Import...

Uninstall

Get UID

Restare Defaults Apply

Fig. 4: MicroEJ Platform List

4.2.2 Build and Run an Application

Create a MicroEJ Standalone Application

« Create a project in your workspace. Select File > New > Standalone Application Project .

File Edit Source Refactor Mavigate Search Project

Mew Alt+Shift+M »
Open File...

[} Open Projects from File System...
Recent Files .
Close Editor Ctrl+W
Close All Editors Ctrl+Shift+W
Save Ctrl+5
Save As

Run

B

Uz

ks
=

1 Id F

|

Window Help
Sandboxed Application Project
Standalone Application Project
Add-On Library Project
Module Project
Platform Project
Front Panel Project

Project...

MicroEl Font

Fig. 5: New MicroEJ Standalone Application Project

« Fill in the Application template fields, the project name field will automatically duplicate in the following

fields. For this tutorial, the project nameis hello. Click on Finish . A template project is automatically
created and ready to use, this project already contains all folders wherein developers need to put content:

4.2. Standalone Application
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- src/main/java: Folder for future sources
- src/main/resources : Folder for future resources (images, fonts, etc.)

- module.ivy: Module description file, dependencies description for the current project

« A Main class already exists in the package com.mycompany and prints “Hello World!” :

1] Mainjava i2

2@ Javal]

5 package com.mycompany;

B

70 =+

8 * @Generated by the build-firmware-singleapp-skeleton.<br:
9 * please keep it in sync with the property "application.main.c.
B *

1 public class Main {

2

32 =

14 * Simple main.

15 *

16 * [param args

17 = command line arguments.

18 */

198 public static void main{String[] args) {

2@ system.out.println{"Hello World!™); //SNON-NLS-1%
21 }

22 }

23

Fig. 6: MicroEJ Application Content

The main Application is now ready to be executed. See next sections.

Run on the Simulator

Note: A Platform must have been imported to run the Application. If several Platforms have been imported, the
target Platform can be selected in the Launcher’s Execution tab.

To run the sample project on Simulator, select it in the left panel then right-click and select Run > Runas >
MicroEJ Application .
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|- RICIN B fPﬁf%-Qv%viﬂﬁ\@v;i&E.jvi - > to o ~| %
New b
= .
& p Go Into B [J] Mainjava 2
b 26 Javal]
o Open in New Window 5 package com.mycompany;
Open Type Hierarchy F4 E_
Show In Alt+Shift+W » 8 * Generated by the build-firmware-singleapp-skeleton.<b
9 * Please keep it in sync with the property 'application
[ Copy Ctrl+C 18 */
E=  Copy Qualified Name _: public class Main {
ra
[[& Paste Ctrl+V 3 JE*
3 Delete Delete 4 Simple main.
5 "
Build Path ] 6 args
. command line arguments.
Source Alt+Shift+5 » Y]
Refactor Alt+Shift+T » public static void main(String[] args) {
System,out.println(“Hello World!™); //BNON-NLS-1!
[z_],\._, Import... 2 ¥
7 Export.. b
" Refresh Fs
Close Project
Close Unrelated Project
Assign Working Sets...
{J PRunAs >[I 1Java Application Alt+Shift+X, J
45 Debug As » 7] 2 Microb) Application Alt+5hift+X, M
Profile As »

_ Run Configurations...
# Build Module r

Fig. 7: MicroEJ Launcher Shortcut

MicroEJ SDK console will display Launch steps messages.

SUCCESS

Run on the Device

Build the Application

+ Opentherundialog( Run > Run Configurations... ).
+ Select the MicroEJ Application > Hello Main thatis created by the previous chapter.

+ Open Execution tab and select Execute on Device .

« Set Settings checkboxto Build & Deploy .
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@ Run Cenfigurations m] X

o

P S =] x' =g Name:|HeHo Main |

[3] Main [ Execution i Configuration | mi JRE| % Source| [[] Common

[E] C/C++ Application Target
Ju JUnit Platferm: MicroEl Platform

Create, manage, and run configurations

Browse...
i Launch Group
~ [T] Microk) Application
7] Hello Main Execution
g Microkl Tool
Ha Microst oo () Execute on Simulator (® Execute on Device
Core Engine Mode: | Default ~
Android Settings: | Build & Deploy ~
The application is generated, linked and deployed.
Options

Output folder: | ${project_loc:hello} Browse...

Clean intermediate files [ verbose
Options Files
Add...
Remove
Up
Down
Revert Appl
Filter matched 6 of 14 items = PRy

Fig. 8: Execution on Device

« Click Run : The Application is compiled and the Application, the runtime library and the header files are
automatically deployed to the locations defined in your Platform BSP connection settings.

=============== [ Deployment ] ===============

MicroEJ files for the 3rd-party BSP project are generated to '<application-project>/<fully-qualified-
—name-of-main-class>/platform'.

The MicroEJ application (microejapp.o) has been deployed to: '<path-to-deployment-location>".

The MicroEJ platform library (microejruntime.a) has been deployed to: '<path-to-deployment-location>".
The MicrokEJ platform header files (*.h) have been deployed to: '<path-to-deployment-location>'.
=============== [ Completed Successfully ] ===============

SUCCESS

Build the Executable File

If your Platform has configured a build script file, the final Application linking can be triggered from the launcher:

» Open Configuration tab and select Device > Deploy . The optionsto deploy the Application, runtime
library and header files have already been set in the previous step.

« Check Execute the MicroEJ build script (build.bat) at a location known by the 3rd-party BSP project .
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Q- Run Configurations O b4
Create, manage, and run configurations ;—I
Iﬁ ~ = X | E | Name: | Hello Main |
type filter text 3] Main | mié Execution |} Configuration . =i JRE| % Source | [[] Commen
[€] C/C++ Application ||| v Device Configuration ~
Ju JUnit Core Engine ’ A —_ - -
[-] Deploy the MicroE) application (microejapp.o] at a location known by the 3rd-party BSP project.
& Lounch Group Deploy £ Deploy pp ( japp.c) y party BSP proj
w 7] MicroE) Application Libraries
[T Hello Main Runtime
T Microk) Tool
Browse
Deploy the MicroE) platform library (microgjruntime.a) at a location known by the 3rd-party BSP project.
Browse
Deploy the MicroE) platform header files (*.h) at a location known by the 3rd-party BSP project.
Browse
I Execute the MicroE) build script (build.bat) at a location known by the 3rd-party BSP project. I
v
< >
< >
Revert Appl
Filter matched 6 of 13 items PPy
(?) Run Close

Fig. 9: BSP Connection Application Options

Note: The table MicroEJ Application Options for BSP Connection specifies the Application options that can be set
depending on the BSP connection configured by the Platform.

+ Click Apply and Run :thefinalexecutable application.out fileisgenerated inthe directory from where
the script has been executed and can now be deployed on your Device using the appropriate flash tool.

4.2.3 Build Output Files

When building a Standalone Application, multiple files are generated next to the ELF executable file.

Launch Output Folder

Using a MicroEJ Application Launch, the files are generated in a folder which is named like the main type and which
is located in the output folder specified in the run configuration.
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v [ com.microg).demo.widget.commeon.Mavigation
= bon
= cc
[ externalResources
= fonts
= heapDump
== Images
= logs
= platform
= resourceBuffer
v [ soar
=| com.microej.demo.widget.common.Mavigation.clinitmap
com.micreej.demo.widget.common.MNavigation.o
E-i com.micreel.demeo.widget.common.Mavigation.s3infos
|¥| com.microej.demo.widget.commen.Mavigation.xml
L] sni_intern.h
0 SOAR.map

SOAR.0

Fig. 10: Build Output Files from MicroEJ Application Launch

Published Module Files

After building the Standalone Application, the published module contains the following main files:
o [name]-[version].out : Firmware (ELF Executable)
o [name]-[version].zip: Virtual Device

« [name]-[version]-workingEnv.zip : Build intermediate files, including the content of the launch output
Folder)
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ation-1.0.2.out <—— Firmware (ELF Executable)
& ation-1.0.2-workingEnv.zip <= Build Intermediate Files
] application-1.0.2.zip «— Virtual Device
£ application-build-meta-1.0.2xml  <+—— MMM metadata
] CHANGELOG-1.0.2.md <+— Changelog
] i 2.xm <+— MMM metadata
& ivy-fixed-1.0.2.xml <+—— MMM metadata
] README-1.0.2.m <—— README

Fig. 11: Published Standalone Application Module Files

The SOAR Map File

The SOAR.map file lists every embedded symbol of the application (section, Java class or method, etc.) and its size
in ROM or RAM. This file can be opened using the Memory Map Analyzer.

The embedded symbols are grouped into multiple categories. For example, the Object class and its methods are
grouped inthe LibFoundationEDC category. For each symbol or each category, you can see its size in ROM ( Image
Size)and RAM (Runtime Size).

The SOAR groups all the Java strings in the same section, which appearsinthe ApplicationStrings category. The
same appliesto the staticfields (Statics category), thetypes (Types category), and the class names (ClassNames
category).

The SOAR Information File

The soar/<main class>.xml file can be opened using any XML editor.
This file contains the list of the following embedded elements:

» method (in selected_methods tag)

« resource (in selected_resources tag)

« system property (in java_properties tag)

+ string (in selected_internStrings tag)

« type (in selected_types tag)

« immutable (in selected_immutables tag)

4.2.4 MicroEJ Launch

The MicroEJ launch configuration sets up the MicroEJ Applications environment (main class, resources, target plat-
form, and platform-specific options), and then launches a MicroEJ launch script for execution.

Execution is done on either the MicroEJ Platform or the MicroEJ Simulator. The launch operation is platform-
specific. It may depend on external tools that the platform requires (such as target memory programming). Refer
to the platform-specific documentation for more information about available launch settings.
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Main Tab

The Main tab allows you to setin order:
1. The main project of the application.
2. The main class of the application containing the main method.

3. Types required in your application that are not statically embedded from the main class entry point. Most
required types are those that may be loaded dynamically by the application, using the Class.forName()
method.

4. Binary resources that need to be embedded by the application. These are usually loaded by the application
using the Class.getResourceAsStream() method.

5. Immutable objects’ description files. See the [BON 1.2] ESR documentation for use of immutable objects.

0 Run Configurations n
Create. manage. and run configurations ;—l
- —*,
= x| 8 5 Name: | HelloWerld
type filter text 31 Main s Execution | §fif Configuration | =, JRE E Source | [[] Commen
E C/C++ Application Praject ~
Ju JUnit

# Launch Group MyHelloWorld5ample Browse...

4 [7] MicroE) Application Main type, Required types

31 HelloWarld
2 Microkl Tool com.is2t.examples.edc.helle. HelloWorld Select Main type...
Add types...
Extra types...
Remove
Resources
Add...
Remove
Immutables v

. . Revert Apply
Filter matched 6 of 11 items

Fig. 12: MicroEJ Launch Application Main Tab

Execution Tab

The next tab is the Execution tab. Here the target needs to be selected. Choose between execution on a MicroEJ
Platform or on a MicroEJ Simulator. Each of them may provide multiple launch settings. This page also allows you
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to keep generated, intermediate files and to print verbose options (advanced debug purpose options).

G Run Cenfigurations

Create, manage, and run configurations

»

CERX B -

type filter text

[©] C/C++ Application
Ju JUnit
L Launch Group
~ [3] MicroE) Application
31 Widget Dema (EME)
7] Widget Demo (SIM)
» [ MicroE) Tool

Name: | Widget Demo (SIM)

3] Main s Execution ™. 31 Configuratiorﬂ % JREW E_E/ Source\l = Qommoﬂ

Target

Platform: | STM32F746G-DISCO SingleApp Production [K1AU3] (4.0.0-RC202007301413) | Browse...
Execution
(®) Execute on Simulator () Execute on Device

Core Engine Mode: [Eiefaul

Settings: | Default ~ | Settings: | Build 8 Deploy
The Application (s simulated

Options
Output folder: | Y{project_loc:com.microej.demo.widget} Browse...
Clean intermediate files [ verbose
Options Files
Y project_loc:com.microgj.demo.widget}/build/common.properties Add...
Y project_loc:com.microe].demo.widget}/build/sim/sim.properties
Remaove
Up
Down
Revert Appl
Filter matched 8 of 21 items — e
® Bun Close

Configuration Tab

Fig. 13: MicroEJ Launch Application Execution Tab

The next tab is the Configuration tab. This tab contains all platform-specific options.

4.2. Standalone Application




MicroEJ Documentation, Revision c72145fb

ﬂ Run Configurations n

Create. manage. and run configurations ; I

S X B2 Name: | HelloWorld

type filter text 37 Main | s Execution | ifif Configuration g, JRE E Source | [[] Commen
[E] C/C++ Application 4 Debug
Ju JUnit Code Coverage
[ Launch Group Heap Dumper
4 [7] MicroE) Application 1Dwe
Logs
@ MicroE) Tool 4 Simulator
Com Port
F5
HAL
4 Target
Memory

Specify debug options

4 Libraries
EDC
Shielded Plug
. ECOM
FS
> Microll
Met
MNLS
S5L

. . Revert Apply
Filter matched 6 of 11 items

Fig. 14: Configuration Tab

JRE Tab

The next tabisthe JRE tab. Thistab allows you to configure the Java Runtime Environment used for running the
underlying launch script. It does not configure the MicroEJ Application execution. The VM Arguments text field
allows you to set vm-specific options, which are typically used to increase memory spaces:

« To modify heap space to 1024MB, set the -Xmx1024M option.

« To modify string space (also called PermGen space) to 256MB, set the -XX:PermSize=256M
-XX:MaxPermSize=256M options.

« To set thread stack space to 512MB, set the -Xss512M option.

Source Tab

Thenexttabisthe Source tab. Bydefault,itisautomatically configured to connect your Add-On Libraries sources
dependencies. To connect your Platform Foundation Library sources, please refer to the section Foundation Library
Sources.
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Common Tab

The last tabisthe Common tab. This is a default Eclipse tab that allows to configure your launch. Particularly,
you can configure the console encoding. Refer to Eclipse help for more details on other available options.

4.2.5 Application Options
Introduction
To run a MicroEJ Standalone Application on a MicroEJ Platform, a set of options must be defined. Options can be
of different types:
« Memory Allocation options (e.g set the Java Heap size). These options are usually called link-time options.
« Simulator & Debug options (e.g. enable periodic Java Heap dump).
+ Deployment options (e.g. copy microejapp.o to a suitable BSP location).

« Foundation Library specific options (e.g. embed UTF-8 encoding).

The following section describes options provided by MicroEJ Architecture. Please consult the appropriate MicroEJ
Pack documentation for options related to other Foundation Libraries (MicroUl, NET, SSL, FS, ...) integrated to the
Platform.

Notice that some options may not be available, in the following cases:

« Option is specific to the MicroEJ Core Engine capability (tiny/single/multi) which is integrated in the targeted
Platform.

« Option is specific to the target (MicroEJ Core Engine on Device or Simulator).

+ Option has been introduced in a newer version of the MicroEJ Architecture which is integrated in the targeted
Platform.

« Options related to Board Support Package (BSP) connection.

Defining an Option

A MicroEJ Standalone Application option can be defined either from a launcher or from a properties file. It is also
possible to use both together. Each MicroEJ Architecture and MicroEJ Pack option comes with a default value,
which is used if the option has not been set by the user.

Using a Launcher

To set an option in a launcher, perform the following steps:

1. In MicroEJ SDK, select Run > Run Configurations... menu,
2. Select the launcher of the application under MicroEJ Application or create a new one,

3. Select the Configuration tab,

4. Find the desired option and set it to the desired value.

It is recommended to index the launcher configuration to your version control system. To export launcher options
to the filesystem, perform the following steps:

1. Selectthe Common tab,
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2. Selectthe Shared file: option and browse the desired export folder,

3. Pressthe Apply button. Afile named [launcher_configuration_name].launch is generated in the ex-
port folder.

Using a Properties File

Options can be also be defined in properties files.

When a MicroEJ Standalone Application is built using the firmware-singleapp skeleton, options are loaded from
properties files located in the build folder at the root of the project.

The properties files are loaded in the following order:

1. Every file matching build/sim/x.properties, for Simulator options only (Virtual Device build). These files
are optional.

2. Every file matching build/emb/*.properties , for Device options only (Firmware build). These files are
optional.

3. Everyfile matching build/*.properties,both for Simulatorand Device options. At least onefileis required.
Usually, the build folder contains a single file named common.properties.

In case an option is defined in multiple properties files, the option of the first loaded file is taken into account and
the same option defined in the other files is ignored (a loaded option cannot be overridden).

The figure below shows the expected tree of the build folder:

v [ build
v [ emb
=| emb.properties
w [~ sim
=| sim.properties

& commeon.properties

Fig. 15: Build Options Folder

It is recommended to index the properties files to your version control system.

To set an option in a properties file, open the file in a text editor and add a line to set the desired option to the
desired value. For example: soar.generate.classnames=false.

To use the options declared in properties files in a launcher, perform the following steps:
1. In MicroEJ SDK, select Run > Run Configurations... ,
2. Select the launcher of the application,
3. Selectthe Execution tab,
4. Under Option Files , pressthe Add... button,

5. Browse the sim.properties file for Simulator or the emb.properties file for Device (if any) and press
Open button,
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6.

Add the common.properties file and press the Open button.

Note: An option set in a properties file can not be modified in the Configuration tab. Options are loaded in the
order the properties files are added (you can use Up and Down buttons to change the file order). In Configuration
tab, hovering the pointer over an option field will show the location of the properties file that defines the option.

Generating a Properties File

In order to export options defined ina . launch file to a properties file, perform the following steps:

1.

N

> W

Selectthe [launcher_configuration_name].launch file,
Select File > Export > MicroEJ > Launcher as Properties File ,
Browse the desired output .properties file,

Press the Finish button.

Category: Runtime

~ Device

T
w CoreEngine 4P
Kernel [ Embed all type names
Watchdog
Deploy Assertions
v Feature [] Execute assertions on Simulator
Dynamic Download
w Libraries [] Execute assertions on Device
v ECOM
Comm Connection Trace
EDC [JEnable execution traces
External Resources Loader
Shielded Plug [ Start execution traces automatically
w Runtime
Memory

~ Simulator

Code Coverage
Com Port
Debug

Device

Heap Dumper
Logs

Group: Types

Option(checkbox): Embed all type names

Option Name: soar.generate.classnames

Default value: true

Description:
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Embed the name of all types. When this option is disabled, only names of declared required types are embedded.

Group: Assertions
Option(checkbox): Execute assertions on Simulator

Option Name: core.assertions.sim.enabled
Default value: false
Description:

When this option is enabled, assert statements are executed. Please note that the executed code may produce
side effects or throw java.lang.AssertionError.

Option(checkbox): Execute assertions on Device

Option Name: core.assertions.emb.enabled
Default value: false
Description:

When this option is enabled, assert statements are executed. Please note that the executed code may produce
side effects or throw java.lang.AssertionError.

Group: Trace
Option(checkbox): Enable execution traces

Option Name: core.trace.enabled

Default value: false

Option(checkbox): Start execution traces automatically

Option Name: core.trace.autostart

Default value: false
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Category: Memory

w Device Heaps

v CoreEngine L
Kernel Java heap size (in bytes) | |
Watchdog
Deploy
w Feature

Immortal heap size (in bytes) | |

Dynamic Download Threads

w Libraries Number of threads | |
v ECOM
Comm Connection Number of blocks in pool | |

EDC
External Resources Loader Block size (in bytes) | |
Shielded Plug

w Runtime Maximum size of thread stack (in blocks) | |
Memory

Simulator

<

Code Coverage
Com Port
Debug

Device

Heap Dumper
Logs

Group: Heaps
Option(text): Java heap size (in bytes)

Option Name: core.memory. javaheap.size
Default value: 65536

Description:

Specifies the Java heap size in bytes.

A Java heap contains live Java objects. An OutOfMemory error can occur if the heap is too small.

Option(text): Immortal heap size (in bytes)

Option Name: core.memory.immortal.size
Default value: 4096

Description:

Specifies the Immortal heap size in bytes.

The Immortal heap contains allocated Immortal objects. An OutOfMemory error can occur if the heap is too small.

Group: Threads

Description:
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This group allows the configuration of application and library thread(s). A thread needs a stack to run. This stack
is allocated from a pool and this pool contains several blocks. Each block has the same size. At thread startup the
thread uses only one block for its stack. When the first block is full it uses another block. The maximum number of
blocks per thread must be specified. When the maximum number of blocks for a thread is reached or when there
is no free block in the pool, a StackOverflow error is thrown. When a thread terminates all associated blocks are
freed. These blocks can then be used by other threads.

Option(text): Number of threads

Option Name: core.memory.threads.size
Default value: 5
Description:

Specifies the number of threads the application will be able to use at the same time.

Option(text): Number of blocks in pool

Option Name: core.memory.threads.pool.size
Default value: 15
Description:

Specifies the number of blocks in the stacks pool.

Option(text): Block size (in bytes)

Option Name: core.memory.thread.block.size
Default value: 512
Description:

Specifies the thread stack block size (in bytes).

Option(text): Maximum size of thread stack (in blocks)

Option Name: core.memory.thread.max.size
Default value: 4
Description:

Specifies the maximum number of blocks a thread can use. If a thread requires more blocks a StackOverflow error
will occur.
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Category: Simulator

w Device Options
~ Core Engine

Kernel |:| Use target characteristics

Watchd
arendeg Slowing factor (0 means disabled): |
Deploy
Feat
v reature . HIL Connection
Dynamic Download
~ Libraries [ Specify a port
~ ECOM
Comm Connection Port: | ‘
EDC
External Resources Loader Timeout (s): | ‘
Shielded Plug
+ Runtime Maximum frame size (bytes) : | ‘
Memory
~ Simulater Shielded Plug server configuration

Code Coverage
Com Port
Debug

Device

Heap Dumper
Kernel

Server socket port: | ‘

Legs

Group: Options

Description:

This group specifies options for MicroEJ Simulator.

Option(checkbox): Use target characteristics

Option Name: s3.board.compliant
Default value: false
Description:

When selected, this option forces the MicroEJ Simulator to use the MicroEJ Platform exact characteristics. It sets
the MicroEJ Simulator scheduling policy according to the MicroEJ Platform one. It forces resources to be explicitly
specified. It enables log trace and gives information about the RAM memory size the MicroEJ Platform uses.

Option(text): Slowing factor (0 means disabled)

Option Name: s3.slow
Default value: 0
Description:

Format: Positive integer

This option allows the MicroEJ Simulator to be slowed down in order to match the MicroEJ Platform execution
speed. The greater the slowing factor, the slower the MicroEJ Simulator runs.
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Group: HIL Connection

Description:

This group enables the control of HIL (Hardware In the Loop) connection parameters (connection between MicroEJ
Simulator and the Mocks).

Option(checkbox): Specify a port

Option Name: s3.hil.use.port
Default value: false
Description:

When selected allows the use of a specific HIL connection port, otherwise a random free port is used.

Option(text): Port

Option Name: s3.hil.port
Default value: 8001
Description:

Format: Positive integer
Values: [1024-65535]

It specifies the port used by the MicroEJ Simulator to accept HIL connections.

Option(text): Timeout (s)

Option Name: s3.hil.timeout
Default value: 10

Description:

Format: Positive integer

It specifies the time the MicroEJ Simulator should wait before failing when it invokes native methods.

Option(text): Maximum frame size (bytes)

Option Name: com.microej.simulator.hil.frame.size
Default value: 262144
Description:

Maximum frame size in bytes. Must be increased to transfer large arrays to native side.
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Group: Shielded Plug server configuration

Description:

This group allows configuration of the Shielded Plug database.

Option(text): Server socket port

Option Name: sp.server.port
Default value: 10082
Description:

Set the Shielded Plug server socket port.

Category: Code Coverage

~ Device Code Coverage

w CoreEngine _
Kernel [ Activate code coverage analysis
Watchdog
Deploy
w Feature
Dynamic Download
~ Libraries
w ECOM
Comm Connection
EDC
External Resources Loader
Shielded Plug
~ Runtime
Memaory
Simulator

<

Code Coverage
Com Port
Debug

Device

Heap Dumper
Logs

Group: Code Coverage

Description:

This group is used to set parameters of the code coverage analysis tool.

Option(checkbox): Activate code coverage analysis

Option Name: s3.cc.activated

Default value: false
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Description:

When selected it enables the code coverage analysis by the MicroEJ Simulator. Resulting files are output in the cc
directory inside the output directory. You can process these files to an HTML report afterward with the built-in Code
Coverage Analyzer .

Option(text): Saving coverage information period (in sec.)

Option Name: s3.cc.thread.period
Default value: 15
Description:

It specifies the period between the generation of .cc files.

Category: Debug

v Device Remote Debug
w CoreEngine
Kernel Debug port: | 12000
Watchdog
Deploy
~ Feature

Dynamic Download
w Libraries
w ECOM
Comm Connection
EDC
External Resources Loader
Shielded Plug
w Runtime
Memory
w Simulator
Code Coverage
Com Port
Debug
Device
Heap Dumper
Logs

Group: Remote Debug
Option(text): Debug port

Option Name: debug.port
Default value: 12000

Description:

Configures the JDWP debug port.

Format: Positive integer
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Values: [1024-65535]

Category: Heap Dumper

w Device Heap Inspection
w CoreEngine
Kernel
Watchdog
Deploy
w Feature

[ Activate heap dumper

Dynamic Download
w Libraries
v ECOM
Comm Cennection
EDC
External Resources Loader
Shielded Plug
w Runtime
Memory
Simulator

<

Code Coverage
Com Port
Debug

Device

Heap Dumper
Logs

Group: Heap Inspection

Description:

This group is used to specify heap inspection properties.

Option(checkbox): Activate heap dumper

Option Name: s3.inspect.heap
Default value: false
Description:

When selected, this option enables a dump of the heap each time the System.gc() method is called by the MicroEJ
Application.
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Category: Logs

w Device

Logs
v CoreEngine L
system thread maonitoring
Kernel 2
Watchdog memory schedule monitors
Deploy
w Feature 2

Dynamic Download
~ Libraries
w ECOM
Comm Connection
EDC
External Resources Loader
Shielded Plug
~ Runtime
Memory
Simulator

<

Code Coverage
Com Port
Debug

Device

Heap Dumper
Logs

Group: Logs

Description:

This group defines parameters for MicroEJ Simulator log activity. Note that logs can only be generated if the
Simulator > Use target characteristics optionis selected.

Some logs are sent when the platform executes some specific action (such as start thread, start GC, etc), other logs
are sent periodically (according to defined log level and the log periodicity).

Option(checkbox): system

Option Name: console.logs.level.low

Default value: false

Description:

When selected, System logs are sent when the platform executes the following actions:
start and terminate a thread

start and terminate a GC

exit

Option(checkbox): thread

Option Name: console.logs.level.thread
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Default value: false
Description:

When selected, thread information is sent periodically. It gives information about alive threads (status, memory
allocation, stack size).

Option(checkbox): monitoring

Option Name: console.logs.level .monitoring
Default value: false
Description:

When selected, thread monitoring logs are sent periodically. It gives information about time execution of threads.

Option(checkbox): memory

Option Name: console.logs.level .memory
Default value: false
Description:

When selected, memory allocation logs are sent periodically. This level allows to supervise memory allocation.

Option(checkbox): schedule

Option Name: console.logs.level.schedule
Default value: false
Description:

When selected, a log is sent when the platform schedules a thread.

Option(checkbox): monitors

Option Name: console.logs.level .monitors
Default value: false
Description:

When selected, monitors information is sent periodically. This level permits tracing of all thread state by tracing
monitor operations.

Option(text): period (in sec.)

Option Name: console.logs.period
Default value: 2
Description:

Format: Positive integer
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Values: [0-60]

Defines the periodicity of periodical logs.

Category: Device

w Device Device Architecture
w CoreEngine
Kernel
Watchdog
Deploy

[] Use a custom device architecture

~ Feature
Device Uni D
Dynamic Download evice Lnique

w Libraries [ Use a custom device unique ID
w ECOM
Comm Cennection
EDC
External Resources Loader
Shielded Plug
w Runtime
Memory
~ Simulator
Code Coverage
Com Port
Debug
Device
Heap Dumper
Logs

Group: Device Architecture

Option(checkbox): Use a custom device architecture

Option Name: s3.mock.device.architecture.option.use

Default value: false

Option(text): Architecture Name

Option Name: s3.mock.device.architecture.option

Default value: (empty)

Group: Device Unique ID

Option(checkbox): Use a custom device unique ID

Option Name: s3.mock.device.id.option.use

Default value: false
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Option(text): Unique ID (hexadecimal value)

Option Name: s3.mock.device.id.option

Default value: (empty)

Category: Com Port

w Device
w CoreEngine
Kernel
Watchdog
Deploy
w Feature
Dynamic Download
w Libraries
v ECOM
Comm Cennection
EDC
External Resources Loader
Shielded Plug
w Runtime
Memory
~ Simulator
Code Coverage
Com Port
Debug
Device
Heap Dumper
Logs
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Category: Libraries

w Device
w CoreEngine
Kernel
Watchdog
Deploy
w Feature
Dynamic Download
w Libraries
v ECOM
Comm Cennection
EDC
External Resources Loader
Shielded Plug
w Runtime
Memory
~ Simulator
Code Coverage
Com Port
Debug
Device
Heap Dumper
Logs

Category: EDC

w Device Java System.out

v Cor;:rr;gewlne [ Use a custom Java output stream
Watchdog
Deploy
w Feature

Runti ti
Dynamic Download B

~ Libraries Embed UTF-8 enceding
v ECOM .
Comm Connection []Enable SecurityManager checks
EDC
External Resources Loader
Shielded Plug

~ Runtime
Memary

w Simulator
Code Coverage
Com Port
Debug
Device
Heap Dumper
Logs

Group: Java System.out
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Option(checkbox): Use a custom Java output stream

Option Name: core.outputstream.disable.uart

Default value: false

Description:

Select this option to specify another Java System.out print stream.

If selected, the default Java output stream is not used by the Java application. the JPF will not use the default Java
output stream at startup.

Option(text): Class

Option Name: core.outputstream.class

Default value: (empty)

Description:

Format: Java class like packageA.packageB.className
Defines the Java class used to manage System.out.

At startup the JPF will try to load this class using the Class.forName() method. If the given class is not available,
the JPF will use the default Java output stream as usual. The specified class must be available in the application
classpath.

Group: Runtime options

Description:

Specifies the additional classes to embed at runtime.

Option(checkbox): Embed UTF-8 encoding

Option Name: cldc.encoding.utf8.included
Default value: true
Description:

Embed UTF-8 encoding.

Option(checkbox): Enable SecurityManager checks

Option Name: com.microej.library.edc.securitymanager.enabled
Default value: false
Description:

Enable the security manager runtime checks.
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Category: Shielded Plug

v Device Shielded Plug configuration
v CoreEngine
Kernel Database definition: Browse...
Watchdog
Deploy
w Feature

Dynamic Download
~ Libraries
w ECOM
Comm Connection
EDC
External Resources Loader
Shielded Plug
~ Runtime
Memory
w Simulator
Code Coverage
Com Port
Debug
Device
Heap Dumper
Logs

Group: Shielded Plug configuration

Description:

Choose the database XML definition.

Option(browse): Database definition

Option Name: sp.database.definition
Default value: (empty)
Description:

Choose the database XML definition.
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Category: ECOM

w Device Device Management

v CoreEngine ] ) -
Kernel [ Enable registration event notifications
Watchdog
Deploy
w Feature
Dynamic Download
~ Libraries
w ECOM
Comm Connection
EDC
External Resources Loader
Shielded Plug
~ Runtime
Memory
w Simulator
Code Coverage
Com Port
Debug
Device
Heap Dumper
Logs

Group: Device Management
Option(checkbox): Enable registration event notifications

Option Name: com.is2t.ecom.eventpump.enabled
Default value: false
Description:

Enables notification of listeners when devices are registered or unregistered. When a device is registered or un-
registered, a new ej.ecom.io.RegistrationEvent isadded to an event queue. Then events are processed by a
dedicated thread that notifies registered listeners.

Option(text): Registration events queue size

Option Name: com.is2t.ecom.eventpump.size
Default value: 5
Description:

Specifies the size (in number of events) of the registration events queue.
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Category: Comm Connection

w Device Comm Connection Options

w CoreEngine

Kernel []Enable comm connections

Watchdog
Deploy Device Management

v Feature Enable dynamic comm ports registration
Dynamic Download
~ Libraries
v ECOM
Comm Connection
EDC
External Resources Loader
Shielded Plug
~ Runtime
Memory
~ Simulator
Code Coverage
Com Port
Debug
Device
Heap Dumper
Logs

Group: Comm Connection Options

Description:

This group allows comm connections to be enabled and application-platform mappings set.

Option(checkbox): Enable comm connections

Option Name: use.comm.connection
Default value: false
Description:

When checked application is able to open a CommConnection.

Group: Device Management
Option(checkbox): Enable dynamic comm ports registration

Option Name: com.is2t.ecom.comm.registryPump.enabled
Default value: false
Description:

Enables registration (or unregistration) of ports dynamically added (or removed) by the platform. A dedicated
thread listens for ports dynamically added (or removed) by the platform and adds (or removes) their CommPort
representation to the ECOM DeviceManager .
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Category: External Resources Loader

<

Device External Resources Loader

v CoreEngine

Kernel Folder where are stored the resources which will be pregrammed outside CPU address
space range (storage media like SD card, serial NOR flash, EEPROM).
Watchdog The resources which will be linked into the CPU address space range (internal
Deploy device memeories, external parallel memories) must be listed in the Resources box
w Feature of Main tab.

Dynamic Download

~ Libraries
v ECOM
Comm Connection
EDC
External Resources Loader
Shielded Plug
~ Runtime

Browse...

Memory

w Simulator
Code Coverage
Com Port
Debug
Device
Heap Dumper
Logs

Group: External Resources Loader

Description:

This group allows to specify the external resources input folder. The content of this folder will be copied in an
application output folder and used by SOAR and the Simulator. If empty, the default location will be [output
folder]/externalResources, where [output folder] is the location defined in Execution tab.

Option(browse):

Option Name: ej.externalResources.input.dir
Default value: (empty)
Description:

Browse to specify the external resources folder..
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Category: Device

Device

<

« CoreEngine Specify target options

Kernel
Watchdog
Deploy
~ Feature
Dynamic Download
w Libraries
w ECOM
Comm Connection
EDC
External Resources Loader
Shielded Plug
w Runtime
Memory
w Simulator
Code Coverage
Com Port
Debug
Device
Heap Dumper
Logs

Category: Core Engine

~ Device Memory

~ Core Engine

Kernel
Watchdog
Deploy
~ Feature

Maximum number of menitors per thread | ‘

Maximum number of frames dumped on OutOfMemoryError | ‘

Dynamic Download [[] Enable Java heap usage monitering

~ Libraries Java heap initial size (in bytes) |
v ECOM

Comm Connection
EDC
External Resources Loader [ Enable Bytecode Verifier
Shielded Plug
~ Runtime

SOAR

Memory

~ Simulator
Code Coverage
Corn Port
Debug
Device
Heap Dumper
Kernel
Logs

Group: Memory
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Option(text):

Option Name: core.memory.thread.max.nb.monitors
Default value: 8
Description:

Specifies the maximum number of monitors a thread can own at the same time.

Option(text):

Option Name: core.memory.oome.nb.frames
Default value: 5
Description:

Specifies the maximum number of stack frames that can be dumped to the standard output when Core Engine
throws an OutOfMemoryError.

Option(checkbox): Enable Java heap usage monitoring

Option Name: com.microej.runtime.debug.heap.monitoring.enabled

Default value: false

Option(text):

Option Name: com.microej.runtime.debug.heap.monitoring.init.size
Default value: 0
Description:

Specify the initial size (in bytes) of the Java Heap.

Group: SOAR
Option(checkbox): Enable Bytecode Verifier

Option Name: soar.bytecode.verifier

Default value: false
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Category: Kernel

Devi
v e [] Check APIs allowed by Kernel
w CoreEngine
Kernel Threads
Watchdog Mazximum number of threads per Feature | |
Deploy
w Feature

Installed Features
Dynamic Download

~ Libraries Mazximum number of installed Features | |
w ECOM
Comm Connection Code Size (in bytes) | |
EDC
External Resources Loader Runtime Size (in bytes) | |
Shielded Plug

~ Runtime
Memary

w Simulator
Code Coverage
Com Port
Debug
Device
Heap Dumper
Logs

Option(checkbox): Check APIs allowed by Kernel

Option Name: apis.check.enable

Default value: true

Group: Threads
Option(text):

Option Name: core.memory.feature.max.threads
Default value: 5
Description:

Specifies the maximum number of threads a Feature is allowed to use at the same time.

Group: Installed Features
Option(text):

Option Name: core.memory.installed.features.max
Default value: ©
Description:

Specifies the maximum number of installed Features that can be added to this Kernel.
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Option(text):

Option Name: core.memory.installed.features.text.size

Default value: 0

Description:

Specifies the size in bytes reserved for installed Features code.

Option(text):

Option Name: core.memory.installed.features.bss.size

Default value: 0

Description:

Specifies the size in bytes reserved for installed Features runtime memory.

Category: Watchdog

~ Device
« CoreEngine [[]1Enable watchdeg support

Kernel Watchdog
Watchdog Maximum number of active watchdogs
Deploy

~ Feature
Dynamic Download
w Libraries
w ECOM
Comm Connection
EDC
External Resources Loader
Shielded Plug
w Runtime
Memory
w Simulator
Code Coverage
Com Port
Debug
Device
Heap Dumper
Logs

Option(checkbox): Enable watchdog support

Option Name: enable.watchdog.support

Default value: true
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Group: Watchdog
Option(text):

Option Name: maximum.active.watchdogs
Default value: 4
Description:

Specifies the maximum number of active watchdogs at the same time.

Category: Deploy

v Device Configuration
v CoreEngine I o o : i :
Kernel [] Deploy the compiled MicroEJ application in a folder in MicroEJ application main class project
Watchdog
Output file: | Browse...
Deploy
~ Feature

Dynamic Download
w Libraries
w ECOM
Comm Connection
EDC
External Resources Loader
Shielded Plug
w Runtime
Memory
w Simulator
Code Coverage
Com Port
Debug
Device
Heap Dumper
Logs

Description:

Configures the output location where store the MicroEJ Application, the MicroEJ platform libraries and header files.

Group: Configuration

Option(checkbox): Deploy the compiled MicroEJ Application in a folder in MicroEJ Application main class
project

Default value: true
Description:

Deploy the compiled MicroEJ Application in a folder in MicroEJ Application’s main class project.
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Option(browse): Output file

Option Name: deploy.copy.filename

Default value: (empty)

Description:

Choose an output file location where copy the compiled MicroEJ Application.

Category: Feature

w Device
w CoreEngine
Kernel
Watchdog
Deploy
~ Feature
Dynamic Download
w Libraries
v ECOM
Comm Connection
EDC
External Resources Loader
Shielded Plug
w Runtime
Memory
~ Simulator
Code Coverage
Com Port
Debug
Device
Heap Dumper
Logs

Description:

Specify Feature options

Specify Feature options

4.2. Standalone Application

107



MicroEJ Documentation, Revision c72145fb

Category: Dynamic Download

v Device Dynamic Download
v CoreEngine
Kernel Output Name: |
Watchdog
Deploy Kernel: | F—
w Feature

Dynamic Download
~ Libraries
w ECOM
Comm Connection
EDC
External Resources Loader
Shielded Plug
~ Runtime
Memory
Simulator

<

Code Coverage
Com Port
Debug

Device

Heap Dumper
Logs

Group: Dynamic Download
Option(text): Output Name

Option Name: feature.output.basename

Default value: application

Option(browse): Kernel

Option Name: kernel.filename

Default value: (empty)

4.2.6 SOAR

This chapter describes SOAR capabilities and optimizations from the Application developer’s point of view. To get
more details on its internal structure, please refer to SOAR Build Phases section.

Class Initialization Code

SOAR complies with the deterministic class initialization ( <clinit>) order specified in [BON] specification. The
application is statically analyzed from its entry points in order to generate a clinit dependency graph. The com-
puted clinit sequence is the result of the topological sort of the dependency graph. An error is thrown if the clinit
dependency graph contains cycles.
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Aclinit map file (ending with extension .clinitmap)is generated beside the SOAR object file. It describes for each
clinit dependency:

» the typesinvolved
« the kind of dependency
« the stack calls between the two types

In case of complex clinit code with too many runtime dependencies, the statically computed clinit order may be
wrong.

Itisthen possible to help SOAR by manually declaring explicit clinit dependencies. Such dependencies are declared
in XML files with the .clinitdesc extension in the application classpath.

The file has the following format:

<?xml version='1.0' encoding='UTF-8'7?>
<clinit>

<type name="T1" depends="T2"/>
</clinit>

where T1 and T2 are fully qualified names on the form a.b.C. This explicitly forces SOAR to create a dependency
from T1 to T2, and therefore cuts a potentially detected dependency from T2 to T1.

Method Devirtualization

Method devirtualization consists of transforming a virtual method call to a direct method call when possible. A
virtual method call is a call to a non-private instance method declared either in an interface orin a class. The Core
Engine determines the proper method to call at runtime depending on the actual class of the object. A call to a
constructor or a private method is already optimized as a direct method call by the Java compiler.

SOAR automatically optimizes a virtual method call to a direct method call if there is one and only one embedded
implementation method.

Note: SOAR generates the list of the embedded methods in the SOAR Information File.

Method Inlining

Method inlining consists of replacing a direct method call with the content of the method. This avoids the creation
of a new stack frame context, which can be slower than executing the code itself. Method inlining is transitively
applied from leaf to root methods.

The following method code patterns are inlined:

« empty code after processing assertions and if code removal.

« call to a constructor with no parameters.
« call to a private method with no parameters.

« call to a static method with no parameters, if and only if the caller is also a static method.

Note: Method inliningis performed after method devirtualization, so a virtual method call will be inlined if there is
a unique embedded implementation method that matches one of the inlined method code patterns.
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4.3 Sandboxed Application

4.3.1 Sandboxed Application Structure

Application Skeleton Creation

The first step to explore a Sandboxed Application structure is to create a new project.

First select File > New > Sandboxed Application Project :

Fill in the application template fields, the Project name field will automatically duplicate in the following fields.

A template project is automatically created and ready to use, this project already contains all folders wherein de-
velopers need to put content:

src/main/java Folder for future sources;
src/main/resources Folder for future resources (images, fonts, etc.);
META-INF Sandboxed Application configuration and resources;

module.ivy Module description file, dependencies description for the current project.

Sources Folder

The project source folder ( src/main) contains two subfolders: java and resources. java folderwill contain all
% java files of the project, whereas resources folder will contain elements that the application needs at runtime
like raw resources, images or character fonts.

META-INF Folder

The META-INF folder contains several folders and a manifest file. They are described hereafter.
certificate (folder) Contains certificate information used during the application deployment.

libraries (folder) Contains a list of additional libraries useful to the application and not resolved through the
regular transitive dependency check.

properties (folder) Containsan application.properties file which contains application specific properties
that can be accessed at runtime.

services (folder) Contains a list of files that describe local services provided by the application. Each file name
represents a service class fully qualified name, and each file contains the fully qualified name of the provided
service implementation.

wpk (folder) Contains a set of applications ( .wpk files) that will be started when the application is executed on
the Simulator.

MANIFEST.MF (file) Containsthe information given at project creation, extra information can be added to this file
to declare the entry points of the application.

module. ivy File

The module.ivy file describes all the libraries required by the application at runtime. The lvy classpath container
lists all the modules that have been automatically resolved from the content of module.ivy . See MicroEJ Module
Manager for more informations about MicroEJ Module Manager.
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4.3.2 Application Publication
Build the WPK

When the application is ready for deployment, the last step is to create the WPK (Wadapps PacKage) file that is
intended to be published on a MicroEJ Forge instance for end users.

In the SDK, right-click on the Sandboxed Application project name and select Build Module.

The WPK build process will display messages in MicroEJ console, ending up the following message:

[echo] project hello published locally with version 0.1.0-RC201907091602
BUILD SUCCESSFUL

Total time: 1 minute 6 seconds

The WPK file produced by the build process is located in a dedicated target~/artifacts folderinthe projectand
is published to the target module repository declared in MicroEJ Module Manager settings file.

The module repository can be a MicroEJ Forge instance.

4.3.3 Shared Interfaces
Principle

The Shared Interface mechanism provided by MicroEJ Core Engine is an object communication bus based on plain
Java interfaces where method calls are allowed to cross MicroEJ Sandboxed Applications boundaries. The Shared
Interface mechanism is the cornerstone for designing reliable Service Oriented Architectures on top of MicroEJ.
Communication is based on the sharing of interfaces defining APIs (Contract Oriented Programming).

The basic schema:
« Aprovider application publishes an implementation for a shared interface into a system registry.

« Auser application retrieves the implementation from the system registry and directly calls the methods de-
fined by the shared interface.

USER APPLICATION FROVIDER AFPLICALITON
Shared Interface Call
AA.mm() >

MICROEJ CORE ENGINE

Fig. 16: Shared Interface Call Mechanism

Shared Interface Creation

Creation of a Shared Interface follows three steps:

« Interface definition,
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« Proxy implementation,

« Interface registration.

Interface Definition

The definition of a Shared Interface starts by defining a standard Java interface.

package mypackage;

public interface MyInterface(
void foo();

3

To declare aninterface as a Shared Interface, it must be registered in a Shared Interfaces identification file. A Shared
Interface identification file is an XML file with the .si suffix with the following format:

<sharedInterfaces>
<sharedInterface name="mypackage.MyInterface"/>
</sharedInterfaces>

Shared Interface identification files must be placed at the root of a path of the application classpath. For a MicroEJ
Sandboxed Application project, it is typically placed in src/main/resources folder.
Some restrictions apply to Shared Interfaces compared to standard java interfaces:

« Types for parameters and return values must be transferable types;

« Thrown exceptions must be classes owned by the MicroEJ Firmware.

Transferable Types

In the process of a cross-application method call, parameters and return value of methods declared in a Shared
Interface must be transferred back and forth between application boundaries.

USER APPLICATION Shared Interface Transfer FRASAAMSAAASSALLTA.

R = AA.mm(P1, P2)

Fig. 17: Shared Interface Parameters Transfer

Shared Interface Types Transfer Rules describes the rules applied depending on the element to be transferred.
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Table 1: Shared Interface Types Transfer Rules

Type Owner Instance Rule
Owner

Base type N/A N/A Passing by value. (boolean, byte, short
, char, int, long, double, float)

Any Class, Array or Inter- | Kernel Kernel Passing by reference

face

Any Class, Array or Inter- | Kernel Application Kernel specific or forbidden

face

Array of base types Any Application Clone by copy

Arrays of references Any Application Clone and transfer rules applied again on
each element

Shared Interface Application Application Passing by indirect reference (Proxy cre-
ation)

Any Class, Array or Inter- | Application Application Forbidden

face

Objects created by a Sandboxed Application which type is owned by the Kernel can be transferred to another Sand-
boxed Application provided this has been authorized by the Kernel. The list of Kernel types that can be transferred
is Kernel specific, so you have to consult your Kernel specification. When an argument transfer is forbidden, the
callis abruptly stopped and a java.lang.IllegalAccessError isthrown by the Core Engine.

Note:
Kernel.

For these types to be transferable, a dedicated Kernel Type Converter must have been registered in the

The table below shows typical Kernel types allowed to be transferred through a Shared Interface call on Evaluation
Firmware distributed by MicroEJ Corp.

Table 2: MicroEJ Evaluation Firmware Example of Transfer Types

Type Rule
java.lang.Boolean Clone by copy
| java.lang.Byte Clone by copy
| java.lang.Character | Clone by copy
| java.lang.Short Clone by copy
| java.lang.Integer Clone by copy
| java.lang.Float Clone by copy
| java.lang.Long Clone by copy
java.lang.Double Clone by copy
| java.lang.String Clone by copy
java.io.InputStream | Create a Proxy reference
| java.util.Date Clone by copy

| java.util.List<T>
java.util.Map<K,v>

Clone by copy with recursive element conversion

Clone by copy with recursive keys and values conversion

Proxy Class Implementation

The Shared Interface mechanism is based on automatic proxy objects created by the underlying MicroEJ Core En-
gine, so that each application can still be dynamically stopped and uninstalled. This offers a reliable way for users
and providers to handle the relationship in case of a broken link.
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Once a Java interface has been declared as Shared Interface, a dedicated implementation is required (called the
Proxy class implementation). Its main goal is to perform the remote invocation and provide a reliable implemen-
tation regarding the interface contract even if the remote application fails to fulfill its contract (unexpected excep-
tions, application killed...). The MicroEJ Core Engine will allocate instances of this class when an implementation
owned by another application is being transferred to this application.

USER APPLICATION

R = AA.mm(P1, P2

Proxy Class

EROVIDERAEELICATION

MICROEJ CORE ENGINE

Invoke

Transfer

Shared Interfaces Binding

Fig. 18: Shared Interfaces Proxy Overview

A proxy class is implemented and executed on the client side, each method of the implemented interface must be

defined according to the following pattern:

package mypackage;

public class MyInterfaceProxy extends Proxy<MyInterface> implements MyInterface {

@Override
public void foo(){
try {

invoke(); // perform remote invocation

} catch (Throwable e) {
e.printStackTrace();
3

3

Each implemented method of the proxy class is responsible for performing the remote call and catching all errors
from the server side and to provide an appropriate answer to the client application call according to the interface
method specification (contract). Remote invocation methods are defined in the super class ej.kf.Proxy and are
named invokeXXX() where XXX is the kind of return type. As this class is part of the application, the application
developer has the full control on the Proxy implementation and is free to insert additional code such as logging

calls and errors for example.

Table 3: Proxy Remote Invocation Built-in Methods

Invocation Method

Usage

void invoke()

Remote invocation for a proxy method that returns void

Object invokeRef()

Remote invocation for a proxy method that returns a reference

boolean invokeBoolean(), byte invokeByte(),
char invokeChar(), short invokeShort(), int in-
vokelnt(), long invokeLong(), double invoke-
Double(), float invokeFloat()

Remote invocation for a proxy method that returns a base type

4.3. Sandboxed Application
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4.4 MicroEJ Libraries

A MicroEJ Foundation Library is a MicroEJ Core library that provides core runtime APIs or hardware-dependent
functionality. A Foundation library is divided into an APl and an implementation. A Foundation library APl is com-
posed of a name and a 2 digits version (e.g. EDC-1.3) and follows the semantic versioning (http://semver.org)
specification. A Foundation Library API only contains prototypes without code. Foundation Library implementa-
tions are provided by MicroEJ Platforms. From a MicroEJ Classpath, Foundation Library APIs dependencies are
automatically mapped to the associated implementations provided by the Platform or the Virtual Device on which
the application is being executed.

A MicroEJ Add-On Library is a MicroEJ library that is implemented on top of MicroEJ Foundation Libraries (100%
full Java code). A MicroEJ Add-On Library is distributed in a single JAR file, with a 3 digits version and provides its
associated source code.

Foundation and Add-On Libraries are added to MicroEJ Classpath by the application developer as module depen-
dencies (see MicroEJ Module Manager).

YOUR APPLICATIONS

ADD-ON LIBRARIES

FOUNDATION LIBRARIES

—

Fig. 19: MicroEJ Foundation Libraries and Add-On Libraries

Java code

MicroEJ Corp. provides a large number of libraries through the MicroEJ Central Repository. To consult its libraries
APIs documentation, please visit https://developer.microej.com/microej-apis/.

4.5 Virtual Device

The Virtual Device includes the same custom MicroEJ Core, libraries and System Applications as the real device.
The Virtual Device allows developers to run their applications either on the Simulator, or directly on the real device
through local deployment.

The Simulator runs a mockup board support package (BSP Mock) that mimics the hardware functionality. An ap-
plication on the Simulator is run as a Standalone Application.

Before an application is locally deployed on device, the SDK ensures that it does not depend on any API that is
unavailable on the device.
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YOUR APPLICATIONS

ADD-ON LIBRARIES

Web / REST servers | MQTT /LWM2M clients | JSON | CBOR | Crypto | Widgets | Components | Eclasspath | ...

FOUNDATION LIBRARIES

= BT

2 MICROEJ.VEE

VIRTUALIZATION

e -
Engine Simulator

Linux / Windows [ macOS

PLATFORM

D PROCESSOR
CORE Serial Bluetooth

WORKSTATION

Ethernet

Wi-Fi / LTE Display

Fig. 20: MicroEJ Virtual Device Architecture

4.6 MicroEJ Runtime

4.6.1 Language
MicroEJ allows to develop Applications in the Java® Language Specification version 7, and supports code exten-
sions written in JavaScript.

Basically, Java source code is compiled by the Java compiler' into the binary format specified in the JVM specifica-
tion”. This binary code is linked by a tool named SOAR before execution: .class files and some other application-
related files (see Classpath chapter) are linked to produce the final binary file that the Core Engine will execute.

4.6.2 Core Libraries

This section describes the core libraries which make up the runtime. Theses Foundation Libraries are tightly cou-
pled with the Core Engine.

Embedded Device Configuration (EDC)
The Embedded Device Configuration specification defines the minimal standard runtime environment for embed-
ded devices. It defines all default API packages:

« java.io

« java.lang

! The JDT compiler from the Eclipse IDE.
2 Tim Lindholm & Frank Yellin, The Java™ Virtual Machine Specification, Second Edition, 1999
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+ java.lang.annotation
« java.lang.ref

« java.lang.reflect

+ java.util
Documentation Link
Java APIs https://repository.microej.com/javadoc/microej_5.x/libraries/edc-1.3-api/
Module https://repository.microej.com/modules/ej/api/edc/
Beyond Profile (BON)

This profile defines a suitable and flexible way to fully control both memory usage and start-up sequences on de-
vices with limited memory resources. It does so within the boundaries of Java semantics. More precisely, it allows:

+ Controlling the initialization sequence in a deterministic way.

« Defining persistent, immutable, read-only objects (that may be placed into non-volatile memory areas), and
which do not require copies to be made in RAM to be manipulated.

« Defining immortal, read-write objects that are always alive.

+ Defining and accessing compile-time constants.

Documentation Link

Java APIs https://repository.microej.com/javadoc/microej_5.x/apis/ej/bon/
package-summary.html

Specification http://e-s-r.net/download/specification/ESR-SPE-0001-BON-1.2-F.pdf

Module https://repository.microej.com/modules/ej/api/bon/

Simple Native Interface (SNI)

SNI provides a simple mechanism for implementing native Java methods in the C language.
SNI allows you to:
« Call a Cfunction from a Java method.

+ Access an Immortal array in a C function (see the Beyond Profile (BON) to learn about immortal objects).

SNI does not allow you to:
« Access or create a Java object in a C function (except byte arrays).
« Access Java static variables in a C function.
+ Call Java methods from a C function.

SNI also provides some Java APIs to manipulate some data arrays between Java and the native (C) world.

Documentation Link

Java APlIs https://repository.microej.com/javadoc/microej_5.x/apis/ej/sni/
package-summary.html

Specification http://e-s-r.net/download/specification/ESR-SPE-0012-SNI_GT-1.2-H.pdf

Module https://repository.microej.com/modules/ej/api/sni/
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Please refer to Simple Native Interface (SNI) section for more details.

Kernel & Features (KF)

The Kernel & Features semantic (KF) extends the runtime for managing Multi-Sandboxed Applications.

Please refer to the Kernel & Features Specification for more details, the Multi-Sandbox capability of the Core Engine
and more generally the Kernel Developer Guide chapter.

4.6.3 Scheduler

The Core Engine features a Green Threads model. The semantic is as follows:
« preemptive for different priorities,
« round-robin for same priorities,
« “priority inheritance protocol” when priority inversion occurs.?

Threads stacks automatically adapt their sizes according to the thread requirements: once a thread terminates, its
associated stack is reclaimed, freeing the corresponding RAM memory.

4.6.4 Garbage Collector

The Core Engine includes a state-of-the-art memory management system, the Garbage Collector (GC). It manages
a bounded piece of RAM memory, devoted to the Java world. The GC automatically frees dead Java objects, and
defragments the memory in order to optimize RAM usage. This is done transparently while the Application keep
running.

4.7 Module Natures

This page describes the most common module natures as follows:
« Skeleton Name: the project skeleton name.

« Build Type Name: the build type name, derived from the module nature name: com.is2t.easyant.
buildtypes#build-[NATURE_NAME] .

« Documentation: a link to the documentation.

« SDK Menu: the menu to the direct wizard in MicroEJ SDK (if available). Any module nature can be created
with the default wizard from File > New > Module Project .

Configuration: properties that can be defined to configure the module. Properties are defined inside the
ea:build tag of the module.ivy file, using ea:property tag as described in the section Build Options. A
module nature also inherits the configuration properties from the listed Natures Plugins.

3 This protocol raises the priority of a thread that is holding a monitor needed by a higher-priority thread, to the priority of that higher-priority
thread (until exiting the monitor).
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4.7.1 Add-On Library

Skeleton Name: microej-javalib

Build Type Name: com.is2t.easyant.buildtypes#build-microej-javalib
Documentation: MicroEJ Libraries

SDKMenu: File > New > Add-On Library Project

Configuration:

This module nature inherits the configuration properties of the following plugins:

« Java Compilation

« Plat