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Welcome to MicroEJ developer documentation. Browse the following chapters to familiarize yourself with MicroEJ
Technology and understand the principles of app and platform development with MicroEJ.

The Glossary chapter describes MicroEJ terminology.
The Overview chapter introduces MicroEJ products and technology.
The Application Developer Guide presents Java applications development and debugging tools.

The Platform Developer Guide teaches you how to integrate a C Board Support as well as simulation config-
urations.

The Kernel Developer Guide introduces you to advanced concepts, such as partial updates and dynamic app
life cycle workflows.

The Tutorials chapter covers a variety of topics related to developing with the MicroEJ ecosystem.
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CHAPTER

ONE

MICROEJ GLOSSARY

This glossary defines the technical terms upon which the MicroEJ Virtual Execution Environment is built.

Add-On Library A MicroEJ Add-On Libraryis a pure managed code (Java) library. It runs over one or more MicroEJ
Foundation Libraries.

Abstraction Layer An Abstraction Layer is the C code that implements a Foundation Library’s low-level APIs over
a board support package (BSP) or a C library.

Application A MicroEJ Application is a software program that runs on a Powered by MicroEJ device.

Standalone Application MicroEJ Standalone Application is a MicroEJ Application that is directly
linked to the C code to produce a MicroEJ Mono-Sandbox Firmware. Itis edited using MicroEJ
SDK.

Sandboxed Application A MicroEJ Sandboxed Application is a MicroEJ Application that can run
over a MicrokEJ Multi-Sandbox Firmware. It can be linked either statically or dynamically.

System Application A MicroEJ System Application is a MicroEJ Sandboxed Application that is
statically linked to a MicroEJ Multi-Sandbox Firmware, as it is part of the initial image and
cannot be removed.

Kernel Application A MicroEJ Kernel Application is a MicroEJ Standalone Application that imple-
ments the ability to be extended to produce a MicroEJ Multi-Sandbox Firmware.

Architecture A MicroEJ Architecture is a software package that includes the MicroEJ Core Engine port to a target
instruction set and a C compiler, core MicroEJ Foundation Libraries (EDC, [BON], [SN/], [KF]) and the MicroEJ
Simulator. MicroEJ Architectures are distributed either as evaluation or production version.

Core Engine MicroEJ Core Engine is a scalable runtime for resource-constrained embedded devices running on
32-bit microcontrollers or microprocessors. MicroEJ Core Engine allows devices to run multiple and mixed
Java and C software applications.

Firmware A MicroEJ Firmware is the result of the binary link of a MicroEJ Standalone Application with a MicroEJ
Platform. The firmware is a binary program that can be programmed into the flash memory of a device.

Mono-Sandbox Firmware A MicroEJ Mono-Sandbox Firmware is a MicroEJ Firmware thatimple-
ments an unmodifiable set of functions. (previously MicroEJ Single-app Firmware)

Multi-Sandbox Firmware A MicroEJ Multi-Sandbox Firmware is a MicroEJ Firmware that imple-
ments the ability to be extended, by exposing a set of APIs and a memory space to link MicroEJ
Sandboxed Applications. (previously MicroEJ Multi-app Firmware)

Foundation Library AMicroEJ Foundation Libraryis a library that provides core or hardware-dependent function-
alities. A Foundation Library combines managed code (Java) and low-level APIs (C) implemented by one or
more Abstraction Layers through a native interface (SNV/).

Mock A MicroEJ Mock is a mockup of a Board Support Package capability that mimics an hardware functionality
for the MicroEJ Simulator.
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Module Manager MicroEJ Module Manager downloads, installs and controls the consistency of all the dependen-
cies and versions required to build and publish a MicroEJ asset. It is based on Semantic Versioning specifi-
cation.

Platform A MicroEJ Platform integrates a MicroEJ Architecture, one or more Foundation Libraries with their re-
spective Abstraction Layers and the board support package (BSP) for the target Device. It also includes asso-
ciated MicroEJ Mocks for the MicroEJ Simulator.

SDK MicroEJ SDK allows MicroEJ Firmware developers to build a MicroEJ-ready device, by integrating a MicroEJ
Architecture with both Java and C software on their device.

Simulator MicroEJ Simulator allows running MicroEJ Applications on a target hardware simulator on the devel-
oper’s desktop computer. The MicroEJ Simulator runs one or more MicrokEJ mock that mimics the hardware
functionality. It enables developers to develop their MicroEJ Applications without the need of hardware.

Studio MicroEJ Studio allows application developers to write a MicroEJ Sandboxed Application, run it on a Virtual
Device, deploy it on a MicroEJ-ready device, and publish it to a MicroEJ Forge instance.

Virtual Device A MicroEJ Virtual Device is a software package that includes the simulation part of a MicroEJ
Firmware: runtime, libraries and application(s). It can be run on any PC without the need of MicroEJ Stu-
dio. In case a MicroEJ Multi-Sandbox Firmware, it is also used for testing a MicroEJ Sandboxed Application
in MicroEJ Studio.
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CHAPTER

TWO

OVERVIEW

2.1 MicroEJ Editions

2.1.1 Introduction
MicroEJ offers a comprehensive toolset to build the embedded software of a device. The toolset covers two levels
in device software development:

+ MicroEJ SDK for device firmware development

+ MicroEJ Studio for application development

The firmware will generally be produced by the device OEM, it includes all device drivers and a specific set of Mi-
croEJ functionalities useful for application developers targeting this device.

QA Platform Firmware @ Application | ;1 ulator
Sources

Sources
MICROEJ. 5DK MICROEJ Studic
Firmware Developer Host Application Developer Host
Import Build
Virtual
Device
Build
I
Target Local Deploy
- MICROEJ
- irmware | ——— APPLICATION
Build Flash — (7) —
L7 Install N Publish

MICROEJ.Forge

Fig. 1: MicroEJ Development Tools Overview

Using the MicroEJ SDK tool, a firmware developer will produce two versions of the MicroEJ binary, each one able
to run applications created with the MicroEJ Studio tool:

+ A MicroEJ Firmware binary to be flashed on OEM devices;
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« AVirtual Device which will be used as a device simulator by application developers.
Using the MicroEJ Studio tool, an application developer will be able to:

« Import Virtual Devices matching his target hardware in order to develop and test applications on the Simu-
lator;

« Deploy the application locally on an hardware device equipped with the MicroEJ Firmware;

« Package and publish the application on a MicroEJ Forge Instance, enabling remote end users to install it on
their devices. For more information about MicroEJ Forge, please consult https://www.microej.com/product/
forge.

2.1.2 Determine the MicroEJ Studio/SDK Version

In MicroEJ Studio/SDK, go to Help > About MicroEJ SDK menu.
In case of MicroEJ SDK 4.1 .x, the MicroEJ SDK version is directly displayed, suchas 4.1.5:

A About MicroEl® SDK

MicroEl® SDE

Version 4.1.5

Copyright ©2016-2018 1527 5.4, All Rights Reserved.

Use of this program is subject to Microk) License Agreement.

MicroE)® SDK is built on Eclipse, licensed under the terms of the Commen Public
License (CPL).

MicroEl® 50K and the MicreEl) logos are tradernarks of MicroE) 5.4,

CSEHOFPFS I EBwEDF

3 . .
@ Installation Details

In case of MicroEJ SDK 5. x , the value displayed is the MicroEJ SDK distribution, suchas 19.05 or 20.07:

2.1. MicroEJ Editions 5
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= About MicroEl

Copyright ©2018-2020 Microb) Corp. All Rights Reserved.

Use of this program is subject to MicroE) License Agreement.

MicroE)® SDK is built on Eclipse, licensed under the terms of the Common
r Public License (CPL).

MicroEl® 5DK and the MicrokE) logos are trademarks of MicroB) Corp.

CSEOFPF O JE WS

® Installation Details

To retrieve the MicroEJ SDK version that is currently installed in this distribution, proceed with the following steps:
o Clickonthe Installation Details button,
o Clickonthe Installed Software tab,

+ Retrieve the version of entry named MicroEJ SDK (or MicroEJ Studio).

K Installation Details

Installed Software |nstallation History Features Plug-ins Coenfiguration

Name Version Id Provider
@= C/C++ Development Tools SDK 9.4.3.201802261533  org.eclipse.cdt.sdk.feature.group Eclipse COT
[k C/C++ GCC Cross Compiler Support 9.4.3.201802261533  org.eclipse.cdt.build.crossgec.feature.group  Eclipse COT
[ C/C++ GDB Hardware Debugging 9.4.3.201802261533  org.eclipse.cdt.debug.gdbjtag.feature.gro... Eclipse COT
[{f- Eclipse Checkstyle Plug-in 6.8.0.201507251301  net.sf.eclipsecs.feature.group http:/Yeclipse-cs.sfu
@ Eclipse Runner Feature 1.34 com.eclipserunnerfeature feature.group Eclipse Runner Tean
@: Eclipse SDK 4.7.3.M20180330-06... org.eclipse.sdk.ide Eclipse.org
@: Eclipse XML Editors and Tools 3.9.2,:201803221834  erg.eclipse.wstxml_uifeaturefeature.group Eclipse Web Tools P
@: Git integration for Eclipse 4.9.2.201712130930-r  org.eclipse.egit.feature.group Eclipse EGit
@: JAutodoc 1.13.0 net.sf,jautodec.feature feature.group Martin Kesting
(= Markdown Editor 0.2.3 markdown.editor.feature.feature.group Winterwell
i i Joldeded?00728-1506  com.is2t.microej.mpp-feature feature.gro...  MicroEl
5.2.0 com.is2t.microej.sdk.feature.feature.group  MicroEJ
- LLUZ0I00728-1306  com.is2t.microgj.mpp.product.feature.fea.. MicroE)
@ Mylyn WikiText 3.0.792001711172000  erg.eclipse.mylynwikitext_featurefeature.... Eclipse Mylyn
@: PMD Plug-in 4.0.5720141105-1906  net.sourceforge.pmd.eclipsefeature.group PMD Project
@: Sonarlint for Eclipse 4.0.0.201810170711  org.sonarlint.eclipse featurefeature.group  SonarSource

2.1. MicroEJ Editions 6
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2.2 Licenses

2.2.1 License Manager Overview

MicroEJ Architectures are distributed in two different versions:

« Evaluation Architectures, associated with a software license key. Can be downloaded at https://repository.
microej.com/architectures/.

+ Production Architectures, associated with an hardware license key stored on a USB dongle. Can be requested
to MicroEJ support team support@microej.com.

The license manager is provided with MicroEJ Architectures and this then integrated to Platforms, consequently:

« Evaluation licenses will be shown only if at least one Evaluation Architecture or Platform built from an Eval-
uation Architecture has been imported in MicroEJ SDK.

« Production licenses will be shown only if at least one Production Architecture or Platform built from a Pro-
duction Architecture has been imported in MicroEJ SDK.

See sections MicroEJ Architecture Import and MicroEJ Platform Import for more information.

The list of installed licenses is available in MicroEJ SDK preferences dialog page in Window > Preferences >
MicroEJ :

r - -
= Preferences LI_I—J@ e S
type filter text MicroEJ f=e e

Checkstyl
o .st)re = General settings for MicroE) development:
Copyright
- Data Management MicroEl repository
EasyantdEclipse - -
Help CAPvruntime-Mew_configuration'repo Browse... I | Refresh

> IceTea

> Install/Update Licenses

m

Instant Messaging

; License Id Edition License Tags Expiration Date  Packs Add...
: J\:{ra ' XFRYS-J2MSN-Y3MAS-RBK46 | 5TD 1S2T_J8F5C o 2020-12-31 Poa
4 MicrokEl
Architectures
Naming Convention
Platforms
Platforms in workspace
Updates IRe;tore Defaultsl [ Apply ]
'\/'_7\:' [ QK ] I Cancel I

Fig. 2: MicroEJ Licenses View

2.2.2 Evaluation Licenses
This section should be considered when using Evaluation Architectures, which use software license keys. Amachine

UID needs to be provided to activate an Evaluation license on the MicroEJ Licenses Server. The machine UIDisa 16
hexadecimal digits number.

Get your Machine UID

Retrieving the machine UID depends on the kind of MicroEJ Platform being evaluated.

2.2. Licenses 7
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If your MicroEJ Platform is already imported in Package Explorer and built with MicroEJ Module Manager, the Mi-
croEJ Architecture has been automatically imported. The machine UID will be displayed when building a MicroEJ
Standalone Application on device.

[INFO 1 Launching in Evaluation mode. Your UID is XXXXXXXXXXXXXXXX.
[ERROR] Invalid license check (No license found).

Otherwise, a MicroEJ Architecture or Platform should have been manually imported from the MicroEJ SDK prefer-
ences page. The machine UID can be retrieved as following:

« Goto Window > Preferences > MicroEJ ,

« Select either Architectures or Platforms ,

« Click on one of the available Architectures or Platforms,

« Pressthe GetUID button to getthe machine UID.

Note: To accessthis GetUID option, at least one Evaluation Architecture or Platform must have been imported
before (see License Manager Overview).

Copy the UID. It will be needed when requesting a license.

& UID successfully generated @

Your UID was successfully generated.

Your UID is:  |A856470297673E28

Fig. 3: Machine UID for Evaluation License

Request your Activation Key

« Go to MicroEJ Licenses Server https://license.microej.com.

« Clickon Create a new account link.

« Create your account with a valid email address. You will receive a confirmation email a few minutes after.
Click on the confirmation link in the email and login with your new account.

+ Click on Activate a License .
« Set Product P/N: to 9PEVNLDBU6IJ.
« Set UID: to the machine UID you copied before.

« Clickon Activate .

« The license is being activated. You should receive your activation by email in less than 5 minutes. If not,
please contact support@microej.com.

2.2. Licenses 8


https://license.microej.com
mailto:support@microej.com

MicroEJ Documentation, Revision 9c1bc719

« Once received by email, save the attached zip file that contains your activation key.

Install the License Key

If your MicroEJ Platform is already imported in Package Explorer and built with MicroEJ Module Manager, the license
key zip file must be simply dropped to the ~/.microej/licenses/ directory (create it if it doesn’t exist).

» ThisPC » Local Disk (C:) » Users » user » .microgj » licenses
MName Date modified Type Size
REW2Z-XSTRL-5ZYUE-K33DCzip 30/08/2020 12:27 Compressed (zipp... 1 KB

Fig. 4: MicroEJ Shared Licenses Directory

Note: The MicroEJ SDK Preferences page will be automatically refreshed when building a MicroEJ Standalone
Application on device.

Otherwise, the license key must be installed as following:
+ Go back to MicroEJ SDK.

« Selectthe Window > Preferences > MicroEJ menu.

« Press Add... .

« Browse the previously downloaded activation key archive file.

« Press OK. A new license is successfully installed.

+ Go to Architectures sub-menu and check that all Architectures are now activated (green check).
« Your MicroEJ SDK is successfully activated.

If an error message appears, the license key could not be installed. (see section Troubleshooting). A license key can
be removed from key-store by selecting it and by clickingon Remove button.

Troubleshooting
Consider this section when an error message appears while adding the Evaluation license key. Before contacting
MicroEJ support, please check the following conditions:

+ Key is corrupted (wrong copy/paste, missing characters or extra characters)

+ Key has not been generated for the installed environment

+ Key has not been generated with the machine UID

« Machine UID has changed since submitting license request and no longer matches license key

+ Keyhasnotbeen generated for one of the installed Architectures (no license manager able to load this license)

2.2. Licenses 9
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= Invalid activation key w

The key could not be installed in this environment. Possible reasons are:

- key is corrupted,

- key is valid but does not match any available license manager(s), (Works for an
other edition),

- key has not been generated for this machine,

- old key version.

Fig. 5: Invalid License Key Error Message

2.2.3 Production Licenses

This section should be considered when using Production Architectures, which use hardware license keys stored
on an USB dongle.

= 12345678

Fig. 6: MicroEJ USB Dongle

Note: If your USB dongle has been provided to you by your sales representative and you don’t have received an
activation certificate by email, it may be a pre-activated dongle. Then you can skip the activation steps and directly
jump to Check Activation on MicroEJ SDK section.

Request your Activation Key

+ Goto license.microej.com.
« Clickon Create a new account link.

« Create your account with a valid email address. You will receive a confirmation email a few minutes after.
Click on the confirmation link in the email and login with your new account.

« Clickon Activate a License .

« Set Product P/N: to The P/N on the activation certificate.

2.2. Licenses 10
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« Enter your UID: serial number printed on the USB dongle label (8 alphanumeric char.).

« Clickon Activate and check confirmation message.

+ Click on Confirm your registration .
+ Enter the Registration Code provided on the activation certificate.

o Clickon Submit .

« Your Activation Key will be sent to you by email as soon as it is available (12 business hours max.).

Note: You can check the My Products page to verify your product registration status, the Activation Key avail-
ability and to download the Activation Key when available.

Once the Activation Key is available, download and save the Activation Key ZIP file to a local directory.

Activate your USB Dongle

This section contains instructions that will allow to flash your USB dongle with the proper activation key.
You shall ensure that the following prerequisites are met :
+ The USB dongle is plugged and recognized by your operating system (see Troubleshooting section)
+ No more than one USB dongle is plugged to the computer while running the update tool
+ The update tool is not launched from a Network drive or from a USB key

+ The activation key you downloaded is the one for the dongle UID on the sticker attached to the dongle (each
activation key is tied to the unique hardware ID of the dongle).

You can then proceed to the USB dongle update:
« Unzipthe Activation Key file to a local directory
« Enter the directory just created by your ZIP extraction tool.

+ Launch the executable program.

« Clickonthe Update button (no password needed)

2.2. Licenses 1
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(=] Update Tool

k.eylcharacter zting]

Ky

Fig. 7: Dongle Update Tool

« On success, an Update successfully message shall appear. On failure, an Error key or no proper
rockey message may appear.

update_E24C0785 i

ﬂ Update successfully

OK

Fig. 8: Successful dongle update

Check Activation on MicroEJ SDK

Note: Production licenses will be shown only if at least one Production Architecture or Platform has been imported
before (see License Manager Overview).

+ Go back to MicroEJ SDK,

« Goto Window > Preferences > MicroEJ ,

« Goto Architectures or Platforms sub-menuand checkthatall Production Architectures or Platforms are
now activated (green check).

2.2. Licenses 12
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type filter text Platforms =T -
EasyantdEclipse " Add or remove platforms,
> Help
. lceTea Platforms, Virtual Devices and Architectures:
> Install/Update . Mame Version  Lic... Select All
:”“a”tmessag'”g [ FRDM-KL46Z Jakarta Kickstart 135 Decelect Al
> vy
. Java ugQ me_ L‘\rchitect:.'re:CMD
4 MicroEl [14F STM Hardware Part Number: Jakarta Import...
. [1€¥F STM: Compilation Toolchain: CMO_ARMCC
Architectures []€F sTM: Name: KickStart Uninstall
MNaming Conventior )43 sTm: Provider: [S2T
oy, Version: 1.3.5 Get UID
Platforms in worksp g 1 Core Engine Architecture: 14
Undates [C14¥ STM: Usage Level:Fer ]
P 143 STM: Technology Version: 1.6
> Mylyn []£3 vicr License Tag{[52TJaF5C
Planning []¢) vicp Build Labek: 207503071047
» Plug-in Development Path: .microgfrepositorieshFull\1.64sd002
Fig. 9: Platform License Status OK
Troubleshooting

This section contains instructions to check that your USB dongle is correctly recognized by your operating system.

GNU/Linux Troubleshooting
For GNU/Linux Users (Ubuntu at least), by default, the dongle access has not been granted to the user, you have to
modify udev rules. Please create a /etc/udev/rules.d/91-usbdongle.rules file with the following contents:

ACTION!="add", GOTO="usbdongle_end”
SUBSYSTEM=="usb", GOTO="usbdongle_start”
SUBSYSTEMS=="usb", GOTO="usbdongle_start"”
GOTO="usbdongle_end"
LABEL="usbdongle_start”
ATTRS{idVendor}=="096e" , ATTRS{idProduct}=="0006" , MODE="0666"
LABEL="usbdongle_end"
Then, restart udev: /etc/init.d/udev restart

You can check that the device is recognized by running the 1susb command. The output of the command should
contain a line similar to the one below for each dongle : Bus 002 Device 003: ID 096e:0006 Feitian
Technologies, Inc.

Windows Troubleshooting

For Windows users, each dongle shall be recognized with the following hardware ID :

HID\VID_0Q96E&PID_0006&REV_0109

On Windows 8.1, go to Device Manager > Human Interface Devices and check amongthe USB Input Device
entries that the Details > Hardware Ids property match the ID mentioned before.

2.2. Licenses 13
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VirtualBox Troubleshooting

In a VirtualBox virtual machine, USB drives must be enabled to be recognized correctly. So make sure to enable the
USB dongle by clicking on it in the VirtualBox menu Devices > USB.

In order to make this setting persistent, go to Devices > USB > USB Settings... and add the USB donglein the
USB Devices Filters list.

2.3 MicroEJ Runtime

2.3.1 Language

MicroEJ is compatible with the Java language version 7.

Java source code is compiled by the Java compiler' into the binary format specified in the JVM specification’. This
binary code needs to be linked before execution: .class files and some other application-related files (see MicroEJ
Classpath) are compiled to produce the final application that the MicroEJ Runtime can execute.

MicroEJ complies with the deterministic class initialization (<clinit>) order specified in /[BON]. The application is
statically analyzed from its entry points in order to generate a clinit dependency graph. The computed clinit se-
quence is the result of the topological sort of the dependency graph. An error is thrown if the clinit dependency
graph contains cycles.

2.3.2 Scheduler
The MicroEJ Architecture features a green thread platform that can interact with the C world [SNI]. The (green)
thread policy is as follows:

+ preemptive for different priorities,

« round-robin for same priorities,

« “priority inheritance protocol” when priority inversion occurs.’

MicroEJ stacks (associated with the threads) automatically adapt their sizes according to the thread requirements:
Once the thread has finished, its associated stack is reclaimed, freeing the corresponding RAM memory.

2.3.3 Garbage Collector
The MicroEJ Architecture includes a state-of-the-art memory management system, the Garbage Collector (GC).
It manages a bounded piece of RAM memory, devoted to the Java world. The GC automatically frees dead Java

objects, and defragments the memory in order to optimize RAM usage. This is done transparently while the MicroEJ
Applications keep running.

2.3.4 Foundation Libraries

Embedded Device Configuration (EDC)

The Embedded Device Configuration specification defines the minimal standard runtime environment for embed-
ded devices. It defines all default API packages:

! The JDT compiler from the Eclipse IDE.
2 Tim Lindholm & Frank Yellin, The Java™ Virtual Machine Specification, Second Edition, 1999
3 This protocol raises the priority of a thread (that is holding a resource needed by a higher priority task) to the priority of that task.

2.3. MicroEJ Runtime 14
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* java.io

+ java.lang

+ java.lang.annotation
« java.lang.ref

« java.lang.reflect

« java.util

Beyond Profile (BON)

[BON] defines a suitable and flexible way to fully control both memory usage and start-up sequences on devices
with limited memory resources. It does so within the boundaries of Java semantics. More precisely, it allows:

« Controlling the initialization sequence in a deterministic way.

« Defining persistent, immutable, read-only objects (that may be placed into non-volatile memory areas), and
which do not require copies to be made in RAM to be manipulated.

« Defining immortal, read-write objects that are always alive.

« Defining and accessing compile-time constants.

2.4 MicroEJ Libraries

A MicroEJ Foundation Library is a MicroEJ Core library that provides core runtime APIs or hardware-dependent
functionality. A Foundation library is divided into an APl and an implementation. A Foundation library APl is com-
posed of a name and a 2 digits version (e.g. EDC-1.3) and follows the semantic versioning (http://semver.org)
specification. A Foundation Library API only contains prototypes without code. Foundation Library implementa-
tions are provided by MicroEJ Platforms. From a MicroEJ Classpath, Foundation Library APIs dependencies are
automatically mapped to the associated implementations provided by the Platform or the Virtual Device on which
the application is being executed.

A MicroEJ Add-On Library is a MicroEJ library that is implemented on top of MicroEJ Foundation Libraries (100%
full Java code). A MicroEJ Add-On Library is distributed in a single JAR file, with a 3 digits version and provides its
associated source code.

Foundation and Add-On Libraries are added to MicroEJ Classpath by the application developer as module depen-
dencies (see MicroEJ Module Manager).

YOUR APPLICATIONS

ADD-ON LIBRARIES
FOUNDATION LIBRARIES

Java code

—

Fig. 10: MicroEJ Foundation Libraries and Add-On Libraries

MicroEJ Corp. provides a large number of libraries through the MicroEJ Central Repository. To consult its libraries
APIs documentation, please visit https://developer.microej.com/microej-apis/.

2.4. MicroEJ Libraries 15
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2.5 MicroEJ Central Repository

The MicroEJ Central Repository is the binary repository maintained by MicroEJ Corp. It contains Foundation Library
APIs and numerous Add-On Libraries. Foundation Libraries APIs are distributed under the organization ej.api and
com.microej.api . All other artifacts are Add-On Libraries.

By default, MicroEJ SDK s configured to connect online MicroEJ Central Repository. The MicroEJ Central Repository
can be downloaded locally for offline use. Please follow the steps described at https://developer.microej.com/
central-repository/.

To consult its libraries APls documentation, please visit https://developer.microej.com/microej-apis/.

2.6 Embedded Specification Requests

MicroEJ implements the following ESR Consortium specifications:

[BON] | http://e-s-r.net/download/specification/ESR-SPE-0001-BON-1.2-F.pdf

[SNI] http://e-s-r.net/download/specification/ESR-SPE-0012-SNI_GT-1.2-H.pdf
[SP] http://e-s-r.net/download/specification/ESR-SPE-0014-SP-2.0-A.pdf ]
[MUI] | http://e-s-r.net/download/specification/ESR-SPE-0002-MICROUI-2.0-B.pdf
[KF] http://e-s-r.net/download/specification/ESR-SPE-0020-KF-1.4-F.pdf

2.7 MicroEJ Firmware

2.7.1 Bootable Binary with Core Services
A MicroEJ Firmware is a binary software program that can be programmed into the flash memory of a device. A
MicroEJ Firmware includes an instance of a MicroEJ runtime linked to:

+ underlying native libraries and BSP + RTOS,

« MicroEJ libraries and application code (C and Java code).

2.5. MicroEJ Central Repository 16
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YOUR APPLICATIONS

)
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Fig. 11: MicroEJ Firmware Architecture

2.7.2 Specification

The set of libraries included in the firmware and its dimensioning limitations (maximum number of simulta-
neous threads, open connections, ...) are firmware specific. Please refer to https://developer.microej.com/5/
getting-started-studio.html for evaluation firmware release notes.

2.8 Introducing MicroEJ SDK

MicroEJ SDK provides tools based on Eclipse to develop software applications for MicroEJ-ready devices. MicroEJ
SDK allows application developers to write MicroEJ Applications and run them on a virtual (simulated) or real de-
vice.

This document is a step-by-step introduction to application development with MicroEJ SDK. The purpose of
MicroEJ SDK is to develop for targeted MCU/MPU computers (loT, wearable, etc.) and it is therefore a cross-
development tool.

Unlike standard low-level cross-development tools, MicroEJ SDK offers unique services like hardware simulation
and local deployment to the target hardware.

Application development is based on the following elements:

« MicroEJ SDK, the integrated development environment for writing applications. It is based on Eclipse and is
relies on the integrated Java compiler (JDT). It also provides a dependency manager for managing MicroEJ
Libraries (see MicroEJ Module Manager). The current distribution of MicroEJ SDK ( 20.10 ) is built on top of
Eclipse 2020-06.

2.8. Introducing MicroEJ SDK 17
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+ MicroEJ Platform, a software package including the resources and tools required for building and testing an
application for a specific MicroEJ-ready device. MicroEJ Platforms are imported into MicroEJ SDK within a
local folder called MicroEJ Platforms repository. Once a MicroEJ Platform is imported, an application can be
launched and tested on Simulator. It also provides a mean to locally deploy the application on a MicroEJ-
ready device.

+ MicroEJ-ready device, an hardware device that will be programmed with a MicroEJ Firmware. A MicroEJ
Firmware is a binary instance of MicroEJ runtime for a target hardware board.

Starting from scratch, the steps to go through the whole process are detailed in the following sections of this chapter

« Download and install a MicroEJ Platform

« Build and run your first Application on Simulator

« Build and run your first Application on Device

2.9 Introducing MicroEJ Studio and Virtual Devices

MicroEJ Studio provides tools based on Eclipse to develop software applications for MicroEJ-ready devices. Mi-
croEJ Studio allows application developers to write MicroEJ Applications, run them on a virtual (simulated) or real
device, and publish them to a MicroEJ Forge instance.

This document is an introduction to application development with MicroEJ Studio. The purpose of MicroEJ Studio
is to develop for targeted MCU/MPU computers (loT, wearable, etc.) and it is therefore a cross-development tool.

Unlike standard low-level cross-development tools, MicroEJ Studio offers unique services like hardware simula-
tion, deployment to the target hardware and final publication to a MicroEJ Forge instance.

Application development is based on the following elements:

+ MicroEJ Studio, the integrated development environment for writing applications. It is based on Eclipse and
relies on the integrated Java compiler (JDT). It also provides a dependency manager for managing MicroEJ
Libraries (see MicroEJ Module Manager). The current distribution of MicroEJ Studio (19.05) is built on top of
Eclipse Oxygen (https://www.eclipse.org/oxygen/).

+ MicroEJ Virtual Device, a software package including the resources and tools required for building and test-
ing an application for a specific MicroEJ-ready device. A Virtual Device will simulate all capabilities of the
corresponding hardware board:

Computation and Memory,

Communication channels (e.g. Network, USB....),

Display,

User interaction.

Virtual Devices are imported into MicroEJ Studio within a local folder called MicroEJ Repository. Once a Vir-
tual Device is imported, an application can be launched and tested on Simulator. It also provides a mean to
locally deploy the application on a MicroEJ-ready device.

«+ MicroEJ-ready device, a hardware device that has been previously programmed with a MicroEJ Firmware. A
MicroEJ Firmware is a binary instance of MicroEJ runtime for a target hardware board. MicroEJ-ready devices
are built using MicroEJ SDK. MicroEJ Virtual Devices and MicroEJ Firmwares share the same version (there is
a 1:1 mapping).

The following figure gives an overview of MicroEJ Studio possibilities:
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- 9 Simulator
-\ = MICROE} ,‘ g\ .
. - Test
MICROEJ Studio

MICROEJ
APPLICATION

MICROEJ.Forge

Fig. 12: MicroEJ Application Development Overview

2.10 Perform Online Getting Started

MicroEJ Studio Getting Started is available on https://developer.microej.com/5/getting-started-studio.html.
Starting from scratch, the steps to go through the whole process are:
1. Setup a board and test a MicroEJ Firmware:
« Select between one of the available boards;
« Download and install a MicroEJ Firmware on the target hardware;
« Deploy and run a MicroEJ demo on board.
2. Setup and learn to use development tools:
» Download and install MicroEJ Studio;
« Download and install the corresponding Virtual Device for the target hardware;
« Download, build and run your first application on Simulator;

« Build and run your first application on target hardware.

The following figure gives an overview of the MicroEJ software components required for both host computer and

target hardware:

2.10. Perform Online Getting Started
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MicroEJ - MicroEJ
Virtual Device Firmware
(.vde)

Q Software

MICROEJ Studio (-exe) (binary)
l Install I Install I Flash
$
. —
Your Workstation Local Target
with Simulator Deploy
Download
& Install
» | @ MICROEJ forge
Publish [ 2~

Fig. 13: MicroEJ Studio Development Imported Elements

2.11 GitHub Repositories

Alarge number of examples, libraries, demos and tools are shared on MicroEJ GitHub account: https://github.com/
MicroEJ.

Most of these GitHub repositories contain projects ready to be imported in MicroEJ SDK. This section explains the
steps to import them in MicroEJ SDK, using the MWT Examples repository.

Note: MicroEJ SDK Distribution includes the Eclipse plugin for Git.

First, from the GitHub page, copy the repository URI (HTTP address) from the dedicated field in the right menu
(highlighted in red):
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O Why GitHub? ~~ Team Enterprise Explore Marketplace Pricing Sign in ‘ Sign up |
& MicroE) / ExampleJava-MWT ®Watch | 2 TrStar | 1 Yok 0
<> Code Issues Pull requests Actions Projects Security Insights

$ master - P 1branch  © 2 tags Go to file About

These projects provide examples
Q privron Merge branch ‘develop’ into ‘master’ .. BJ Clone @ for MWT

HTTPS  GitHub CLI
: - e e (FF [ Readme
com.microej.example.mwt.basic ix api minor version @ignc https://github.con/MicroEl/Exanplela | 7]
com.microej.example.mwtbutt..  Fix api minor version @ignc  Use Git or checkout with SVN using the web URL. BB View license
com.microej.example.mwt.hello...  Fix api minor version @ignc
Et] Open with GitHub Desktop
. Releases
com.microej.example.mwt.mvc Fix api minor version @ignc
: - o - X B D load ZIP @ 2 tags
com.microej.example.mwtslidi..  Fix api minor version @igne & ownloa
[ .gh-copyright.template Move mwt example from foundation libraries @ignore_branc... 3 years ago
N e AT e A 1 e e o e e . Packages

In MicroEJ SDK, to clone and import the project from the remote Git repository into the MicroEJ workspace, select
File > Import > Git > Projectsfrom Git wizard.
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® |mport

Select

Import one or more projects from a Git Repository. Iﬁ

Select an import wizard:

type filter text

= General

= C/C++

= CV5
v = Git

S0 Projects from Git

= Install
= MicroEl
= Plug-in Development
[= Run/Debug
= Tasks
= Teamn
= XML

® < Back Finish Cancel

Click Next , select CloneURI ,click Next and paste the remote repository address in the URI field. For
this repository, the address is https://github.com/MicroEJ/ExampleJava-MWT.git. If the HTTP address is a valid
repository, the other fields are filed automatically.
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® |mport Projects from Git
Source Git Repository GIT
Enter the location of the source repository. :_‘:n‘
Location
URJ: ?| https:.-"fgithul:l.cum.-"MicrDElexampI&lava-M‘."H"T.giﬂ | Lacal File...
Host: | github.com |
Repository path: | /Microbl/Examplelava-MWT.git |
Connection
Protocol: | https
Authentication
User | |
Password: | |
[ ]5tore in Secure Store
® = Back Finish Cancel

Click Next , selectthe master branch, click Next and acceptthe proposed Local Destination by clicking Next

once again.

2.11. GitHub Repositories
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® |mport Projects from Git

Local Destination

GIT

Configure the local storage location for Examplelava-MWT. E‘
Destination

Directory: | IC:\Users\user\git\Examplelava-MWT | Browse
Initial branch: K master v

[]Clene submodules

Configuration

Remote name: | crigin

® < Back Finish Cancel

Click Next once more and finally Finish . The Package Explorer view now contains the imported projects.

£ Package Explorer &2 ‘Eg Type Hierarchy % ™

w '[c‘.gl- com.microgj.example.mwt.basic [Examplelava-MWT master]
& src/main/java
B\ Module Dependencies module.ivy [*]
[ src
[%} CHANGELOG.md
5 LICEMSE.txt
ke moduleivy
[#} README.md
'[c".gl- com.microgj.example.mwt.button [Examplelava-MWT master]
'_,fé com.microg).example.rmwt.helloworld [Examplelava-MWT master]
'[;_—'é com.microgj.example.mwt.mve [Examplelava-MWT master]

1—.;‘- com.microg).example.mwt.slidingwidget [Examplelava-MWT master]
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If you want to import projects from another (GitHub) repository, you simply have to do the same procedure using
the Git URL of the desired repository.

2.12 System Requirements

MicroEJ SDK and MicroEJ Studio

+ Intel x64 PC with minimum :
- Dual-core Core i5 processor
- 4GB RAM
- 2GB Disk

« Operating Systems :

Windows 10, Windows 8.1 or Windows 8

Linux distributions (tested on Ubuntu 18.04 and 20.04) - As of SDK 20.10 (based on Eclipse 2020-06),
Ubuntu 16.04 is not supported.

Mac OS X (tested on version 10.13 High Sierra, 10.14 Mojave)

« Java:

JRE or JDK 8 (OpenJDK or Oracle JDK)
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CHAPTER

THREE

APPLICATION DEVELOPER GUIDE

3.1 Introduction

The following sections of this document shall prove useful as a reference when developing applications for MicroEJ.
They cover concepts essential to MicroEJ Applications design.

In addition to these sections, by going to https://developer.microej.com/, you can access a number of helpful re-
sources such as:

« Libraries from the MicroEJ Central Repository (https://developer.microej.com/central-repository/);
« Application Examples as source code from MicroEJ Github Repositories (https://github.com/MicroEJ);
« Documentation (HOWTOs, Reference Manuals, APIs javadoc...).

MicroEJ Applications are developed as standard Java applications on Eclipse JDT, using Foundation Libraries. Mi-
croEJ SDK allows you to run / debug / deploy MicroEJ Applications on a MicroEJ Platform.

Two kinds of applications can be developed on MicroEJ: MicroEJ Standalone Applications and MicroEJ Sanboxed
Applications.

A MicroEJ Standalone Application is a MicroEJ Application that is directly linked to the C code to produce a Mi-
croEJ Firmware. Such application must define a main entry point, i.e. a class containing a public static void
main(String[]) method. MicroEJ Standalone Applications are developed using MicroEJ SDK.

A MicroEJ Sandboxed Application is a MicroEJ Application that can run over a Multi-Sandbox Firmware. It can be
linked either statically or dynamically. If it is statically linked, it is then called a System Application as it is part of
the initial image and cannot be removed. MicroEJ Sandboxed Applications are developed using MicroEJ Studio.

3.2 Local Workspaces and Repositories

When starting MicroEJ SDK, it prompts you to select the last used workspace or a default workspace on the first
run. A workspace is a main folder where to find a set of projects containing MicroEJ source code.

When loading a new workspace, MicroEJ SDK prompts for the location of the MicroEJ repository, where the Mi-
croEJ Architectures, Platforms or Virtual Devices will be imported. By default, MicroEJ SDK suggests to point to
the default MicroEJ repository on your operating system, located at ${user.home}/.microej/repositories/
[version]. You can select an alternative location. Another common practice is to define a local repository relative
to the workspace, so that the workspace is self-contained, without external file system links and can be shared
within a zip file.
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3.3 Standalone Application

3.3.1 MicroEJ Platform Import

A MicroEJ Platform is required to run a MicroEJ Standalone Application on the Simulator or build the Firmware
binary for the target device.

The Platform Developer Guide describes how to create a MicroEJ Platform from scratch for any kind of device. In
addition, MicroEJ Corp. provides Platforms for various development boards (see https://repository.microej.com/
index.php?resource=JPF).

MicroEJ Platforms are distributed in two packages:
« Source Platform. The source files are imported into the workspace. This is the default case.

+ Binary Platform. A . jpf fileisimported into the MicroEJ repository. As of MicroEJ SDK 5. 3.0, this package
is deprecated.

Source Platform Import

Import from Folder

This section applies when the Platform files are already available on a local folder. This is likely the case when the
files are checked out from a Version Control System, such as a local git repository clone.

Note: If you are going to import a Platform from MicroEJ Github, you can follow the specific GitHub Repositories
section instead (the projects will be automatically imported).

+ Select File > Import... > General > Existing ProjectsintoWorkspace > Selectrootdirectory =

Browse... .
« Select the root directory. The wizard will automatically discover projects to import.

« Clickonthe Finish button.

Import from Zip File

This section applies when the Platform files are packagedina .zip file.

» Select File > Import... > General > Existing Projectsinto Workspace > Select archive file =
Browse... .

« Select the zip of the project (e.g., x.zip). The wizard will automatically discover projects to import.

« Clickonthe Finish button.

Platform Build

MicroEJ Platforms are usually shared with only the Platform configuration files. Once the projects are imported,
follow the platform-specific documentation to build the Platform.

Once imported or built, a Platform project should be available as following:

3.3. Standalone Application 27


https://repository.microej.com/index.php?resource=JPF
https://repository.microej.com/index.php?resource=JPF

MicroEJ Documentation, Revision 9c1bc719

v 2 myDevice-myPlatform-CMdhardfp_|ARS3-1.0.0
(% build
= =ource
=| .project

Fig. 1: MicroEJ Platform Project
The source folder contains the Platform content which can be set to the target.platform.dir option.

Binary Platform Import

After downloading the MicroEJ Platform . jpf file, launch MicroEJ SDK and follow these steps to import the MicroEJ
Platform:

« Open the Platform view in MicroEJ SDK, select Window > Preferences > MicroEJ > Platforms . The
view should be empty on a fresh install of the tool.

'('} Preferences = n

type filter text Platforms L= A4

» General A
» Ant
y CfC++ Platforms, Virtual Devices and Architectures:
Checkstyle
EasyantdEclipse
» Help Deselect All
» Install/Update
> vy
» Java
4 Microk)
Architectures Get UID
Maming Convention
Platforms in workspace
Updates
» Mylyn

Add or remove platforms.

MName Version Lic... Select All

Import...

Uninstall

> Plug-in Development
- PMD
n Restore Defaults Apph

Fig. 2: MicroEJ Platform Import

« Press Import... button.

« Choose SelectFile... andusethe Browse option to navigate tothe .jpf file containing your MicroEJ
Platform, then read and accept the license agreement to proceed.
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- oS

('} Import Platforms, Virtual Devices and Architectures

Import Platforms, ¥irtual Devices and Architectures

Select a directory/file to search for available platforms, virtual devices and architectures.

(") Select directory: Browse...
(®) Select file: Ch\Usersh, MicroEJPlatform jpof Browse...
Platforms, Yirtual Devices and Architectures:
Mame Yersion Select All
L} MicroE Platform 2.1.1 Deselect Al

MICROE) LICEMSE AGREEMENT

PREAMELE

THIS SOFTWARE LICEMNSE AGREEMENT (THE « AGREEMENT ») APPLIES TO PRODUCTS LICEMSE
On purchase of any Licensed Product from 52T or an 52T Partner or an [52T Distributor, the relz
THE LICEMSEE, AS A USER OF THE LICEMSED PRODUCTS REFERRED TO ABOVE AND OM THE REI

1 DEFIMITIONS

€ >

[+]1 agree and accept the above terms and conditions and | want to install the copyrighted Software

Fig. 3: MicroEJ Platform Selection

+ The MicroEJ Platform should now appear in the Platforms view, with a green valid mark.

3.3. Standalone Application
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O

ty

Preferences = n

rpe filter text Platforms =1 v w

» General ~
» Ant
s CfC++ Platforms, Virtual Devices and Architectures:

Checkstyle MName Version  Lic.. Select All

EasyantdEclipse ;
211 >
. Help L} MicroEJ Piatform o Deselect Al

+ Install/Update
> Iy

. Java

Add or remove platforms.

Import...

Uninstall

4 Microk)

<

Architectures Get UID
Maming Conventicon
Platforms in workspace
Updates

» Mylyn

» Plug-in Development

> PMD

noom Restare Defaults Apply

3.3

Fig. 4: MicroEJ Platform List

.2 Build and Run an Application

Create a MicroEJ Standalone Application

« Create a project in your workspace. Select File > New > MicroEJ Standalone Application Project .

File | Edit Source Refactor Mavigate Search Project Run  Window Help
Mew Alt+Shift+N » | (22 MicroE) Standalone Application Project -
Open File... \g MicroE) Standalone Example Project
Cloze Ctrl+W ‘3 ST
Close Al CtrlShift+ W R
£ MicroE) Sandboxed Application Project
Sav |+ 5
Save Ctrl+5 |=<3 T
Save Az
FE¥  MirrnFl Eant
Fig. 5: New MicroEJ Standalone Application Project
« Fillin the application template fields, the Project name field will automatically duplicate in the following
fields. Click on Finish . A template project is automatically created and ready to use, this project already
contains all folders wherein developers need to put content:
- src/main/java: Folder for future sources
- src/main/resources : Folder for future resources (images, fonts, etc.)
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- META-INF : Sandboxed Application configuration and resources

- module.ivy: lvyinput file, dependencies description for the current project

+ Rightclickonthesourcefolder src/main/java andselect New > Package . Giveaname: com.mycompany
. Clickon Finish .

0 Mew Java Package - 0 n
Java Package

Create a new Java package.

Creates folders corresponding to packages.

Source folder: | MyTest/src Browse...

Mame: COM.Mmycompany

[ | Create package-info.java

Fig. 6: New Package

+ The package com.mycompany is available under src/main/java folder. Right click on this package and
select New > Class . Give a name: Test and check the box public static void main(String[]

args) . Clickon Finish .
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0 Mew Java Class - B n

Jawva Class —=
Create a8 new Java class, @

Source folder: MyTest/src Browse...

Package: COM.mMycompany Browse...

[ Enclosing type: Browse...

Mame: Test

Modifiers: (@) public () package private protected

[ ]abstract [ ]final ctatic

Superclass: java.lang.Object Browse...

Interfaces: Add...
Bemowve

Which method stubs would you like to create?
[#]ipublic static void main(String[] args);

[ ] Constructors from superclass
Inherited abstract methods
Do you want to add comments? (Configure templates and default value here

|:| Generate comments

Fig. 7: New Class

+ The new class has been created with an empty main() method. Fill the method body with the following
lines:

System.out.println("hello world!");
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by module.ivy [J] Testjava &3

package com.mycompany;

public class Test {

-
“

public =s=tatic void main(String([] args)
System.out.println("hello world!"™});

Fig. 8: MicroEJ Application Content
The test application is now ready to be executed. See next sections.

Run on the Simulator

{

To run the sample project on Simulator, select it in the left panel then right-click and select Run > Runas >

MicroEJ Application .

3.3. Standalone Application
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package com.mycompany;

4 Go Into public class Test {

Open in New Window public static void main

Open Type Hierarchy F4 System.out.println/

Show In Alt+Shift+W »

0

=
= {2 | Copy Ctrl+C
¥ | BS

w —

Copy Qualified Mame
[ Paste Ctrl+V
. Delete Delete

Build Path »
Source Alt+Shift+5 ¥
Refactor Alt+Shift+T »

Import...
Export...

EE

wit  Refresh F5
Close Project
Close Unrelated Projects

Assign Warking Sets..,

Run As »
Debug As *
Profile As »
Validate

@ Ruild with Faswlnt

1 lava Applet Alt+5hift+X, A
2 Java Application Alt+Shift+X, J
3 Microk) Application Alt+Shift+X, M

MM A

Run Cenfigurations..,

"

Fig. 9: MicroEJ Development Tools Overview

MicroEJ SDK console will display Launch steps messages.

=============== [ Initialization Stage ) =
=== eI Launchj_ng on Simulator ] ===============

SUCCESS

Run on the Hardware Device

Compile an application, connect the hardware device and deploy on it is hardware dependant. These steps are
described in dedicated documentation available inside the MicroEJ Platform. This documentation is accessible
from the MicroEJ Resources Center view.

Note: MicroEJ Resources Center view may have been closed. Click on Help > MicroEJ Resources Center to
reopen it.

3.3. Standalone Application 34



MicroEJ Documentation, Revision 9c1bc719

Open the menu Manual and select the documentation [hardware device] MicroEJ Platform, where
[hardware device] is the name of the hardware device. This documentation features a guide to run a built-in
application on MicroEJ Simulator and on hardware device.

MicroE) Resource Center 23
type filter text
. &2 Javadoc

6 Manual

[l Hardware Device MicroE] Platform

Fig. 10: MicroEJ Platform Guide

3.3.3 Build Output Files
When building a MicroEJ Application, multiple files are generated next to the ELF file. These files are generated in a
folder which is named like the main type and which is located in the output folder specified in the run configuration.

The following image shows an example of output folder:

v [ com.microg).demo.widget.common.Mavigation
= bon
[= cC
[ externalResources
= fonts
= heapDump
= Images
= logs
= platform
= resourceBuffer
w [—- soar
=| com.microgj.demowidget.common.Mavigation.clinitrap
com.micreel.demo.widget.common.MNavigation.o
Ei com.micreel.demo.widget.common.Mavigation.s3infos
|X| com.microg.demowidget.commen.Mavigation.xml
L] sni_intern.h
[ SOAR.map

SOAR.o

Fig. 11: Build Output Files
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The SOAR Map File

The SOAR.map file lists every embedded symbol of the application (section, Java class or method, etc.) and its size
in ROM or RAM. This file can be opened using the Memory Map Analyzer.

The embedded symbols are grouped into multiple categories. For example, the Object class and its methods are
grouped inthe LibFoundationEDC category. For each symbol or each category, you can see its size in ROM ( Image
Size)and RAM (Runtime Size).

The SOAR groups all the Java strings in the same section, which appearsinthe ApplicationStrings category. The
same appliesto the staticfields (Statics category), thetypes (Types category), and the class names (ClassNames
category).

The SOAR Information File

The soar/<main class>.xml file can be opened using any XML editor.
This file contains the list of the following embedded elements:

« method (in selected_methods tag)

« resource (in selected_resources tag)

« system property (in java_properties tag)

« string (in selected_internStrings tag)

« type (in selected_types tag)

« immutable (in selected_immutables tag)

3.3.4 MicroEJ Launch

The MicroEJ launch configuration sets up the MicroEJ Applications environment (main class, resources, target plat-
form, and platform-specific options), and then launches a MicroEJ launch script for execution.

Execution is done on either the MicroEJ Platform or the MicroEJ Simulator. The launch operation is platform-
specific. It may depend on external tools that the platform requires (such as target memory programming). Refer
to the platform-specific documentation for more information about available launch settings.

Main Tab

The Main tab allows you to setin order:
1. The main project of the application.
2. The main class of the application containing the main method.

3. Types required in your application that are not statically embedded from the main class entry point. Most
required types are those that may be loaded dynamically by the application, using the Class.forName()
method.

4. Binary resources that need to be embedded by the application. These are usually loaded by the application
using the Class.getResourceAsStream() method.

5. Immutable objects’ description files. See the [BON 1.2] ESR documentation for use of immutable objects.
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0 Run Configurations n
Create. manage. and run configurations ;—I
- —*|,
= x| H 5 Name: | HelloWerld
type filter text 3] Main s Execution| 8§ Configuration | g, JRE E Source | [[] Commen
E C/C++ Application Praject ~
Ju JUnit
BI;I La::'1ch Group MyHelloWorld5ample Browse...
4 [7] MicroE) Application Main type, Required types
31 HelloWarld
& MicroE Tool com.is2t.examples.edc.helle. HelloWorld Select Main type...
Add types...
Extra types...
Remove
Resources
Add...
Remove
Immutables v
Revert Apply

Filter matched 6 of 11 items

Fig. 12: MicroEJ Launch Application Main Tab

Execution Tab

The next tab is the Execution tab. Here the target needs to be selected. Choose between execution on a MicroEJ
Platform or on a MicroEJ Simulator. Each of them may provide multiple launch settings. This page also allows you
to keep generated, intermediate files and to print verbose options (advanced debug purpose options).
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G— Run Cenfigurations

Create, manage, and run configurations

)

CEX B3P~

type filter text

] C/C++ Application
Ju JUnit

Name: | Widget Demo (SIM)

3] Main | = Execution

A Configuratioﬂ B JRE} E_/ Source\l i=| Qommoﬂ

Target

Platfarm: | STM32F746G-DISCO SingleApp Production [K1AU3] (4.0.0-RC202007301413) | Browse...
L Launch Group
w [T MicroE) Application Execution
& W!dget Demo (EMB) (®) Execute on Simulator () Execute on Device
[3] Widget Demo (SIM])
» g MicroE! Tool Core Engine Mode: MDefanl ~
Settings: | Default ~ | Seftings: | Build & Deploy w
The Application is simulated
Cptions
Output folder: | S{project_loc:com.microej.demouwidget} Browse...
Clean intermediate files [ Verbose
Opticns Files
Y project_loc:com.microe].demo.widget}/build/commeoen.properties Add...
Y project_loc:com.microgj.demo.widgetl/build/sim/sim.properties
Remove
Up
Down
Revert Appl
Filter matched 8 of 21 items = e
@

Configuration Tab

Fig. 13: MicroEJ Launch Application Execution Tab

The next tabis the Configuration tab. Thistab contains all platform-specific options.

3.3. Standalone Application
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ﬂ Run Configurations n

Create. manage. and run configurations -
w,

S X B2 Name: | HelloWorld

type filter text 37 Main | s Execution | ifif Configuration g, JRE E Source | [[] Commen
[E] C/C++ Application 4 Debug
Ju JUnit Code Coverage
[ Launch Group Heap Dumper
4 [7] MicroE) Application 1Dwe
Logs
@ MicroE) Tool 4 Simulator
Com Port
F5
HAL
4 Target
Memory

Specify debug options

4 Libraries
EDC
Shielded Plug
. ECOM
FS
> Microll
Met
MNLS
S5L

. . Revert Apply
Filter matched 6 of 11 items

Fig. 14: Configuration Tab

JRE Tab

The next tabisthe JRE tab. Thistab allows you to configure the Java Runtime Environment used for running the
underlying launch script. It does not configure the MicroEJ Application execution. The VM Arguments text field
allows you to set vm-specific options, which are typically used to increase memory spaces:

« To modify heap space to 1024MB, set the -Xmx1024M option.

« To modify string space (also called PermGen space) to 256MB, set the -XX:PermSize=256M
-XX:MaxPermSize=256M options.

« To set thread stack space to 512MB, set the -Xss512M option.

Other Tabs

The next tabs ( Source and Common tabs) are the default Eclipse launch tabs. Refer to Eclipse help for more
details on how to use these launch tabs.
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3.3.5 Application Options
Introduction
To run a MicroEJ Standalone Application on a MicroEJ Platform, a set of options must be defined. Options can be
of different types:
« Memory Allocation options (e.g set the Java Heap size). These options are usually called link-time options.
« Simulator & Debug options (e.g. enable periodic Java Heap dump).
+ Deployment options (e.g. copy microejapp.o to a suitable BSP location).
« Foundation Library specific options (e.g. embed UTF-8 encoding).

The following section describes options provided by MicroEJ Architecture. Please consult the appropriate MicroEJ
Pack documentation for options related to other Foundation Libraries (MicroUl, NET, SSL, FS, ...) integrated to the
Platform.

Notice that some options may not be available, in the following cases:

« Option is specific to the MicroEJ Core Engine capability (tiny/single/multi) which is integrated in the targeted
Platform.

+ Option is specific to the target (MicroEJ Core Engine on Device or Simulator).

« Option has been introduced in a newer version of the MicroEJ Architecture which is integrated in the targeted
Platform.

+ Options related to Board Support Package (BSP) connection.

Defining an Option

A MicroEJ Standalone Application option can be defined either from a launcher or from a properties file. It is also
possible to use both together. Each MicroEJ Architecture and MicroEJ Pack option comes with a default value,
which is used if the option has not been set by the user.

Using a Launcher

To set an option in a launcher, perform the following steps:

1. In MicroEJ Studio/SDK, select Run > Run Configurations... menu,
2. Select the launcher of the application under MicroEJ Application or create a new one,

3. Select the Configuration tab,

4. Find the desired option and set it to the desired value.

It is recommended to index the launcher configuration to your version control system. To export launcher options
to the filesystem, perform the following steps:

1. Selectthe Common tab,
2. Selectthe Shared file: option and browse the desired export folder,

3. Pressthe Apply button. Afile named [launcher_configuration_name].launch is generated in the ex-
port folder.
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Using a Properties File

Options can be also be defined in properties files.

When a MicroEJ Standalone Application is built using the firmware-singleapp skeleton, options are loaded from
properties files located in the build folder at the root of the project.

The properties files are loaded in the following order:

1. Every file matching build/sim/x.properties, for Simulator options only (Virtual Device build). These files
are optional.

2. Every file matching build/emb/x.properties, for Device options only (Firmware build). These files are
optional.

3. Everyfile matching build/*.properties, bothfor Simulatorand Device options. At least one fileis required.
Usually, the build folder contains a single file named common.properties.

In case an option is defined in multiple properties files, the option of the first loaded file is taken into account and
the same option defined in the other files is ignored (a loaded option cannot be overridden).

The figure below shows the expected tree of the build folder:

v [ build
v [ emb
=| emb.properties
W [ sim
=| sim.properties

+ common.properties

Fig. 15: Build Options Folder

Itis recommended to index the properties files to your version control system.

To set an option in a properties file, open the file in a text editor and add a line to set the desired option to the
desired value. For example: soar.generate.classnames=false.

To use the options declared in properties files in a launcher, perform the following steps:
1. In MicroEJ Studio/SDK, select Run > Run Configurations... ,
2. Select the launcher of the application,
3. Selectthe Execution tab,
4. Under Option Files , pressthe Add... button,

5. Browse the sim.properties file for Simulator or the emb.properties file for Device (if any) and press
Open button,

6. Add the common.properties file and pressthe Open button.

Note: An option setin a properties file can not be modified in the Configuration tab. Options are loaded in the
order the properties files are added (you can use Up and Down buttons to change thefile order). In Configuration
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tab, hovering the pointer over an option field will show the location of the properties file that defines the option.

Generating a Properties File

In order to export options defined ina . launch file to a properties file, perform the following steps:

1. Selectthe [launcher_configuration_name].launch file,

2. Select File > Export > MicroEJ > Launcher as Properties File ,
3. Browse the desired output .properties file,
4. Pressthe Finish button.

Category: Runtime

w Device T
es
v CoreEngine P
Kernel [JEmbed all type names
Watchdog
Deploy
v Feature [] Execute assertions on Simulator
Dynamic Download
~ Libraries [] Execute assertions on Device
v ECOM
Comm Connection
EDC [ Enable execution traces
External Resources Loader
Shielded Plug [ start execution traces automatically

Assertions

Trace

~ Runtime
Memory
Simulator

<

Code Coverage
Com Port
Debug

Device

Heap Dumper
Logs

Group: Types
Option(checkbox): Embed all type names

Option Name: soar.generate.classnames
Default value: true
Description:

Embed the name of all types. When this option is disabled, only names of declared required types are embedded.
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Group: Assertions
Option(checkbox): Execute assertions on Simulator

Option Name: core.assertions.sim.enabled
Default value: false
Description:

When this option is enabled, assert statements are executed. Please note that the executed code may produce
side effects or throw java.lang.AssertionError.

Option(checkbox): Execute assertions on Device

Option Name: core.assertions.emb.enabled
Default value: false
Description:

When this option is enabled, assert statements are executed. Please note that the executed code may produce
side effects or throw java.lang.AssertionError.

Group: Trace
Option(checkbox): Enable execution traces

Option Name: core.trace.enabled

Default value: false

Option(checkbox): Start execution traces automatically

Option Name: core.trace.autostart

Default value: false
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Category: Memory

w Device Heaps

v CoreEngine L
Kernel Java heap size (in bytes) | |
Watchdog
Deploy
w Feature

Immortal heap size (in bytes) | |

Dynamic Download Threads

w Libraries Number of threads | |
v ECOM
Comm Connection Number of blocks in pool | |

EDC
External Resources Loader Block size (in bytes) | |
Shielded Plug

w Runtime Maximum size of thread stack (in blocks) | |
Memory

Simulator

<

Code Coverage
Com Port
Debug

Device

Heap Dumper
Logs

Group: Heaps
Option(text): Java heap size (in bytes)

Option Name: core.memory. javaheap.size
Default value: 65536

Description:

Specifies the Java heap size in bytes.

A Java heap contains live Java objects. An OutOfMemory error can occur if the heap is too small.

Option(text): Immortal heap size (in bytes)

Option Name: core.memory.immortal.size
Default value: 4096

Description:

Specifies the Immortal heap size in bytes.

The Immortal heap contains allocated Immortal objects. An OutOfMemory error can occur if the heap is too small.

Group: Threads

Description:
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This group allows the configuration of application and library thread(s). A thread needs a stack to run. This stack
is allocated from a pool and this pool contains several blocks. Each block has the same size. At thread startup the
thread uses only one block for its stack. When the first block is full it uses another block. The maximum number of
blocks per thread must be specified. When the maximum number of blocks for a thread is reached or when there
is no free block in the pool, a StackOverflow error is thrown. When a thread terminates all associated blocks are
freed. These blocks can then be used by other threads.

Option(text): Number of threads

Option Name: core.memory.threads.size
Default value: 5
Description:

Specifies the number of threads the application will be able to use at the same time.

Option(text): Number of blocks in pool

Option Name: core.memory.threads.pool.size
Default value: 15
Description:

Specifies the number of blocks in the stacks pool.

Option(text): Block size (in bytes)

Option Name: core.memory.thread.block.size
Default value: 512
Description:

Specifies the thread stack block size (in bytes).

Option(text): Maximum size of thread stack (in blocks)

Option Name: core.memory.thread.max.size
Default value: 4
Description:

Specifies the maximum number of blocks a thread can use. If a thread requires more blocks a StackOverflow error
will occur.
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Category: Simulator

~ Device Options
v CoreEngine

Kernel [[]Use target characteristics

Watchdog Slowing factor (0 means disabled): | 0
Deploy
v Feature . HIL Connectien
Dynamic Download
w Libraries [ Specify a port
w ECOM
Comm Connection 8001
EDC
External Resources Loader HIL connection timeout: | 10 |
Shielded Plug
~ Runtime Shielded Plug server configuration
. Memory Server socket port: | 10082 |
w Simulator

Code Coverage
Com Port
Debug

Device

Heap Dumper
Logs

Group: Options

Description:

This group specifies options for MicroEJ Simulator.

Option(checkbox): Use target characteristics

Option Name: s3.board.compliant
Default value: false
Description:

When selected, this option forces the MicroEJ Simulator to use the MicroEJ Platform exact characteristics. It sets
the MicroEJ Simulator scheduling policy according to the MicroEJ Platform one. It forces resources to be explicitly
specified. It enables log trace and gives information about the RAM memory size the MicroEJ Platform uses.

Option(text): Slowing factor (0 means disabled)

Option Name: s3.slow
Default value: 0
Description:

Format: Positive integer

This option allows the MicroEJ Simulator to be slowed down in order to match the MicroEJ Platform execution
speed. The greater the slowing factor, the slower the MicroEJ Simulator runs.
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Group: HIL Connection

Description:

This group enables the control of HIL (Hardware In the Loop) connection parameters (connection between MicroEJ
Simulator and the Mocks).

Option(checkbox): Specify a port

Option Name: s3.hil.use.port
Default value: false
Description:

When selected allows the use of a specific HIL connection port, otherwise a random free port is used.

Option(text): HIL connection port

Option Name: s3.hil.port
Default value: 8001
Description:

Format: Positive integer
Values: [1024-65535]

It specifies the port used by the MicroEJ Simulator to accept HIL connections.

Option(text): HIL connection timeout

Option Name: s3.hil.timeout
Default value: 10

Description:

Format: Positive integer

It specifies the time the MicroEJ Simulator should wait before failing when it invokes native methods.

Group: Shielded Plug server configuration

Description:

This group allows configuration of the Shielded Plug database.

Option(text): Server socket port

Option Name: sp.server.port
Default value: 10082

Description:

3.3. Standalone Application 47



MicroEJ Documentation, Revision 9c1bc719

Set the Shielded Plug server socket port.

Category: Code Coverage

~ Device Code Coverage
w CoreEngine
Kernel
Watchdog
Deploy
w Feature

[ Activate code coverage analysis

Dynamic Download
w Libraries
v ECOM
Comm Cennection
EDC
External Resources Loader
Shielded Plug
w Runtime
Memory
Simulator

<

Code Coverage
Com Port
Debug

Device

Heap Dumper
Logs

Group: Code Coverage

Description:

This group is used to set parameters of the code coverage analysis tool.

Option(checkbox): Activate code coverage analysis

Option Name: s3.cc.activated
Default value: false
Description:

When selected it enables the code coverage analysis by the MicroEJ Simulator. Resulting files are output in the cc
directory inside the output directory.

Option(text): Saving coverage information period (in sec.)

Option Name: s3.cc.thread.period
Default value: 15
Description:

It specifies the period between the generation of .cc files.
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Category: Debug

v Device Remote Debug
v CoreEngine
Kernel Debug port: | 12000
Watchdog
Deploy
w Feature

Dynamic Download
~ Libraries
w ECOM
Comm Connection
EDC
External Resources Loader
Shielded Plug
~ Runtime
Memory
w Simulator
Code Coverage
Com Port
Debug
Device
Heap Dumper
Logs

Group: Remote Debug
Option(text): Debug port

Option Name: debug.port
Default value: 12000
Description:

Configures the JDWP debug port.
Format: Positive integer

Values: [1024-65535]
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Category: Heap Dumper

~ Device Heap Inspection

v CoreEngine i
Kernel [] Activate heap dumper
Watchdog
Deploy
w Feature
Dynamic Download
~ Libraries
v ECOM
Comm Connection
EDC
External Resources Loader
Shielded Plug
~ Runtime
Memory
Simulator

<

Code Coverage
Com Port
Debug

Device

Heap Dumper
Logs

Group: Heap Inspection

Description:

This group is used to specify heap inspection properties.

Option(checkbox): Activate heap dumper

Option Name: s3.inspect.heap
Default value: false

Description:

When selected, this option enables a dump of the heap each time the System.gc() method is called by the MicroEJ

Application.
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Category: Logs

w Device

Logs
v CoreEngine L
system thread maonitoring
Kernel 2
Watchdog memory schedule monitors
Deploy
w Feature 2

Dynamic Download
~ Libraries
w ECOM
Comm Connection
EDC
External Resources Loader
Shielded Plug
~ Runtime
Memory
Simulator

<

Code Coverage
Com Port
Debug

Device

Heap Dumper
Logs

Group: Logs

Description:

This group defines parameters for MicroEJ Simulator log activity. Note that logs can only be generated if the
Simulator > Use target characteristics optionis selected.

Some logs are sent when the platform executes some specific action (such as start thread, start GC, etc), other logs
are sent periodically (according to defined log level and the log periodicity).

Option(checkbox): system

Option Name: console.logs.level.low

Default value: false

Description:

When selected, System logs are sent when the platform executes the following actions:
start and terminate a thread

start and terminate a GC

exit

Option(checkbox): thread

Option Name: console.logs.level.thread
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Default value: false
Description:

When selected, thread information is sent periodically. It gives information about alive threads (status, memory
allocation, stack size).

Option(checkbox): monitoring

Option Name: console.logs.level .monitoring
Default value: false
Description:

When selected, thread monitoring logs are sent periodically. It gives information about time execution of threads.

Option(checkbox): memory

Option Name: console.logs.level .memory
Default value: false
Description:

When selected, memory allocation logs are sent periodically. This level allows to supervise memory allocation.

Option(checkbox): schedule

Option Name: console.logs.level.schedule
Default value: false
Description:

When selected, a log is sent when the platform schedules a thread.

Option(checkbox): monitors

Option Name: console.logs.level .monitors
Default value: false
Description:

When selected, monitors information is sent periodically. This level permits tracing of all thread state by tracing
monitor operations.

Option(text): period (in sec.)

Option Name: console.logs.period
Default value: 2
Description:

Format: Positive integer
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Values: [0-60]

Defines the periodicity of periodical logs.

Category: Device

w Device Device Architecture
w CoreEngine
Kernel
Watchdog
Deploy

[] Use a custom device architecture

~ Feature
Device Uni D
Dynamic Download evice Lnique

w Libraries [ Use a custom device unique ID
w ECOM
Comm Cennection
EDC
External Resources Loader
Shielded Plug
w Runtime
Memory
~ Simulator
Code Coverage
Com Port
Debug
Device
Heap Dumper
Logs

Group: Device Architecture

Option(checkbox): Use a custom device architecture

Option Name: s3.mock.device.architecture.option.use

Default value: false

Option(text): Architecture Name

Option Name: s3.mock.device.architecture.option

Default value: (empty)

Group: Device Unique ID

Option(checkbox): Use a custom device unique ID

Option Name: s3.mock.device.id.option.use

Default value: false
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Option(text): Unique ID (hexadecimal value)

Option Name: s3.mock.device.id.option

Default value: (empty)

Category: Com Port

w Device
w CoreEngine
Kernel
Watchdog
Deploy
w Feature
Dynamic Download
w Libraries
v ECOM
Comm Cennection
EDC
External Resources Loader
Shielded Plug
w Runtime
Memory
~ Simulator
Code Coverage
Com Port
Debug
Device
Heap Dumper
Logs
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Category: Libraries

w Device
w CoreEngine
Kernel
Watchdog
Deploy
w Feature
Dynamic Download
w Libraries
v ECOM
Comm Cennection
EDC
External Resources Loader
Shielded Plug
w Runtime
Memory
~ Simulator
Code Coverage
Com Port
Debug
Device
Heap Dumper
Logs

Category: EDC

w Device Java System.out

v Cor;:rr;gewlne [ Use a custom Java output stream
Watchdog
Deploy
w Feature

Runti ti
Dynamic Download B

~ Libraries Embed UTF-8 enceding
v ECOM .
Comm Connection []Enable SecurityManager checks
EDC
External Resources Loader
Shielded Plug

~ Runtime
Memary

w Simulator
Code Coverage
Com Port
Debug
Device
Heap Dumper
Logs

Group: Java System.out
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Option(checkbox): Use a custom Java output stream

Option Name: core.outputstream.disable.uart

Default value: false

Description:

Select this option to specify another Java System.out print stream.

If selected, the default Java output stream is not used by the Java application. the JPF will not use the default Java
output stream at startup.

Option(text): Class

Option Name: core.outputstream.class

Default value: (empty)

Description:

Format: Java class like packageA.packageB.className
Defines the Java class used to manage System.out.

At startup the JPF will try to load this class using the Class.forName() method. If the given class is not available,
the JPF will use the default Java output stream as usual. The specified class must be available in the application
classpath.

Group: Runtime options

Description:

Specifies the additional classes to embed at runtime.

Option(checkbox): Embed UTF-8 encoding

Option Name: cldc.encoding.utf8.included
Default value: true
Description:

Embed UTF-8 encoding.

Option(checkbox): Enable SecurityManager checks

Option Name: com.microej.library.edc.securitymanager.enabled
Default value: false
Description:

Enable the security manager runtime checks.
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Category: Shielded Plug

~ Device Shielded Plug cenfiguration

v CoreEngine
Kernel Database definition: Browse...
Watchdog

Deploy
w Feature

Dynamic Download
~ Libraries
w ECOM
Comm Connection
EDC
External Resources Loader
Shielded Plug
~ Runtime
Memory
w Simulator
Code Coverage
Com Port
Debug
Device
Heap Dumper
Logs

Group: Shielded Plug configuration

Description:

Choose the database XML definition.

Option(browse): Database definition

Option Name: sp.database.definition
Default value: (empty)
Description:

Choose the database XML definition.
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Category: ECOM

w Device Device Management

v CoreEngine ] ) -
Kernel [ Enable registration event notifications
Watchdog
Deploy
w Feature
Dynamic Download
~ Libraries
w ECOM
Comm Connection
EDC
External Resources Loader
Shielded Plug
~ Runtime
Memory
w Simulator
Code Coverage
Com Port
Debug
Device
Heap Dumper
Logs

Group: Device Management
Option(checkbox): Enable registration event notifications

Option Name: com.is2t.ecom.eventpump.enabled
Default value: false
Description:

Enables notification of listeners when devices are registered or unregistered. When a device is registered or un-
registered, a new ej.ecom.io.RegistrationEvent isadded to an event queue. Then events are processed by a
dedicated thread that notifies registered listeners.

Option(text): Registration events queue size

Option Name: com.is2t.ecom.eventpump.size
Default value: 5
Description:

Specifies the size (in number of events) of the registration events queue.
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Category: Comm Connection

w Device Comm Connection Options

w CoreEngine

Kernel []Enable comm connections

Watchdog
Deploy Device Management

v Feature Enable dynamic comm ports registration
Dynamic Download
~ Libraries
v ECOM
Comm Connection
EDC
External Resources Loader
Shielded Plug
~ Runtime
Memory
~ Simulator
Code Coverage
Com Port
Debug
Device
Heap Dumper
Logs

Group: Comm Connection Options

Description:

This group allows comm connections to be enabled and application-platform mappings set.

Option(checkbox): Enable comm connections

Option Name: use.comm.connection
Default value: false
Description:

When checked application is able to open a CommConnection.

Group: Device Management
Option(checkbox): Enable dynamic comm ports registration

Option Name: com.is2t.ecom.comm.registryPump.enabled
Default value: false
Description:

Enables registration (or unregistration) of ports dynamically added (or removed) by the platform. A dedicated
thread listens for ports dynamically added (or removed) by the platform and adds (or removes) their CommPort
representation to the ECOM DeviceManager .
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Category: External Resources Loader

<

Device External Resources Loader

v CoreEngine

Kernel Folder where are stored the resources which will be pregrammed outside CPU address
space range (storage media like SD card, serial NOR flash, EEPROM).
Watchdog The resources which will be linked into the CPU address space range (internal
Deploy device memeories, external parallel memories) must be listed in the Resources box
w Feature of Main tab.

Dynamic Download

~ Libraries
v ECOM
Comm Connection
EDC
External Resources Loader
Shielded Plug
~ Runtime

Browse...

Memory

w Simulator
Code Coverage
Com Port
Debug
Device
Heap Dumper
Logs

Group: External Resources Loader

Description:

This group allows to specify the external resources input folder. The content of this folder will be copied in an
application output folder and used by SOAR and the Simulator. If empty, the default location will be [output
folder]/externalResources, where [output folder] is the location defined in Execution tab.

Option(browse):

Option Name: ej.externalResources.input.dir
Default value: (empty)
Description:

Browse to specify the external resources folder..
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Category: Device

w Device
w CoreEngine
Kernel
Watchdog
Deploy
w Feature
Dynamic Download
w Libraries
v ECOM
Comm Cennection
EDC
External Resources Loader
Shielded Plug
w Runtime
Memory
~ Simulator
Code Coverage
Com Port
Debug
Device
Heap Dumper
Logs

Category: Core Engine

v Device
v CoreEngine
Kernel
Watchdog
Deploy
w Feature
Dynamic Download
~ Libraries
v ECOM
Comm Connection
EDC
External Resources Loader
Shielded Plug
~ Runtime
Memary
w Simulator
Code Coverage
Com Port
Debug
Device
Heap Dumper
Logs

Group: Memory

Specify target options

Memory

Maximum number of monitors per thread

Maximum number of frames dumped on OutOfMemoryError
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Option(text):

Option Name: core.memory.thread.max.nb.monitors
Default value: 8
Description:

Specifies the maximum number of monitors a thread can own at the same time.

Option(text):

Option Name: core.memory.oome.nb.frames
Default value: 5
Description:

Specifies the maximum number of stack frames that can be dumped to the standard output when Core Engine
throws an OutOfMemoryError.

Category: Kernel

Device

<

[] Check APIs allowed by Kernel
v CoreEngine

Kernel Threads
Watchdog
Deploy
~ Feature

Maximum number of threads per Feature | |

Installed Features
Dynamic Download

w Libraries Maximum number of installed Features | |
v ECOM
Comm Connection Code Size (in bytes) | |
EDC
External Resources Loader Runtime Size (in bytes) | |
Shielded Plug
~ Runtime

Memary

w Simulator
Code Coverage
Com Port
Debug
Device
Heap Dumper
Logs

Option(checkbox): Check APIs allowed by Kernel

Option Name: apis.check.enable

Default value: true
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Group: Threads

Option(text):

Option Name: core.memory.feature.max.threads
Default value: 5

Description:

Specifies the maximum number of threads a Feature is allowed to use at the same time.

Group: Installed Features

Option(text):

Option Name: core.memory.installed.features.max
Default value: 0

Description:

Specifies the maximum number of installed Features that can be added to this Kernel.

Option(text):

Option Name: core.memory.installed.features.text.size
Default value: ©
Description:

Specifies the size in bytes reserved for installed Features code.

Option(text):

Option Name: core.memory.installed.features.bss.size
Default value: ©
Description:

Specifies the size in bytes reserved for installed Features runtime memory.
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Category: Watchdog

v Device
+ CoreEngine [ Enable watchdog support

Kernel Watchdog
Watchdog Mazximum number of active watchdogs
Deploy

w Feature
Dynamic Download
~ Libraries
w ECOM
Comm Connection
EDC
External Resources Loader
Shielded Plug
~ Runtime
Memory
w Simulator
Code Coverage
Com Port
Debug
Device
Heap Dumper
Logs

Option(checkbox): Enable watchdog support

Option Name: enable.watchdog. support

Default value: true

Group: Watchdog
Option(text):

Option Name: maximum.active.watchdogs
Default value: 4

Description:

Specifies the maximum number of active watchdogs at the same time.
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Category: Deploy

~ Device Configuration

v CoreEngine
Kemgel [ Deploy the compiled MicroE) application in a folder in MicroE) application main class project
Watchdog
Deploy
w Feature

Output file: | Browse...

Dynamic Download
~ Libraries
w ECOM
Comm Connection
EDC
External Resources Loader
Shielded Plug
~ Runtime
Memory
Simulator

<

Code Coverage
Com Port
Debug

Device

Heap Dumper
Logs

Description:

Configures the output location where store the MicroEJ Application, the MicroEJ platform libraries and header files.

Group: Configuration

Option(checkbox): Deploy the compiled MicroEJ Application in a folder in MicroEJ Application main class
project

Default value: true
Description:

Deploy the compiled MicroEJ Application in a folder in MicroEJ Application’s main class project.

Option(browse): Output file

Option Name: deploy.copy.filename
Default value: (empty)
Description:

Choose an output file location where copy the compiled MicroEJ Application.
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Category: Feature

e [‘J'ewcc:re Engine Specify Feature options
Kernel
Watchdog
Deploy
~ Feature
Dynamic Download
w Libraries
w ECOM
Comm Connection
EDC
External Resources Loader
Shielded Plug
w Runtime
Memory
w Simulator
Code Coverage
Com Port
Debug
Device
Heap Dumper
Logs

Description:

Specify Feature options
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Category: Dynamic Download

w Device Dynamic Download

v CoreEngine

Kernel Output Name: |
Watchdog
Deploy Kernel: | F—
w Feature

Dynamic Download
~ Libraries
w ECOM
Comm Connection
EDC
External Resources Loader
Shielded Plug
~ Runtime
Memory
Simulator

<

Code Coverage
Com Port
Debug

Device

Heap Dumper
Logs

Group: Dynamic Download
Option(text): Output Name

Option Name: feature.output.basename

Default value: application

Option(browse): Kernel

Option Name: kernel.filename

Default value: (empty)

3.3.6 SOAR

SOAR complies with the deterministic class initialization ( <clinit>) order specified in /[BON]. The application is
statically analyzed from its entry points in order to generate a clinit dependency graph. The computed clinit se-
quence is the result of the topological sort of the dependency graph. An error is thrown if the clinit dependency
graph contains cycles.

An explicit clinit dependency can be declared by creating an XML file with the .clinitdesc extension in the ap-
plication classpath. The file has the following format:

<?xml version='1.0' encoding='UTF-8'?>
<clinit>
(continues on next page)
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(continued from previous page)

<type name="T1" depends="T2"/>
</clinit>

where T1 and T2 are fully qualified names on the form a.b.C. This explicitly forces SOAR to create a dependency
from T1 to T2, and therefore cuts a potentially detected dependency from T2 to T1.

Aclinit map file (ending with extension .clinitmap)is generated beside the SOAR object file. It describes for each
clinit dependency:

+ the typesinvolved
« the kind of dependency

« the stack calls between the two types

3.4 Sandboxed Application

3.4.1 Sandboxed Application Structure

Application Skeleton Creation

The first step to explore a Sandboxed Application structure is to create a new project.

Firstselect File > New > MicroEJ Sandboxed Application Project :

Fillin the application template fields, the Project name field will automatically duplicate in the following fields.

A template project is automatically created and ready to use, this project already contains all folders wherein de-
velopers need to put content:

src/main/java Folder for future sources;
src/main/resources Folder for future resources (images, fonts, etc.);
META-INF Sandboxed Application configuration and resources;

module.ivy Ivyinput file, dependencies description for the current project.

Sources Folder

The project source folder ( src/main) contains two subfolders: java and resources. java folder will contain all
*. java files of the project, whereas resources folder will contain elements that the application needs at runtime
like raw resources, images or character fonts.

META-INF Folder

The META-INF folder contains several folders and a manifest file. They are described hereafter.
certificate (folder) Contains certificate information used during the application deployment.

libraries (folder) Contains a list of additional libraries useful to the application and not resolved through the
regular transitive dependency check.

properties (folder) Containsan application.properties file which contains application specific properties
that can be accessed at runtime.
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services (folder) Contains a list of files that describe local services provided by the application. Each file name
represents a service class fully qualified name, and each file contains the fully qualified name of the provided
service implementation.

wpk (folder) Contains a set of applications ( .wpk files) that will be started when the application is executed on
the Simulator.

MANIFEST.MF (file) Containsthe information given at project creation, extra information can be added to this file
to declare the entry points of the application.

module.ivy File

The module.ivy file describes all the libraries required by the application at runtime. The lvy classpath container
lists all the modules that have been automatically resolved from the content of module.ivy . See MicroEJ Module
Manager for more informations about MicroEJ Module Manager.

3.4.2 Application Publication

Build the WPK

When the application is ready for deployment, the last step in MicroEJ Studio is to create the WPK (Wadapps Pack-
age) file that is intended to be published on a MicroEJ Forge instance for end users.

In MicroEJ Studio, right-click on the Sandboxed Application project name and select Build Module.

The WPK build process will display messages in MicroEJ console, ending up the following message:

[echo] project hello published locally with version 0.1.0-RC201907091602
BUILD SUCCESSFUL

Total time: 1 minute 6 seconds

Publish on a MicroEJ Forge Instance

The WPK file produced by the build process is located in a dedicated target~/artifacts folderin the project.

The .wpk fileis ready to be uploaded to a MicroEJ Forge instance. Please consult https://community.microej.com
for more information.

3.4.3 Shared Interfaces
Principle

The Shared Interface mechanism provided by MicroEJ Core Engine is an object communication bus based on plain
Java interfaces where method calls are allowed to cross MicroEJ Sandboxed Applications boundaries. The Shared
Interface mechanism is the cornerstone for designing reliable Service Oriented Architectures on top of MicroEJ.
Communication is based on the sharing of interfaces defining APIs (Contract Oriented Programming).

The basic schema:
« Aprovider application publishes an implementation for a shared interface into a system registry.

+ Auser application retrieves the implementation from the system registry and directly calls the methods de-
fined by the shared interface.
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USER APPLICATION PROVIDER APPLICATION

Shared Interface Call

AA.mm() > mm() {
//code

}

MICROEJ CORE ENGINE

Fig. 16: Shared Interface Call Mechanism

Shared Interface Creation

Creation of a shared interface follows three steps:
« Interface definition,
« Proxy implementation,

+ Interface registration.

Interface Definition

The definition of a shared interface starts by defining a standard Java interface.

package mypackage;

public interface MyInterface(
void foo();

3

To declare an interface as a shared interface, it must be registered in a shared interfaces identification file. A shared
interface identification file is an XML file with the .si suffix with the following format:

<sharedInterfaces>
<sharedInterface name="mypackage.MyInterface"/>
</sharedInterfaces>

Shared interface identification files must be placed at the root of a path of the application classpath. For a MicroEJ
Sandboxed Application project, it is typically placed in src/main/resources folder.
Some restrictions apply to shared interface compared to standard java interfaces:

+ Types for parameters and return values must be transferable types;

« Thrown exceptions must be classes owned by the MicroEJ Firmware.

Transferable Types

In the process of a cross-application method call, parameters and return value of methods declared in a shared
interface must be transferred back and forth between application boundaries.
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USER APPLICATION Shared Interface Transfer [FHMSALCSS AR IREL.

R = AA.mm(P1, P2)

Fig. 17: Shared Interface Parameters Transfer

Shared Interface Types Transfer Rules describes the rules applied depending on the element to be transferred.

Table 1: Shared Interface Types Transfer Rules

Type Owner Instance Rule
Owner

Base type N/A N/A Passing by value. (boolean, byte, short
, char, int, long, double, float)

Any Class, Array or Inter- | Kernel Kernel Passing by reference

face

Any Class, Array or Inter- | Kernel Application Kernel specific or forbidden

face

Array of base types Any Application Clone by copy

Arrays of references Any Application | Clone and transfer rules applied again on
each element

Shared Interface Application Application Passing by indirect reference (Proxy cre-
ation)

Any Class, Array or Inter- | Application Application Forbidden

face

Objects created by an application which class is owned by the Kernel can be transferred to another application
if this has been authorized by the Kernel. The list of eligible types that can be transferred is Kernel specific, so
you have to consult the firmware specification. MicroEJ Evaluation Firmware Example of Transfer Types lists Kernel
types allowed to be transferred through a shared interface call. When an argument transfer is forbidden, the call is
abruptly stopped and a java.lang.IllegalAccessError isthrown by MicroEJ Core Engine.

Table 2: MicroEJ Evaluation Firmware Example of Transfer Types

Type Rule
Clone by copy

java.lang.String

. . Proxy reference creation
java.io.InputStream

Clone by deep copy

java.util.Map<String,String>

Proxy Class Implementation

The Shared Interface mechanism is based on automatic proxy objects created by the underlying MicroEJ Core En-
gine, so that each application can still be dynamically stopped and uninstalled. This offers a reliable way for users
and providers to handle the relationship in case of a broken link.

Once a Java interface has been declared as Shared Interface, a dedicated implementation is required (called the
Proxy class implementation). Its main goal is to perform the remote invocation and provide a reliable implemen-
tation regarding the interface contract even if the remote application fails to fulfill its contract (unexpected excep-
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tions, application killed...). The MicroEJ Core Engine will allocate instances of this class when an implementation
owned by another application is being transferred to this application.

USER APPLICATION PROVIDER APPLICATION

R = AA.mm(P1, P2

Proxy Class

MICROEJ CORE ENGINE

Transfer

Shared Interfaces Binding

Fig. 18: Shared Interfaces Proxy Overview

A proxy class is implemented and executed on the client side, each method of the implemented interface must be
defined according to the following pattern:

package mypackage;
public class MyInterfaceProxy extends Proxy<MyInterface> implements MyInterface {

@0verride
public void foo(){
try {
invoke(); // perform remote invocation
} catch (Throwable e) {
e.printStackTrace();

b
3

Each implemented method of the proxy class is responsible for performing the remote call and catching all errors
from the server side and to provide an appropriate answer to the client application call according to the interface
method specification (contract). Remote invocation methods are defined in the super class ej.kf.Proxy and are
named invokeXXX() where XXX is the kind of return type. As this class is part of the application, the application
developer has the full control on the Proxy implementation and is free to insert additional code such as logging
calls and errors for example.

Table 3: Proxy Remote Invocation Built-in Methods

Invocation Method Usage
void invoke() Remote invocation for a proxy method that returns void
Object invokeRef() Remote invocation for a proxy method that returns a reference

boolean invokeBoolean(), byte invokeByte(), | Remote invocation for a proxy method that returns a base type
char invokeChar(), short invokeShort(), int in-
vokelnt(), long invokeLong(), double invoke-
Double(), float invokeFloat()
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3.5 Virtual Device

3.5.1 Using a Virtual Device for Simulation

The Virtual Device includes the same custom MicroEJ Core, libraries and System Applications as the real device.
The Virtual Device allows developers to run their applications either on the Simulator, or directly on the real device
through local deployment.

The Simulator runs a mockup board support package (BSP Mock) that mimics the hardware functionality. An ap-
plication on the Simulator is run as a Standalone Application.

Before an application is locally deployed on device, MicroEJ Studio ensures that it does not depend on any API that
is unavailable on the device.

YOUR APPLICATIONS

ADD-ON LIBRARIES

Web / REST servers | MQTT/LWM2M clients | JSON | CBOR | Crypto | Widgets | Components | Eclasspath | ...

FOUNDATION LIBRARIES

I ST

% MICROEJ VEE

VIRTUALIZATION
g ~
Engine Simulator

Linux / Windows [ macOS

PLATFORM

PROCESSOR
Ethernet D CORE Serial Bluetooth

WORKSTATION

Wi-Fi / LTE Display

Fig. 19: MicroEJ Virtual Device Architecture

3.5.2 Runtime Environment

The set of MicroEJ APIs exposed by a Virtual Device (and therefore provided by its associated firwmare) is docu-
mented in Javadoc format in the MicroEJ Resource Center ( Window > Show View > MicroEJ Resource Center

).
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i® MicroE) Resource Center 53
type filter text

4 | 2] Javadoc
[ MICROEJ-DEVELOPER-RUNTIME 1.0

- @2 Online Resources

Fig. 20: MicroEJ Resource Center APIs

3.6 MicroEJ Module Manager

3.6.1 Introduction

Modern electronic device design involves many parts and teams to collaborate to finally obtain a product to be sold
on its market. MicroEJ encourages modular design which involves various stake holders: hardware engineers, UX
designers, graphic designers, drivers/BSP engineers, software engineers, etc.

Modular design is a design technique that emphasizes separating the functionality of an application into inde-
pendent, interchangeable modules. Each module contains everything necessary to execute only one aspect of
the desired functionality. In order to have team members collaborate internally within their team and with other
teams, MicroEJ provides a powerful modular design concept, with smart module dependencies, controlled by the
MicroEJ Module Manager (MMM). MMM frees engineers from the difficult task of computing module dependencies.
Engineers specify the bare minimum description of the module requirements.

The following schema introduces the main concepts detailed in this chapter.
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[#) CHANGELOG.md

Module i) LICENSEtxt Build & Publish Module

Description by module.ivy »  Module Repository
File (] README.md
I 4

Module Project Skeleton

Fig. 21: MMM Overview

MMM is based on the following tools:
« Apache lvy (http://ant.apache.org/ivy) for dependencies resolution and module publication;

« Apache EasyAnt (https://ant.apache.org/easyant/history/trunk/reference.html) for module build from
source code.

3.6.2 Specification

MMM provides a non ambiguous semantic for dependencies resolution. Please consult the MMM specification
available on https://developer.microej.com/packages/documentation/TLT-0831-SPE-MicroEJModuleManager-2.
0-E.pdf.

3.6.3 Module Project Skeleton

In MicroEJ SDK, a new MicroEJ module project is created as following:

+ Select File > New > Project... ,

« Select MicroEJ > MicroEJ Module Project ',

« Fill the module information (project name, module organization, name and revision),
+ Select one of the suggested skeletons depending on the desired module nature,

« Clickon Finish .

11f using MicroEJ SDK versions lower than 5.2.0, please refer to the following section.
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The project is created and a set of files and directories are generated from the selected skeleton.

Note: When an empty Eclipse project already exists or when the skeleton has to be created within an existing
directory, the MicroEJ module is created as following:

« In the Package Explorer, click on the parent project or directory,

« Select File > New > Other... ,

+ Select EasyAnt > EasyAnt Skeleton .

3.6.4 Module Description File

Amodule descriptionfileis an Ivy configuration file named module. ivy, located at the root of each MicroEJ module
project. It describes the module nature (also called build type) and dependencies to other modules.

<ivy-module version="2.0" xmlns:ea="http://www.easyant.org” xmlns:m="http://ant.apache.org/ivy/extra”
xmlns:ej="https://developer.microej.com” ej:version="2.0.0">
<info organisation="[organisation]” module="[name]" status="integration” revision="[version]">
<ea:build organisation="com.is2t.easyant.buildtypes” module="[buildtype_name]” revision=
—"[buildtype_version]">
<ea:property name="[buildoption_name]"” value="[buildoption_value]"/>
</ea:build>
</info>

<configurations defaultconfmapping="default->default;provided->provided">
<conf name="default” visibility="public"/>
<conf name="provided" visibility="public"/>
<conf name="documentation” visibility="public"/>
<conf name="source" visibility="public"/>
<conf name="dist"” visibility="public"/>
<conf name="test"” visibility="private"/>
</configurations>

<publications>
</publications>

<dependencies>
<dependency org="[dep_organisation]” name="[dep_name]” rev="[dep_version]"/>

</dependencies>
</ivy-module>

Enable MMM Semantic

The MMM semantic is enabled in a module by adding the MicroEJ XML namespace and the ej:version attribute
inthe ivy-module node:

<ivy-module xmlns:ej="https://developer.microej.com” ej:version="2.0.0">

Note: Multiple namespaces can be declared in the ivy-module node.

MMM semantic is enabled in the module created with the Module Project Skeleton.
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Module Dependency

Module dependencies are added to the dependencies node as follow:

<dependencies>
<dependency org="[dep_organisation]” name="[dep_name]"” rev="[dep_version]"/>
</dependencies>

When no matching rule is specified, the default matching rule is compatible.

Dependency Matching Rule

The following matching rules are specified by MMM:

Name Range Notation Semantic

compatible [M.m.p-RC, (M+1).0.0-RC][ Equal or up to next major version. Default if
not set.

equivalent [M.m.p-RC, M.(m+1).0-RC [ Equal or up to next minor version

greaterOrEqual [M.m.p-RC, oo Equal or greater versions

perfect [M.m.p-RC, M.m.(p+1)-RC[ Exact match (strong dependency)

Set the matching rule of a given dependency with ej:match="matching rule”.Forexample:

<dependency org="[dep_organisation]” name="[dep_name]” rev="[dep_version]" ej:match="perfect” />

Dependency Visibility

« Adependency declared public is transitively resolved by upper modules. The default when not set.
« Adependency declared private isonly used by the module itself, typically for:

- Bundling the content into the module

- Testing the module

The visibility is set by the configurations declared in the configurations node. For example:

<configurations defaultconfmapping="default->default;provided->provided">
<conf name="[conf_name]” visibility="private"/>
</configurations>

The configuration of a dependency is specified by setting the conf attribute, for example:

<dependency org="[dep_organisation]” name="[dep_name]"” rev="[dep_version]"” conf="[conf_name]->x" />

Automatic Update Before Resolution

The Easyant plugin ivy-update can be used to automatically update the version (attribute rev ) of every module
dependencies declared.

<info organisation="[organisation]” module="[name]"” status="integration” revision="[version]">
<ea:plugin org="com.is2t.easyant.plugins” name="ivy-update"” revision="1.+" />
</info>
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When the plugin is enabled, for each module dependency, MMM will check the version declared in the module file
and update it to the highest version available which satisfies the matching rule of the dependency.

Build Options

MMM Build Options can be set with:
<ea:property name="[buildoption_name]” value="[buildoption_value]"/>

The following build options are globally available:

Table 4: Build Options

Property | Description Default Value
Name

Path to the build directory target~.
target ${basedir}/target~

Refer to the documentation of Module Natures for specific build options.

3.6.5 MicroEJ Module Manager Configuration

By default, when starting an empty workspace, MicroEJ SDK is configured to import dependencies from
MicroEJ Central Repository and to publish built modules to a local folder. The repository configura-
tion is stored in a settings file ( ivysettings.xml ), and the default one is located at $USER_HOME\.
microej\microej-ivysettings-[VERSION].xml

Preferences Page

The MMM preferences page in the MicroEJ SDK is available at Window > Preferences > MicroEJ >

Module Manager .
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Fig. 22: MMM Preferences Page

This page allows to configure the following elements:

1.
2.
3.

Settings File:the file describing how to connect module repositories. See the settings file section.
Options: files declaring MMM options. See the Options section.

Use Module repository as Build repository:thesettings file for connecting the build repositoryin place
of the one bundled in MicroEJ SDK. This option shall not be enabled by default and is reserved for advanced
configuration.

Build repository Settings File:the settings file for connecting the build repository in place of the one
bundled in MicroEJ SDK. This option is automatically initialized the first time MicroEJ SDK is launched. It
shall not be modified by default and is reserved for advanced configuration.

Set verbose mode : to enable advanced debug traces when building a module.
Runtime JRE :the Java Runtime Environment that executes the build process.
Max build history size:the maximum number of previous builds available in Build Module shortcut

list:

3

File Refactor Mavigate Search  Project  Run
cruoiv[@]Jeis-0-a-i@e-

4 Package Explorer 33 | ) Build Selected Module (Ctrl+Alt-C, E)

workspaceRepository -

Edit Source
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Settings File

The settings file is an XML file that describes how MMM connects local or online module repositories. The file format
is described in Apache lvy documentation.

To configure MMM to a custom settings file (usually from an offline repository):

1. Set Settings file toacustom ivysettings.xml settings file',

2. Clickon Apply and Close button

If the workspace is not empty, it is recommended to trigger a full resolution and rebuild all the projects using this
new repository configuration:

1. Clean caches

« In the Package Explorer, right-click on a project;
« Select Ivy > Cleanallcaches .
2. Resolve projects using the new repository

To resolve all the workspace projects, click on the Resolve All button in the toolbar:

'® workspaceRepository -

File Edit Source Refactor Mavigate Searc

Awi | R il v o

To only resolve a subset of the workspace projects:

« In the Package Explorer, select the desired projects,
+ Right-click on a project and select lvy > Clean all caches .
3. Trigger Add-On Library processors for automatically generated source code

+ Select Project > Clean... ,
+ Select Clean all projects |,

o Clickon Clean button.

Options

Options can be used to parameterize a module description file or a settings file. Options are declared as key/value
pairsin a standard Java properties file, and are expanded using the ${my_property} notation.

Atypical usage in a settings file is for extracting repository server credentials, such as HTTP Basic access authenti-
cation:

1. Declare options in a properties file
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[E| credentials.properties &

1# User specific credentials
2 artifactory.username=myusername
3 artifactory.password=AKCKLzp2JHRLDyFvmTPMXocXiiU1Cnad7eidUcCO1ERSUdgIrIu24ZTYieXaCwuMaIWykjCD9

4

2. Register this property file to MMM options

Options

Property files: | Sfworkspace_loctest/credentials.properties}

3. Usethis option in a settings file

38
39 <credentials host="artifactory.corp” realm="Artifactory Realm” username="${artifactory.username}” passwd="$§{artifactory.password}” />
4/

Atypical usage in a module description file is for factorizing dependency versions across multiple modules projects:

1. Declare an option in a properties file

=| versions.properties &3

=l
14# Specify the EDC wersion used in this workspace
2 edc.version=1.3.8

pu

2. Register this property file to MMM options

Options

Property files: | S{workspace_loc:test/versions.properties)

3. Use this option in a module description file

22 <dependencies:

23 ol--

24 Use the EDC version defined by MMM configuration

25 -

26 <dependency org="ej.api" name="edc" rev="%{edc.version}" /»
27 </dependencies:

28 ¢/ivy-module:
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3.6.6 Module Build

In MicroEJ SDK, the build of a MicroEJ module project can be started as following:

« In the Package Explorer, right-click on the project,
+ Select Build Module .

Awilh B BR-PDHF-O0-QU-FOE- BB
[% Package Explorer 51 T¢ Type Hierarchy s § = E
v'_,ff- module ,
= src/r W
B sre/ Go Into
i f . .
o> srcit Open in New Window
B sroft _
v B\ Moc Open Type Hierarchy F4
e Show In Alt+Shift+ W > broej com-5g).
= STC | =y
- = Co Ctrl+C
) CHa ' CoPY
= Lcg 52 Copy Qualified Name
by moc [ Paste Ctrl+W
REAl 3¢ Delete Delete
Build Path H
Source Alt+Shift+5 »
Refactor Alt+5hift+T >
fxy Import..
iy Export.
i Refresh F5
Close Project
Assign Working Sets...
) PRunAs »
%3 Debug As »
Profile As *
& Build Module
restare trom Local History...
@ JAutodoc ¥

Fig. 23: Module Build

The build of a module can take time depending on

« the module nature to build,
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« the number and the size of module dependencies to download,
« the repository connection bandwidth, ...
The module build logs are redirected to the integrated console.

Alternatively, the build of a MicroEJ module project can be started from the build history:

Hmi DG P H-Q-Q

[ Package Explorer @ module3

4 module E modulel
'l_'—,‘f- moduled [Tﬂ maodule
'l_'—,"f- madule3

Fig. 24: Module Build History

3.6.7 Build Kit

The Module Manager build kit is the consistent set of tools and scripts required for building modules.

It is bundled with MicroEJ SDK and can be exported to run in headless mode using the following steps:'

+ Select File > Export > MicroEJ > Module Manager Build Kit ,
+ Choose an empty Target directory ,

+ Clickonthe Finish button.
Once the build kit is fully exported, the directory content shall look like:
w [ sdk_5.2.0 build_kit
w [ ant

= lib
microgj-build-repository.zip

To go further with headless builds, please consult Tool-CommandLineBuild for command line builds, and this tu-
torial to setup MicroEJ modules build in continuous integration environments).

3.6.8 MMM CLI

The MicroEJ SDK also provides a new Command Line Interface (CLI). It allows to perform all the main development
operations without the MicroEJ SDK. This CLI is the good tool if you want to work in a terminal or in any other IDE.

The following operations are supported:
« creating a module project

+ building a module project
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« running the project application on the simulator

+ publishing a module in a module repository

Installation

The steps to install MMM CLI are:
« download the MMM CLI archive
« extract the archive in any directory
« add the bin directory of the created directory to the PATH environment variable of your machine

« make sure the JAVA_HOME environment variable is set and points to a JRE/JDK installation or that java
executable isin the PATH environment variable (Java 8 is required)

confirmthat theinstallation works fine by executing the command mmm --version. Theresult should display
the MMM CLI version.

Usage

In order to use the MMM CLI for your project:
+ go to the root folder of your project
« run the command mmm [<subcommand>]
where subcommand is the subcommand to execute (for example mmm build). The available subcommands are:
« init:create a project
+ build: build the project
« publish: publish the project
« run:run the application on the simulator
« help: display the help for a subcommand
+ no subcommand : executes Easyant with any target
The available options are:
» ——help (-h):display the MMM CLI help
« —-version (-V):display the MMM CLI version

+ ——build-repository-settings-file (-b): path of the Ivy settings file for build artifacts. Defaults to
${user.home}/.microej/microej-ivysettings-5.xml.

« —-repository-settings-file (-r): path of the lvy settings file for module artifacts. Defaults to ${user.
home}/.microej/microej-ivysettings-5.xml.

« ——ivy-file (-f): path of the project’s Ivy file. Defaults to ./module.ivy.

« ——targets (-t): Easyant targets of the build. Available only with no subcommand (for example mmm -t
verify). Defaultsto clean package.

« ——verbose (-v):verbose mode. Disabled by default. Add this option to enable verbose mode.

« -Dxxx=yyy :any additional option passed as system properties.
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Shared configuration

In order to share configuration across several projects, these parameters can be defined in the file ${user.home}/
.microej/.mmmconfig . This file uses the TOML format. Options names are the same, except the character _ is
used as a separator instead of -. Here is an example:

build_repository_settings_file = "/home/johndoe/ivy-configuration/ivysettings.xml”
module_repository_settings_file = "/home/johndoe/ivy-configuration/ivysettings.xml”
ivy_file = "ivy.xml"

[options]

"buildRequesterUserId” = "johndoe”

"artifacts.resolver” = "fetchAll”

"artifactory.cross.username” = "johndoe"

"artifactory.cross.password” = "XXXXXXXXXXXXXXXXXXXXXXXXXX"

Options defined in the [options] section are passed as system properties.

Warning:
« itis mandatory to use quotes for values in the TOML file

« if you use Windows paths, backslashes must be doubled in TOML file, for example
C:\\Users\\johndoe\\ivysettings.xml

Options defined directly in the command line have a higher priority than the ones defined in the configuration file.
So if the same option is defined in both locations, the value defined in the command line is used.

Subcommands
init
The subcommand init creates a project (executes Easyant with skeleton:generate target). The skeleton and
project information must be passed with the following system properties:
« skeleton.org: organisation of the skeleton module. Defaults to org.apache.easyant.skeletons.
« skeleton.module : name of the skeleton module. Mandatory, no default.
« skeleton.rev: revision of the skeleton module. Mandatory, no default.
« project.org: organisation of the project module. Mandatory, no default.
« project.module : name of the project module. Mandatory, no default.
« project.rev: revision of the project module. Defaultsto 0.1.

« skeleton.target.dir : relative path of the project directory (created if it does not exist). Defaults to the
current directory.

For example
mmm init -Dskeleton.org=com.is2t.easyant.skeletons -Dskeleton.module=microej-javalib -Dskeleton.rev=4.2.

—8 -Dproject.org=com.mycompany -Dproject.module=myproject -Dproject.rev=1.0.0 -Dskeleton.target.
—dir=myproject

If one of these properties is missing, it will be asked in interactive mode:
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$ mmm init -Dskeleton.org=com.is2t.easyant.skeletons -Dskeleton.module=microej-javalib -Dskeleton.rev=4.
2.8 -Dproject.org=com.mycompany -Dproject.module=myproject -Dproject.rev=1.0.0

-skeleton:check-generate:

[input] skipping input as property skeleton.org has already been set.

[input] skipping input as property skeleton.module has already been set.

[input] skipping input as property skeleton.rev has already been set.

[input] The path where the skeleton project will be unzipped [/home/tdelhomenie/microej/working/
—skeleton]

To force the non-interactive mode, the property skeleton.interactive.mode must be setto false. In non-
interactive mode the default values are used for missing non-mandatory properties, and the creation fails if manda-
tory properties are missing.

$ mmm init -Dskeleton.org=com.is2t.easyant.skeletons -Dskeleton.module=microej-javalib -Dskeleton.rev=4.
—2.8 -Dproject.org=com.mycompany -Dskeleton.target.dir=myproject -Dskeleton.interactive.mode=false

* Problem Report:

expected property 'project.module': Module name of YOUR project

build

The subcommand build builds the project (executes Easyant with clean package target). For example

mmm build -f ivy.xml -v

builds the project with the Ivy file ivy.xml and in verbose mode.
publish

The subcommand publish publishesthe project. This subcommand accepts the publication target as a parameter,
amongst these values:

+ local (defaultvalue): executesthe clean publish-local Easyanttarget, which publishes the project with
the resolver referenced by the property local.resolver inthe lvy settings.

+ shared : executesthe clean publish-shared Easyanttarget, which publishes the project with the resolver
referenced by the property shared.resolver inthe Ivy settings.

« release :executesthe clean release Easyant target, which publishes the project with the resolver refer-
enced by the property release.resolver inthe Ivy settings.

For example

mmm publish local

publishes the project using the local resolver.
run

The subcommand run runs the application on the simulator (executes Easyant with compile simulator:run
target). It has the following requirements:

« the application to run on the simulator must have one of the following build types:

- build-application, starting from version 7.1.0
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- build-microej-javalib, starting from version 4.2.0
- build-firmware-singleapp, starting with version 1.3.0

« the property application.main.class must be set to the Fully Qualified Name of the application main
class (for example com.mycompany.Main)

« the platform must be referenced using one of these options:

- setthe property platform-loader.target.platform.file to a Platform file absolute path ( *. jpf

)

- setthe property platform-loader.target.platform.dir to a Platform directory absolute path
- declare a dependency in module.ivy

- copy/paste a platform file into the folder defined by the property platform-loader.target.
platform.dropins (by defaultitsvalueis dropins)

« aproperties file (with any name) under a folder build must be available in the project (for example build/
common. properties). It allows to customize simulator configuration.

« the application artifacts must be available before running the simulator, so the mmm build command must
be executed before running the simulator the first time or after a clean.

help

The subcommand help displays the help for a subcommand. For example

mmm help run

displays the help of the subcommand run.

Troubleshooting

Run fails with ““Target “simulator:run” does not exist*¢

If the following message appears when executing the run subcommand:

* Problem Report:

Target "simulator:run” does not exist in the project "my-app”.

it means that the subcommand run is not supported by the build type of your application. Make sure it is one of
the following ones:

+ build-application,with version 7.1.0 or higher
« build-microej-javalib, with version 4.2.0 or higher

« build-firmware-singleapp, with version 1.3.0 or higher

3.6.9 Former MicroEJ SDK Versions

This section describes MMM configuration elements for MicroEJ SDK versions lower than 5.2.0.

New MicroEJ Module Project

The New MicroEJ Module Project wizard is availableat File > New > Project... , EasyAnt > EasyAnt Project
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Preferences Pages

MMM Preferences Pages are located in two dedicated pages. The following pictures show the options mapping
using the same options numbers declared in Preferences Page.

lvy Preferences Page

The Ivy Preferences Page is available at Window > Preferences > Ivy > Settings .

® preferences

type filter text Settings fe=1E 4 - -

General A
Ant [ reload the settings only on demand
CiC++

Checkstyle
Copyright Default | Workspace... | | File System... | | Variables...
EasyantdEclipse

(l) Ivy settings path: | CiA\Users\user\. microgj\microej-ivysettings-3xml |

Help Ivy user dir: ‘ |
lceTea
Install/Update

Workspace... | | File System... | Variables...

Instant Messaging ~
v by (2) Property files: | Stworkspace loc:easyant-build-comp t/rvy/ivyDE.properties} Edit
Advanced S e loc build. p vy/tvyDE_windows.properties}
Add
Classpath Container
Security Remove
Settings
Source/Javadoc Map Up
Workspace Resolver
¥ML Editor Down
Java
JavaScript
< i > Y Restore Defaults Apply

® Apply and Close Cancel

Easyant Preferences Page

The Easyant Preferences Page is available at Window > Preferences > EasyAnt4Eclipse .

® Preferences

type filter text EasyantdEclipse = T
i:: el Set preferences for EasyAnt4Eclipse.
C/Crs (5) [[]Set verbose mode
Checkstyle (3) [[] Use vyDE preferences for vy settings path
Copyright (4) Ivy settings path: | C:\Program Files\MicroENMicroE)-SDK-19.05\rcp\configuration\org.eclipse.osgi\ 54610\ cpirepositorieshivysettings.xml Browse...
Easyant4Eclipse
Help (7) Max build history size: [ 5
leeTea (6) Runtime JRE jre1.80.221 v
Install/Update
Instant Messaging
v vy
Advanced
Classpath Container
Security
Settings ~
Restore Defaults Apply
< >
@ Apply and Close Cancel
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Export the Build Kit

3.7

Create an empty directory (e.g. mmm_sdk_[version]_build_kit),

Locate your SDK installation plugins directory (by default, C:\Program Files\MicroEJ\MicroEJ
SDK-[version]\rcp\plugins on Windows OS),

Open the file com.is2t.eclipse.plugin.easyant4e_[version].jar with an archive manager,
Extract the directory 1ib to the target directory,

Open the file com.is2t.eclipse.plugin.easyant4e.offlinerepo_[version].jar with an archive man-
ager,

Navigate to directory repositories,

Extractthefilenamed microej-build-repository.zip forMicroEJSDK 5.x or is2t_repo.zip forMicroEJ
SDK 4.1.x to the target directory.

Module Natures

The following table describes the project skeleton name for most common MicroEJ Module Natures.

Table 5: MicroEJ Module Natures Summary

Module Nature Skeleton Direct Wizard
Name
Add-On Library microej- File > New > MicroEJ Add-On Library Project
javalib
Mock microej-
mock
Module Repository artifact-
repository
Sandboxed Application application | File > New > MicroEJ Sandboxed Application Project
Standalone Application firmware- File > New > MicroEJ Standalone Application Project
singleapp

3.7.1 Add-On Library

A MicroEJ Add-On Library is a MicroEJ library that is implemented on top of MicroEJ Foundation Libraries (100%
full Java code).

Go to the MicroEJ Libraries page for more details.

3.7.2 Mock

A Mock is a jar file containing some Java classes that simulate natives for the Simulator. Mocks allow applications
to be run unchanged in the Simulator while still (apparently) interacting with native code.

Go to the Mock page for more details.
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3.7.3 Module Repository
A module repository is a module that bundles a set of modules in a portable ZIP file. It is used to contain all the
dependencies required to build and package the applications.

Go to the Module Repository page for more details.

3.7.4 Sandboxed Application

A MicroEJ Sandboxed Application is a MicroEJ Application that can run over a Multi-Sandbox Firmware. It can be
linked either statically or dynamically. If it is statically linked, it is then called a System Application as it is part of
the initial image and cannot be removed.

Go to the Sandboxed Application page for more details.

3.7.5 Standalone Application

A MicroEJ Standalone Application is a MicroEJ Application that is directly linked to the C code to produce a MicroEJ
Firmware. Such application must define a main entry point, i.e. a class containing a public static void main(String[])
method.

Go to the Standalone Application page for more details.

3.8 MicroEJ Classpath

MicroEJ Applications run on a target device and their footprint is optimized to fulfill embedded constraints. The
final execution context is an embedded device that may not even have a file system. Files required by the appli-
cation at runtime are not directly copied to the target device, they are compiled to produce the application binary
code which will be executed by MicroEJ Core Engine.

As a part of the compile-time trimming process, all types not required by the embedded application are eliminated
from the final binary.

MicroEJ Classpath is a developer defined list of all places containing files to be embedded in the final application
binary. MicroEJ Classpath is made up of an ordered list of paths. A path is either a folder or a zip file, called a JAR
file (JAR stands for Java ARchive).

« Application Classpath explains how the MicroEJ Classpath is built from a MicroEJ Application project.

o Classpath Load Model explains how the application contents is loaded from MicroEJ Classpath.

« Classpath Elements specifies the different elements that can be declared in MicroEJ Classpath to describe
the application contents.

3.8.1 Application Classpath

The following schema shows the classpath mapping from a MicroEJ Application project to the MicroEJ Classpath
ordered list of folders and JAR files. The classpath resolution order (left to right) follows the project appearance
order (top to bottom).
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Fig. 25: MicroEJ Application Classpath Mapping

3.8.2 Classpath Load Model

A MicroEJ Application classpath is created via the loading of :

+ an entry point type,

« all . [extension].list files declaredin a MicroEJ Classpath.

The different elements that constitute an application are described in Classpath Elements. They are searched within
MicroEJ Classpath from left to right (the first file found is loaded). Types referenced by previously loaded MicroEJ
Classpath elements are loaded transitively.
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Fig. 26: Classpath Load Principle

3.8.3 Classpath Elements

The MicroEJ Classpath contains the following elements:

« An entrypoint described in section Application Entry Points;

« Typesin .class files, described in section Types;
« Raw resources, described in section Raw Resources;

« Immutables Object data files, described in Section Immutable Objects;

+ Images, Fonts and Native Language Support (NLS) resources, described in Application Resources;

« x.[extension].list files, declaring contents to load. Supported list file extensions and format is specific
to declared application contents and is described in the appropriate section.

At source level, Java types are stored in src/main/java folder of the module project, any other kind of resources
and list files are stored in the src/main/resources folder.

Application Entry Points

MicroEJ Application entry point declaration differs depending on the application kind:

« In case of a MicroEJ Standalone Application, it is a class that contains a public static void
main(String[]) method, declared using the option application.main.class.
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« In case of a MicroEJ Sandboxed Application, it is a class that implements ej.kf.FeatureEntryPoint , de-
clared inthe Application-EntryPoint entryin META-INF/MANIFEST.MF file.

Types
MicroEJ types (classes, interfaces) are compiled from source code ( . java) to classfiles ( .class ). When a type is
loaded, all types dependencies found in the classfile are loaded (transitively).
Atype can be declared as a Required type in order to enable the following usages:
+ to be dynamically loaded from its name (with a call to Class.forName(String) );
« to retrieve its fully qualified name (with a call to Class.getName() ).

A type that is not declared as a Required type may not have its fully qualified name (FQN) embedded. Its FQN can
be retrieved using the stack trace reader tool (see Stack Trace Reader).

Required Types are declared in MicroEJ Classpath using *.types.list files. The file format is a standard Java
properties file, each line listing the fully qualified name of a type. Example:

# The following types are marked as MicroEJ Required Types
com.mycompany .MyImplementation
java.util.Vector

Raw Resources

Raw resources are binary files that need to be embedded by the application so that they may be dynamically re-
trieved with a call to Class.getResourceAsStream(java.io.InputStream) . Raw Resources are declared in Mi-
croEJ Classpath using *.resources.list files. The file format is a standard Java properties file, each line is a
relative / separated name of a file in MicroEJ Classpath to be embedded as a resource. Example:

# The following resource is embedded as a raw resource
com/mycompany/MyResource. txt

Others resources types are supported in MicrokJ Classpath, see Application Resources for more details.

Immutable Objects

Immutables objects are regular read-only objects that can be retrieved with a call to ej.bon.Immutables.
get(String) . Immutables objects are declared in files called immutable objects data files, which format is de-
scribed in the [BON] specification. Immutables objects data files are declared in MicroEJ Classpath using *.
immutables.list files. The file format is a standard Java properties file, each lineis a / separated name of a
relative file in MicroEJ Classpath to be loaded as an Immutable objects data file. Example:

# The following file is loaded as an Immutable objects data files
com/mycompany/MyImmutables.data

System Properties
System Properties are key/value string pairs that can be accessed with a call to System.getProperty(String) .

System properties are declared in MicroEJ Classpath *.properties.list files. The file formatis a standard Java
properties file. Example:
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Listing 1: Example of Contents of a MicroEJ Properties File

# The following property is embedded as a System property
com.mycompany . key=com.mycompany . value
microedition.encoding=I1S0-8859-1

System Properties are resolved at runtime, and all declared keys and values are embedded as intern Strings.

System Properties can also be defined using Applications Options. This can be done by setting the option with a
specific prefix in their name:

« Properties for both the MicroEJ Core Engine and the MicroEJ Simulator : name starts with m