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Welcome to MicroEJ developer documentation. Browse the following chapters to familiarize yourself with MicroEJ
Technology and understand the principles of app and platform development with MicroEJ.

The Glossary chapter describes MicroEJ terminology.

The Overview chapter introduces MicroEJ products and technology.

The SDK User Guide chapter presents the MicroEJ Software Development Kit.
The Application Developer Guide presents how to develop a Java application.

The Platform Developer Guide teaches you how to integrate a C Board Support as well as simulation config-
urations.

The Kernel Developer Guide introduces you to advanced concepts, such as partial updates and dynamic app
life cycle workflows.

The Tutorials chapter covers a variety of topics related to developing with the MicroEJ ecosystem.
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CHAPTER

ONE

MICROEJ GLOSSARY

This glossary defines the technical terms upon which the MICROEJ VEE (Virtual Execution Environment) is built.

Add-On Library An Add-On Library is a pure managed code (Java) library. It runs over one or more Foundation
Libraries.

Abstraction Layer An Abstraction Layer is the C code that implements a Foundation Library’s low-level APIs over
a board support package (BSP) or a C library.

Application An Application is a software program that runs on a Powered by MicroEJ device.

Standalone Application A Standalone Application is an Application that is directly linked to the
C code to produce a Mono-Sandbox Firmware.

Sandboxed Application A Sandboxed Application is an Application that can run over a Multi-
Sandbox Firmware. It can be linked either statically or dynamically.

System Application A System Application (formerly called a Resident Application) is a Sand-
boxed Application that is statically linked to a Multi-Sandbox Firmware, as it is part of the
initial image and cannot be removed.

Kernel Application A Kernel Application is a Standalone Application that implements the ability
to be extended to produce a Multi-Sandbox Firmware.

Architecture An Architecture is a software package that includes the Core Engine port to a target instruction set
and a C compiler, core Foundation Libraries ([EDC], [BON], [SNI], [KF]) and the Simulator. Architectures are
distributed either as evaluation or production version.

Core Engine, also named “MEJ32” The Core Engine, also named MEJ32, is a scalable 32-bit core for resource-
constrained embedded devices. It is delivered in various flavors, mostly as a binary software package. The
Core Engine allows applications written in various languages to run in a safe container.

Firmware A Firmware is the result of the binary link of a Standalone Application with a Platform. It can be pro-
grammed into the flash memory of a device.

Mono-Sandbox Firmware A Mono-Sandbox Firmware is a Firmware thatimplements an unmod-
ifiable set of functions. (formerly called a Single-app Firmware)

Multi-Sandbox Firmware A Multi-Sandbox Firmware is a Firmware thatimplements the ability to
be extended, by exposing a set of APIs and a memory space to link Sandboxed Applications.
(formerly called a Multi-app Firmware)

Foundation Library A Foundation Library is a library that provides core or hardware-dependent functionalities.
A Foundation Library combines managed code (Java) and low-level APIs (C) implemented by one or more
Abstraction Layers through a native interface (S\/).

Mock A Mock is a mockup of a Board Support Package capability that mimics an hardware functionality for the
Simulator.
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Module Manager MicroEJ Module Manager (MMM) downloads, installs and controls the consistency of all the de-
pendencies and versions required to build and publish a MicroEJ asset. It is based on Semantic Versioning
specification.

Platform A Platform integrates a MICROEJ VEE, an Architecture, one or more Foundation Libraries with their re-
spective Abstraction Layers, and the board support package (BSP) for the target Device. It also includes as-
sociated Mocks for the Simulator.

SDK MICROEJ SDK allows Firmware developers to build a Powered by MicroEJ device, by integrating an Architec-
ture with both Java and C software on their device.

Simulator The Simulator allows running Applications on a target hardware simulator on the developer’s desktop
computer. The Simulator runs one or more Mock that mimics the hardware functionality. It enables devel-
opers to develop their Applications without the need of hardware.

Studio The Studio is the part of the SDK that can be rebranded by customers for their specific ecosystem. It allows
application developers to write a Sandboxed Application, run it on a Virtual Device, deploy it on a Powered
by MicroEJ device, and publish it to a MicroEJ Forge instance.

VEE MICROEJVEE is an applications container. VEE stands for Virtual Execution Environment, and refers to the first
implementation that embeds a virtual 32-bit processor, hence the term “Virtual”. MICROEJ VEE runs on any
OS/RTOS commonly used in embedded systems (FreeRTOS, QP/C, uc/0S, ThreadX, embOS, Mbed OS, Zephyr
0S, VxWorks, PikeOS, Integrity, Linux, QNX, ...) and can also run without RTOS (bare-metal) or proprietary
RTOS. MICROEJ VEE includes the small MEJ32, along with a wide range of libraries (Add-On Libraries and
Foundation Libraries).

Virtual Device A Virtual Device is a software package that includes the simulation part of a Firmware: runtime,
libraries and application(s). It can be run on any PC without the need of the SDK. In case of a Multi-Sandbox
Firmware, it is also used for developing a Sandboxed Application in the SDK.
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CHAPTER

TWO

OVERVIEW

The MicroEJ product line offers profitable solutions to device manufacturers, application developers and service
providers for:

« Device software development at lower cost and effort,
+ Application development and deployment for generating extra revenue streams with services and data.

MicroEJ solutions enable delivery of user experience and business models similar to mobile Internet (smartphones
and tablets) for embedded devices with strong cost constraints and strict resource limitations (processor perfor-
mance, RAM and flash memory footprint, low-power). It also combines the techniques, methods and tools that
drove the PC and mobile Internet software industry, with the complex technical foundations of embedded systems
(fragmented processor architectures and diverse hardware-dependent software).

With MicroEJ solutions, you will use proven methods that cut software development time and cost. You will create
software that delivers incredible user experience and adjusts to the needs of your business.

2.1 Getting Started

MicroEJ Getting Started is available on https://developer.microej.com/get-started/.
Starting from scratch, the steps to go through the whole process are:

« Download and install the latest SDK Distribution;

+ Select between one of the available boards;

« Import a demo Application;

« Download and install the corresponding Platform for the target hardware;

+ Run the Application on Simulator with a Virtual Device;

« Build the Application for the target hardware to produce a Firmware;

« Deploy the Firmware on the board.

The following figure gives an overview of the SDK workflow:
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Fig. 1: SDK Workflow Overview

2.2 MICROEJ VEE

MicroEJ VEE (Virtual Execution Environment) is an applications container for resource-constrained embedded de-
vices running on microcontrollers or microprocessors. It allows devices to run multiple and mixed managed code
(Java, JavaScript) and C software applications.

MicroEJ VEE provides a fully configurable set of services that can be expanded, including:
» asecure multi-application framework,
+ aGUI framework (includes widgets),
« anetwork connection with security (SSL/TLS, HTTPS, REST, MQTT, ...),
« astorage framework (file system)

« aJava Cryptography Architecture (JCA) implementation.

2.2. MICROEJ VEE 5
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Fig. 2: MICROEJ VEE Overview

2.3 MICROEJ SDK

MICROEJ SDK offers a comprehensive toolset to build the embedded software of a device. The SDK covers two
levels in device software development:

« Device Firmware development
+ Application development

The firmware will generally be produced by the device OEM, it includes all device drivers and a specific set of Mi-
croEJ functionalities useful for application developers targeting this device.

2.3. MICROEJ SDK 6
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Fig. 3: SDK Workflow Overview

Using the SDK, a firmware developer will produce two versions of the MicroEJ binary, each one able to run appli-
cations:

« A Firmware binary to be flashed on OEM devices;
« AVirtual Device which will be used as a device simulator by application developers.
Using the SDK, an application developer will be able to:

« Import Virtual Devices matching his target hardware in order to develop and test applications on the Simu-
lator;

+ Deploy the application locally on an hardware device equipped with the Firmware;

« Package and publish the application on a MicroEJ Forge Instance, enabling remote end users to install it on
their devices. For more information about MicroEJ Forge, please consult https://www.microej.com/product/
forge.

The following diagram outlines the SDK content. Please refer to the SDK User Guide chapter for more details on the
SDK and its usage.

2.3. MICROEJ SDK 7
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CHAPTER

THREE

SDK USER GUIDE

MICROEJ SDK is an integrated environment to create software applications for MicroEJ-ready devices. The SDK
provides tools to write applications and run them on a virtual (simulated) or real device. The capability to execute
an application in a simulated environment allows to quickly test changes done in the application code and hence
provide a short development feedback loop.

Since the purpose of the SDK is to develop for targeted MCU/MPU computers (IoT, wearable, etc.), it is a cross-
development tool. But unlike standard low-level cross-development tools, the SDK offers unique services like
hardware simulation and local deployment to the target hardware.
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Fig. 1: MicroEJ Application Development Overview

The SDK is composed of the following main elements:

+ SDK Version 5.x, an Integrated Development Environment (IDE) for writing Applications and building
Firmware. It is based on Eclipse Java edition and relies on the integrated Java compiler (JDT).

Itis also packaged with Eclipse to produce a SDK Distribution.

+ MicroEJ Module Manager, the module and build manager used to compile and package any kind of MicroEJ
modules natures. It provides a Command Line Interface to build modules, especially used in a Continuous
Integration environment. See MicroEJ Module Manager section for more details.

+ Architecture, the software package that includes the MEJ32 port to a target instruction set and a C compiler,
SOAR, core libraries and Simulator. See MicroEJ Architecture section for more details.

The SDK allows to connect repositories hosting software modules in source and binary form. By default, it is con-
figured with the repositories provided MicroEJ Corp.:
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+ Centraland Developer Repository, the modules repositories containing all the libraries required to develop
an Application. See Module Repositories section for more details.

« Github Repositories, source repositories with examples and demos. See GitHub Repositories section for
more details.

The SDK is licensed under the SDK End User License Agreement (EULA). The following figure shows a detailed view
of the elements.
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Fig. 2: SDK Detailed View

3.1 Download and Install

The SDK is available for download at https://developer.microej.com/get-started. Check the System Requirements
page for the list of supported environments.

Once downloaded, execute the installer and follow the installation process.

3.2 System Requirements

+ Intel x64 PC with minimum :
- Dual-core Core i5 processor
- 4GB RAM
- 2GB Disk
+ Operating Systems :
- Windows 10, Windows 8.1 or Windows 8

3.1. Download and Install 10
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- Linuxdistributions (tested on Ubuntu 18.04,20.04 and 22.04) - As of SDK Distribution 20.10 (based
on Eclipse 2020-06), Ubuntu 16.04 is not supported.

- macOS with Intel chip (tested on version 10.13 High Sierra, 10.14 Mojave)

Warning: macOS with Apple M1 chip is not officially supported. Please contact our support team
for more details.

« Java:

- JRE or JDK 8 (Oracle JDK or other OpenJDK build: tested on AdoptOpenJDK/Eclipse Adoptium)

Warning: When installing the AdoptOpenJDK build on Windows, the option JavaSoft (Oracle) registry
keys must be enabled:

ﬁ AdoptOpen) DK JDK with Hotspot 8u282-b08 (x64) Setup — X

Custom Setup

Select the way you want features to be installed.

Click the icons in the tree below to change the way features will be installed.

AdoptOpen]DK Development Kit with

--------- Q*I Add to PATH Hotspot

--------- gl Associate .jar

--------- X_-| Set JaVA HOME variable

--------- gl JavaSoft (Oracle) registry keys
T EI TEOTEa-VIED This feature requires 186MB on your
hard drive. It has 3 of 5 subfeatures

selected. The subfeatures require 4KB
on your hard drive.

Location: C:\Program Files\AdoptOpenlDK\jdk-8.0.282.8-hotspot), Browse

Reset Disk Usage Back Mext Cancel

Without this option, the SDK installer cannot find the JRE/JDK and the message The application requires
a Java Runtime Environment 1.8.0 isdisplayed.

3.2. System Requirements 1
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3.3 Licenses

3.3.1 SDKEULA

MICROEJ SDK is licensed under the SDK End User License Agreement (EULA), which covers the following elements:
+ SDK Tools & Plugins packaged in the SDK 5.x Version,
« Architectures,

+ Modules published to the Central Repository with the SDK EULA license, such as GUI or Networking Pack (see
Central Repository Licensing for more details).

Q‘ MICROEJ SDK @ Module Repositories
SDK Distribution YY.MM  @p eclipse MICROEJ SDK EULA Central Repository o

Various Licenses including SDK EULA

(End User License Agreement)

SDK Version 5.m.p 'v",& Developer Repository O

GitHub Repository O

Architecture

Module Manager Ef?

Fig. 3: SDK EULA Coverage

3.3.2 License Manager Overview

Architectures are distributed in two different versions:

« Evaluation Architectures, associated with a software license key. They can be downloaded at https://
repository.microej.com/modules/com/microej/architecture/.

« Production Architectures, associated with a hardware license key stored on a USB dongle. They can be re-
quested to our support team.
The license manager is provided with Architectures and then integrated into Platforms, consequently:

« Evaluation licenses will be shown only if at least one Evaluation Architecture or Platform built from an Eval-
uation Architecture has been imported in the SDK.

« Production licenses will be shown only if at least one Production Architecture or Platform built from a Pro-
duction Architecture has been imported in the SDK.

Thelist ofinstalled licensesis availablein the SDK preferences dialog pagein Window > Preferences > MicroEJ

3.3. Licenses 12
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Fig. 4: License Manager View
3.3.3 License Check
The table below summarizes where the license is checked.
Application Run on | Build on De- | Documentation Link
Simulator vice
(Virtual
Device)
Standalone Application or Kernel Application | NO YES Run on the Device
Sandboxed Application NO NO Application Linking

3.3.4 Evaluation Licenses

This section should be considered when using Evaluation Architectures, which use software license keys. Amachine
UID needs to be provided to activate an Evaluation license on the MicroEJ Licenses Server. The machine UID isa 16
hexadecimal digits number.

Get your Machine UID

Retrieving the machine UID depends on the kind of MicroEJ Platform being evaluated.

If your MicroEJ Platform is already imported in Package Explorer and built with MicroEJ Module Manager, the Archi-
tecture has been automatically imported. The machine UID will be displayed when building a MicroEJ Standalone
Application on device.

[INFO ] Launching in Evaluation mode. Your UID is XXXXXXXXXXXXXXXX.
[ERROR] Invalid license check (No license found).

Otherwise, an Architecture or Platform should have been manually imported from the SDK preferences page. The
machine UID can be retrieved as follows:

« Goto Window > Preferences > MicroEJ ,

3.3. Licenses 13
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« Select either Architectures or Platforms ,
« Click on one of the available Architectures or Platforms,

« Pressthe GetUID button to getthe machine UID.

Note: To accessthis GetUID option, at least one Evaluation Architecture or Platform must have been imported
before (see License Manager Overview).

Copy the UID. It will be needed when requesting a license.

& UID successfully generated @

f OB Your UID was successfully generated.
w

Your UID is:  |A856470297673E28

Fig. 5: Machine UID for Evaluation License

Request your Activation Key

« Go to MicroEJ Licenses Server https://license.microej.com.
+ Clickon Create anew account link.

« Create your account with a valid email address. You will receive a confirmation email a few minutes after.
Click on the confirmation link in the email and log in with your new account.

+ Clickon Activate a License .
« Set Product P/N: to 9PEVNLDBU6IJ.
« Set UID: to the machine UID you copied before.

« Clickon Activate .

« The license is being activated. You should receive your activation by email in less than 5 minutes. If not,
please contact our support team.

« Once received by email, save the attached zip file that contains your activation key.
Install the License Key

If your MicroEJ Platform is already imported in Package Explorer and built with MicroEJ Module Manager, the license
key zip file must be simply dropped to the ~/.microej/licenses/ directory (create it if it doesn’t exist).

3.3. Licenses 14
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» ThisPC » Local Disk (C:) » Users » user » .microgj » licenses
MName Date modified Type Size
RBW2Z-X57RL-5ZYUE-K33DC.zip 30/09/2020 12:27 Compressed (zipp... 1 KB

Fig. 6: MicroEJ Shared Licenses Directory

Note: The SDK Preferences page will be automatically refreshed when building a MicroEJ Standalone Application
n devi

Otherwise, the license key must be installed as follows:
+ Go back to the SDK.

o Selectthe Window > Preferences > MicroEJ menu.

+ Press Add... .

« Browse the previously downloaded activation key archive file.

+ Press OK. A new license is successfully installed.

+ Go to Architectures sub-menu and check that all Architectures are now activated (green check).
« Your SDK is successfully activated.

If an error message appears, the license key could not be installed. (see section Troubleshooting). A license key can
be removed from the key-store by selecting it and by clickingon Remove button.

Troubleshooting
Consider this section when an error message appears while adding the Evaluation license key. Before contacting
our support team, please check the following conditions:

+ Key is corrupted (wrong copy/paste, missing characters, or extra characters)

+ Key has not been generated for the installed environment

+ Key has not been generated with the machine UID

+ Machine UID has changed since submitting license request and no longer matches license key

+ Keyhasnotbeen generated for one of the installed Architectures (no license manager able to load this license)

3.3. Licenses 15
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= Invalid activation key w

The key could not be installed in this environment. Possible reasons are:

- key is corrupted,

- key is valid but does not match any available license manager(s), (Works for an
other edition),

- key has not been generated for this machine,

- old key version.

Fig. 7: Invalid License Key Error Message

3.3.5 Production Licenses

This section should be considered when using Production Architectures, which use hardware license keys stored
on a USB dongle.

= 12345678

Fig. 8: MicroEJ USB Dongle

Note: If your USB dongle has been provided to you by your sales representative and you don’t have received an
activation certificate by email, it may be a pre-activated dongle. Then you can skip the activation steps and directly
jump to the Check Activation on SDK section.

Request your Activation Key

+ Goto license.microej.com.
« Clickon Create a new account link.

« Create your account with a valid email address. You will receive a confirmation email a few minutes after.
Click on the confirmation link in the email and login with your new account.

« Clickon Activate a License .

« Set Product P/N: to The P/N on the activation certificate.

3.3. Licenses 16
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« Enter your UID: serial number printed on the USB dongle label (8 alphanumeric char.).
+ Clickon Activate and check the confirmation message.

+ Click on Confirm your registration .

+ Enter the Registration Code provided on the activation certificate.

o Clickon Submit .

« Your Activation Key will be sent to you by email as soon as it is available (12 business hours max.).

Note: You can check the My Products page to verify your product registration status, the Activation Key avail-
ability, and download the Activation Key when available.

Once the Activation Key is available, download and save the Activation Key ZIP file to a local directory.

Activate your USB Dongle

This section contains instructions that will allow you to flash your USB dongle with the proper activation key.
You shall ensure that the following prerequisites are met :

« Your operating system is Windows

+ The USB dongle is plugged and recognized by your operating system (see Troubleshooting section)

« No more than one USB dongle is plugged into the computer while running the update tool

« The update tool is not launched from a network drive or a USB key

The activation key you downloaded is the one for the dongle UID on the sticker attached to the dongle (each
activation key is tied to the unique hardware ID of the dongle).

You can then proceed to the USB dongle update:
« Unzip the Activation Key file to a local directory
« Enter the directory just created by your ZIP extraction tool.
« Launch the executable program.

« Accept running the unsigned software if requested (Windows 10)

3.3. Licenses 17
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update.exe

Publisher: Unknown
File origin: Hard drive on this computer

Show more details

« Clickonthe - button (no password needed)

[#] Update Tool

F.en[character string)

k.ey

Cancel

Fig. 9: Dongle Update Tool

+ On success, an Update successfully message shall appear. On failure, an Error key or no proper
rockey message may appear.

3.3. Licenses 18
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update_E24C0785

l L Update successfully

oK

Fig. 10: Successful Dongle Update

Check Activation on SDK

Note: Production licenses will be shown only if at least one Production Architecture or Platform has been imported

before (see License Manager Overview).

» Go back to the SDK,

« Goto Window > Preferences > MicroEJ ,

« Goto Architectures or Platforms sub-menuand checkthatall Production Architectures or Platforms are

now activated (green check).

type filter text Platforms
EasyantdEclipse . Add or remove platforms.
> Help
. lceTea Platforms, Virtual Devices and Architectures:
> Install/Update . MName Version | Lic..
::;ta"tmessag'"g 143 FROM-KL46Z Jakarta Kickstart 135
. lava g LPG_ P\rchi‘tect:.'re:CMD
4 MicroEl [C14F 5TM: Hardware Part Number: Jakarta

14 5TM: Compilation Toolchain: CMO_ARMCC

Architectures mE=ul Name: KickStart

MNaming Conventior | Provider: 152T
Eg gm Version: 1.3.5
Platfarms in worksp 7 Core Engine Architecture: 14
Updates [f= STM:‘ Usage Level:[fev"]
[1€¥ STM: Technology Version: 1.6
-+ bm 143 vicr License Tag{S2T JeF5C]
Planning 63 vicp Build Label: 20TS0407-T647
» Plug-in Development Path: .microgrepositories\Full\1.64sd002
Fig. 11: Platform License Status OK
Troubleshooting

Select All
Deselect All
Import...
Uninstall

Get UID

This section contains instructions to check that your operating system correctly recognizes your USB dongle.

GNU/Linux Troubleshooting

For GNU/Linux Users (Ubuntu at least), by default, the dongle access has not been granted to the user, you have to

modify udev rules. Please create a /etc/udev/rules.d/91-usbhdongle.rules file with the following contents:

3.3. Licenses
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ACTION!="add", GOTO="usbdongle_end"
SUBSYSTEM=="usb"”, GOTO="usbdongle_start”
SUBSYSTEMS=="usb", GOTO="usbdongle_start"”
GOTO="usbdongle_end"

LABEL="usbdongle_start"
ATTRS{idVendor}=="096e" , ATTRS{idProduct}=="0006" , MODE="0666"
LABEL="usbdongle_end"

Then, restart udev: /etc/init.d/udev restart

You can check that the device is recognized by running the 1susb command. The output of the command should
contain a line similar to the one below for each dongle: Bus 002 Device 003: ID 096e:0006 Feitian
Technologies, Inc.

Windows Troubleshooting

« If the dongle activation failed with No rockey message, check there is one and only one dongle recognized
with the following hardware ID :

HID\VID_Q96E&PID_0006&REV_0201

Go tothe Device Manager > Human Interface Devices and check amongthe USB InputDevice entries

thatthe Details > Hardwarelds property match the ID mentioned before.

« Ifthe dongle activation was successful with Update successfully message butthe license does not appear
in the SDK or is not updated, try to activate again by starting the executable with administrator privileges:

»  GF2N-HMLPM-94M55-Te3KG

s

Mame Date modified
Mj licensexml 18/03/2020 14:16

EY update.exe T
Open

m Run as administrator I

« If the following error message is thrown when building a MicroEJ Firmware, either the dongle plugged is a
verbatim dongle or it has not been successfully activated:

Invalid license check (Dongle found is not compatible).

VirtualBox Troubleshooting
In a VirtualBox virtual machine, USB drives must be enabled to be recognized correctly. Make sure to enable the
USB dongle by clicking on it in the VirtualBox menu Devices > USB .

To make this setting persistent, go to Devices > USB > USB Settings... and add the USB dongle in the
USB Devices Filters list.

3.3. Licenses 20
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Remote USB Dongle Connection

When the dongle cannot be physically plugged to the machine running the SDK (cloud builds, virtualization, miss-
ing permissions, ...), it can be configured using USB redirection over IP network.

There are many hardware and software solutions available on the market. Among others, this has been tested with
https://www.net-usb.com/. Please contact our support team for more details.

3.4 Module Repositories

This chapter describes the module repositories provided by MicroEJ Corp.

3.4.1 Central Repository

The Central Repository is the module repository distributed and maintained by MicroEJ Corp. It contains a selection
of production-grade modules such as Libraries and Packs.

Use

By default, the SDK is configured to import modules from the online Central Repository.
You can manually browse the repository at https://repository.microej.com/modules/.

Before starting to develop production code, it is strongly recommended to import the repository to your local en-
vironment. Please follow the steps described at https://developer.microej.com/central-repository/.

Licensing

The Central Repository is a set of modules distributed under various software licenses, including the SDK EULA for
some of them. Please consult the LICENSE. txt file attached to each module.

Changelog
The Central Repository content is versioned. The overall changelog is available at https://repository.microej.com/

and describes modules additions or removals. For module content changes, please consult the CHANGELOG. md file
attached to each module.

Javadoc

To consult the APIs documentation (Javadoc) of all libraries available in the repository, please visit https://
repository.microej.com/javadoc/microej_5.x/apis/.

3.4.2 Developer Repository

The developer repository is an online repository hosted by MicrokJ Corp., contains community modules provided
“as-is”. It is similar to what Maven Central Repository are for hosting Java standard modules.

MicroEJ Corp. contributes to the developer repository in the following cases:

« Demos (Platforms, Firmware, Virtual Devices, Applications),

3.4. Module Repositories 21
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+ Incubating Libraries,
« Former Central Repository versions,

« Hardware specific modules.

Use

By default, the SDK is configured to import modules from the developer repository'.

You can also manually browse the repository at https://forge.microej.com/artifactory/
microej-developer-repository-release/.

Before starting to develop production code, it is strongly recommended to transfer the desired modules to your
local environment by creating your own module repository copy.

Licensing

The developer repository is a set of modules distributed under various software licenses. Please consult the
LICENSE. txt file attached to each module.

Changelog

The developer repository is populated from multiple sources, thus there is no changelog for the whole repository
content as it is the case of the Central Repository.

Please consult the CHANGELOG.md file attached to each module.
Javadoc

To consult the APIs documentation (Javadoc) of libraries available in the developer repository, please consult the
javadoc attached to each module.

Community

The developer repository can host modules developed by the community. If your organization plan to develop
such module, please contact our support team to get dedicated credentials for publication.

3.4.3 Content Organization

The following table describes how are organized the modules natures within the repository.

1 Require SDK version 5.4.0 or higher.

3.4. Module Repositories 22
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Table 1: Modules Organization

Organization Module Nature
Foundation Library API

ej.api, com.microej.api

) ) ) Architecture
com.microej.architecture -

Pack

com.microej.pack

Tool or Add-On processor
ej.tool, com.microej.tool

Any other Add-On Library

3.5 GitHub Repositories

Alarge number of examples, libraries, demos and tools are shared on MicroEJ GitHub account: https://github.com/
MicroEJ.

Most of these GitHub repositories contain projects ready to be imported in MicroEJ SDK.

3.5.1 Repository Import

This section explains the steps to import a Github repository in MicroEJ SDK, illustrated with the MWT Examples
repository.

Note: MicroEJ SDK Distribution includes the Eclipse plugin for Git.

First, from the GitHub page, copy the repository URI (HTTP address) from the dedicated field in the right menu
(highlighted in red):

O Why GitHub? Team Enterprise Explore Marketplace Pricing Search Sign in
B MicroEJ / Exam pleJava-MWT @ Watch | 2 Yrstar 1 % Fork | 0
<> Code Issues Pull requests Actions Projects Security Insights

% master = P 1branch  © 2 tags Go to file About

These projects provide examples
Q‘ privron Merge branch ‘develop’ into 'master’ .. BJ Clone @ for MWT

HTTPS  GitHub CLI
: - . o (5 [0 Readme
com.microej.example.mwt.basic ix api minor version @igne https://github.com/MicroEl/Exampleda | [9)
com.microej.example.mwt.butt...  Fix api minor version @ignc  Use Git or checkout with SVN using the web URL. s View license
com.microej.example.mwt.hello...  Fix api minor version @ignc
) Open with GitHub Desktop
. o ) ] Releases
com.microej.example.mwt.mvec Fix api minor version @ignc
com.microej.example.mwt.slidi...  Fix api minor version @ignc [ Download ZIP © 2tecs
[ .gh-copyright.template Move mwt example from foundation libraries @ignore_branc... 3 years ago
N e AR E A e e Forn o Packages
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In MicroEJ SDK, to clone and import the project from the remote Git repository into the MicroEJ workspace, select
File > Import > Git > Projectsfrom Git wizard.

= Import

Select

Import one or more projects from a Git Repository. @

Select an import wizard:

type filter text

= General

= C/C++

[= CV5
v [= Git

&1, Projects from Git

= Install
= MicroEl
= Plug-in Development
= Run/Debug
= Tasks
= Teamn
= XML

@ = Back Finish Cancel

Click Next , select CloneURI ,click Next and paste the remote repository address in the URI field. For
this repository, the address is https://github.com/MicroEJ/ExampleJava-MWT.git. If the HTTP address is a valid
repository, the other fields are filed automatically.

3.5. GitHub Repositories 24
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® |mport Projects from Git
Source Git Repository GIT
Enter the location of the source repository. :_‘:n‘
Location
URJ: ?| https:.-"fgithul:l.cum.-"MicrDElexampI&lava-M‘."H"T.giﬂ | Lacal File...
Host: | github.com |
Repository path: | /Microbl/Examplelava-MWT.git |
Connection
Protocol: | https
Authentication
User | |
Password: | |
[ ]5tore in Secure Store
® = Back Finish Cancel

Click Next , selectthe master branch, click Next and acceptthe proposed Local Destination by clicking Next

once again.

3.5. GitHub Repositories
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® |mport Projects from Git

Local Destination

GIT

Configure the local storage location for Examplelava-MWT. E‘
Destination

Directory: | IC:\Users\user\git\Examplelava-MWT | Browse
Initial branch: K master v

[]Clene submodules

Configuration

Remote name: | crigin

® < Back Finish Cancel

Click Next once more and finally Finish . The Package Explorer view now contains the imported projects.

£ Package Explorer &2 ‘Eg Type Hierarchy % ™

w '[c‘.gl- com.microgj.example.mwt.basic [Examplelava-MWT master]
& src/main/java
B\ Module Dependencies module.ivy [*]
[ src
[%} CHANGELOG.md
5 LICEMSE.txt
ke moduleivy
[#} README.md
'[c".gl- com.microgj.example.mwt.button [Examplelava-MWT master]
'_,fé com.microg).example.rmwt.helloworld [Examplelava-MWT master]
'[;_—'é com.microgj.example.mwt.mve [Examplelava-MWT master]

1—.;‘- com.microg).example.mwt.slidingwidget [Examplelava-MWT master]
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If you want to import projects from another (GitHub) repository, you simply have to do the same procedure using
the Git URL of the desired repository.

3.5.2 MicroEJ GitHub Badges

MicroEJ GitHub Badges are badges embedded in a README at the root of the repository. They highlight the com-
patibilities of the repository at a quick glance with MicroEJ Architecture, MicroEJ SDK and Graphical User Interface
versions.

The color of the badge has the following meaning:
« Green means a current supported version:

+ Orange means a still supported version that will be deprecated in the future:

3.6 Workspaces and MicroEJ Repositories

When starting the SDK, it prompts you to select the last used workspace or a default workspace on the first run. A
workspace is a main folder where to find a set of projects containing MicroEJ source code.

When loading a new workspace, the SDK prompts for the location of the MicroEJ repository, where Architectures,
Platforms or Virtual Devices will be imported. By default, the SDK suggests to point to the default MicroEJ reposi-
tory on your operating system, located at ${user.home}/.microej/repositories/[version].You can selectan
alternative location. Another common practice is to define a local repository relative to the workspace, so that the
workspace is self-contained, without external file system links and can be shared within a zip file.

3.7 SDKVersion

In the SDK, go to Help > About MicroEJ SDK menu.

In case of SDK 4.1.x,the SDK version is directly displayed, suchas 4.1.5:
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o About MicroE) ® SDK

MicroEl® SDE

Version 4.1.5

Copyright ©2016-2018 1527 5.A. All Rights Reserved.

Use of this program is subject to Microk License Agreement.

MicroB)® SDK is built on Eclipse, licensed under the terms of the Commen Public
r License (CPL).

MicroB)® 50K and the MicreE) logos are tradernarks of MicroE) 5.4,

CSPZIOP I BB DFH

® Installation Details

In case of SDK 5. x, the value displayed is the SDK distribution, such as 19.05 or 20.07:

= phout MicroE)® SDE

MicroEl® SDK

Dist. 20.07

Copyright ©2012-2020 Microk) Cerp. All Rights Reserved.

Use of this program is subject to MicroB) License Agreement.

MicroEl® 50K is built on Eclipse, licensed under the terms of the Common
Public License (CPL).

MicroEl® 5DK and the MicrokEl logos are trademarks of MicroBl Corp.

CSCSEOF oI & w

® Installation Details

To retrieve the SDK version that is currently installed in this distribution, proceed with the following steps:
 Clickonthe Installation Details button,
« Clickonthe Installed Software tab,

« Retrieve the version of entry named MicroEJ SDK.
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‘& MicroE) ® SDK Installation Details

Installed Software  |nstallation History Features Plug-ins Configuration

MNarne Version Id Provider
[ C/C++ Development Toeols 5DK 0.4,3.201802261533  org.eclipse.cdt.sdk.feature.group Eclipse COT
@; C/C++ GCC Cross Compiler Support 0.4.3.201802261533  erg.eclipse.cdt.build.crossgec.feature.group  Eclipse COT
@: C/C++ GDB Hardware Debugging 0.4.3.201802261533  erg.eclipse.cdt.debug.gdbijtag feature.gro...  Eclipse CDT
(- Eclipse Checkstyle Plug-in 6.8.0.201507251301  net.sf.eclipsecs.feature.group http://eclipse-cs.sf.
@: Eclipse Runner Feature 134 com.eclipserunnerfeature.feature.group Eclipse Runner Tean
EE: Eclipse SDK 4.7.3.M20180330-06... org.eclipse.sdk.ide Eclipse.org
Eﬁ Eclipse XML Editors and Tools 3.9.2.:201803221834  erg.eclipse.wstxml_uifeaturefeature.group Eclipse Web Tools P
[{f- Git integration for Eclipse 4.9.2.201712130930-r  org.eclipse.eqgit.feature.group Eclipse EGit
[{f- JAutodoc 1.13.0 net.sf jautodec.feature feature.group Martin Kesting
@ Markdown Editor 0.2.3 markdown.editor.feature.feature.group Winterwell

Ll 2 00728-1306  com.is2t.microe).mpp-feature feature.gro.,.,  Microkl
@: MicroE) SDK 5.2.0 cam.is2t.microgj.sdk.featurefeature.group  MicroE)
LLLUZ0Z00728-1306  com.is2t.microe).mpp.product.feature.fea.. MicroE)

@: Mylyn WikiText 3.0.19.201711172000  erg.eclipse.mylyn.wikitext_feature.feature.... Eclipse Mylyn
ug-in .0.3.v - net.zourceforge.pmd.eclipse.feature.grou roject

PMD Plug-i 4.0.5.:20141105-1906 eforge.pmd.eclipse.f group  PMD Proj
[{f- Sonarlint for Eclipse 4.0.0.201810170711  org.sonarlint.eclipse featurefeature.group  SonarSource

3.8 MicroEJ Module Manager

3.8.1 Introduction

Modern electronic device design involves many parts and teams to collaborate to finally obtain a product to be sold
on its market. MicroEJ encourages modular design which involves various stake holders: hardware engineers, UX
designers, graphic designers, drivers/BSP engineers, software engineers, etc.

Modular design is a design technique that emphasizes separating the functionality of an application into inde-
pendent, interchangeable modules. Each module contains everything necessary to execute only one aspect of
the desired functionality. In order to have team members collaborate internally within their team and with other
teams, MicroEJ provides a powerful modular design concept, with smart module dependencies, controlled by the
MicroEJ Module Manager (MMM). MMM frees engineers from the difficult task of computing module dependencies.
Engineers specify the bare minimum description of the module requirements.

The following schema introduces the main concepts detailed in this chapter.
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Module Project Skeleton

Fig.12: MMM Overview

MMM is based on the following tools:
« Apache lvy (http://ant.apache.org/ivy) for dependencies resolution and module publication;

« Apache EasyAnt (https://ant.apache.org/easyant/history/trunk/reference.html) for module build from
source code.

3.8.2 Specification

MMM provides a non ambiguous semantic for dependencies resolution. Please consult the MMM specification
available on https://developer.microej.com/packages/documentation/TLT-0831-SPE-MicroEJModuleManager-2.
0-E.pdf.

3.8.3 Module Project Skeleton

In the SDK, a new MicroEJ module project is created as follows:

+ Select File > New > Project... ,

« Select MicroEJ > Module Project ',

« Fill the module information (project name, module organization, name and revision),

+ Select one of the suggested skeletons depending on the desired module nature,

« Clickon Finish .

11f using SDK versions lower than 5.2.0, please refer to the following section.
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The project is created and a set of files and directories are generated from the selected skeleton.

Note: When an empty Eclipse project already exists or when the skeleton has to be created within an existing
directory, the MicroEJ module is created as follows:

« In the Package Explorer, click on the parent project or directory,

« Select File > New > Other... ,

+ Select EasyAnt > EasyAnt Skeleton .

3.8.4 Module Description File

Amodule descriptionfileis an Ivy configuration file named module. ivy, located at the root of each MicroEJ module
project. It describes the module nature (also called build type) and dependencies to other modules.

<ivy-module version="2.0" xmlns:ea="http://www.easyant.org” xmlns:m="http://ant.apache.org/ivy/extra”
xmlns:ej="https://developer.microej.com” ej:version="2.0.0">
<info organisation="[organisation]” module="[name]" status="integration” revision="[version]">
<ea:build organisation="com.is2t.easyant.buildtypes” module="[buildtype_name]” revision=
—"[buildtype_version]">
<ea:property name="[buildoption_name]"” value="[buildoption_value]"/>
</ea:build>
</info>

<configurations defaultconfmapping="default->default;provided->provided">
<conf name="default” visibility="public"/>
<conf name="provided" visibility="public"/>
<conf name="documentation” visibility="public"/>
<conf name="source" visibility="public"/>
<conf name="dist"” visibility="public"/>
<conf name="test"” visibility="private"/>
</configurations>

<publications>
</publications>

<dependencies>
<dependency org="[dep_organisation]” name="[dep_name]” rev="[dep_version]"/>

</dependencies>
</ivy-module>

Enable MMM Semantic

The MMM semantic is enabled in a module by adding the MicroEJ XML namespace and the ej:version attribute
inthe ivy-module node:

<ivy-module xmlns:ej="https://developer.microej.com” ej:version="2.0.0">

Note: Multiple namespaces can be declared in the ivy-module node.

MMM semantic is enabled in the module created with the Module Project Skeleton.
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Module Dependencies

Module dependencies are added to the dependencies node as follow:

<dependencies>
<dependency org="[dep_organisation]” name="[dep_name]"” rev="[dep_version]"/>
</dependencies>

When no matching rule is specified, the default matching rule is compatible.

Dependency Matching Rule

The following matching rules are specified by MMM:

Name Range Notation Semantic

compatible [M.m.p-RC, (M+1).0.0-RC][ Equal or up to next major version. Default if
not set.

equivalent [M.m.p-RC, M.(m+1).0-RC [ Equal or up to next minor version

greaterOrEqual [M.m.p-RC, oo Equal or greater versions

perfect [M.m.p-RC, M.m.(p+1)-RC[ Exact match (strong dependency)

Set the matching rule of a given dependency with ej:match="matching rule”.Forexample:

<dependency org="[dep_organisation]” name="[dep_name]” rev="[dep_version]" ej:match="perfect” />

Dependency Visibility

« Adependency declared public is transitively resolved by upper modules. The default when not set.
« Adependency declared private isonly used by the module itself, typically for:

- Bundling the content into the module

- Testing the module

The visibility is set by the configurations declared in the configurations node. For example:

<configurations defaultconfmapping="default->default;provided->provided">
<conf name="[conf_name]” visibility="private"/>
</configurations>

The configuration of a dependency is specified by setting the conf attribute, for example:

<dependency org="[dep_organisation]” name="[dep_name]"” rev="[dep_version]"” conf="[conf_name]->x" />

Automatic Update Before Resolution

The Easyant plugin ivy-update can be used to automatically update the version (attribute rev ) of every module
dependencies declared.

<info organisation="[organisation]” module="[name]"” status="integration” revision="[version]">
<ea:plugin org="com.is2t.easyant.plugins” name="ivy-update"” revision="1.+" />
</info>
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When the plugin is enabled, for each module dependency, MMM will check the version declared in the module file
and update it to the highest version available which satisfies the matching rule of the dependency.

Build Options

MMM build options can be set with:

<ea:property name="[buildoption_name]” value="[buildoption_value]"/>

The following build options are globally available:

Table 2: Build Options

Property | Description Default Value
Name

Path of the build directory target~.
target ${basedir}/target~

Refer to the documentation of Module Natures for specific build options.

3.8.5 MicroEJ Module Manager Configuration

By default, when starting an empty workspace, the SDK is configured to import dependencies from MicroEJ Central
Repository and to publish built modules to a local directory. The repository configuration is stored in a settings file (
ivysettings.xml), and the default oneis located at $USER_HOME\ .microej\microej-ivysettings-[VERSION].
xml

Preferences Page

The MMM preferences page in the SDK is available at Window > Preferences > MicroEJ > Module Manager
1
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Fig. 13: MMM Preferences Page

This page allows to configure the following elements:

1.
2.
3.

Settings File: the file describing how to connect module repositories. See the settings file section.

Options: files declaring MMM options. See the Options section.

Use Module repository as Build repository : the settings file for connecting the build repository in
place of the one bundled in the SDK. This option shall not be enabled by default and is reserved for advanced
configuration.

Build repository Settings File:the settings file for connecting the build repository in place of the one
bundled in the SDK. This option is automatically initialized the first time the SDK is launched. It shall not be
modified by default and is reserved for advanced configuration.

Set verbose mode : to enable advanced debug traces when building a module.

Runtime JRE :the Java Runtime Environment that executes the build process.

Max build history size:the maximum number of previous builds available in Build Module shortcut
list:

® workspaceRepository -

File Edit Source Refactor Mavigate Search Project  Run

cruoiv[@]Jeis-0-a-i@e-

4 Package Explorer 33 | ) Build Selected Module (Ctrl+Alt-C, E)
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Settings File

The settings file is an XML file that describes how MMM connects local or online module repositories. The file format
is described in Apache lvy documentation.

To configure MMM to a custom settings file (usually from an offline repository):

1. Set Settings file toacustom ivysettings.xml settings file',

2. Clickon Apply and Close button

If the workspace is not empty, it is recommended to trigger a full resolution and rebuild all the projects using this
new repository configuration:

1. Clean caches

« In the Package Explorer, right-click on a project;
« Select Ivy > Cleanallcaches .
2. Resolve projects using the new repository

To resolve all the workspace projects, click on the Resolve All button in the toolbar:

'® workspaceRepository -

File Edit Source Refactor Mavigate Searc

A | B4~ (

To only resolve a subset of the workspace projects:

« In the Package Explorer, select the desired projects,
+ Right-click on a project and select lvy > Clean all caches .
3. Trigger Add-On Library processors for automatically generated source code

+ Select Project > Clean... ,
+ Select Clean all projects |,

o Clickon Clean button.

Options

Options can be used to parameterize a module description file or a settings file. Options are declared as key/value
pairsin a standard Java properties file, and are expanded using the ${my_property} notation.

Atypical usage in a settings file is for extracting repository server credentials, such as HTTP Basic access authenti-
cation:

1. Declare options in a properties file
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[E| credentials.properties &

1# User specific credentials
2 artifactory.username=myusername
3 artifactory.password=AKCKLzp2JHRLDyFvmTPMXocXiiU1Cnad7eidUcCO1ERSUdgIrIu24ZTYieXaCwuMaIWykjCD9

4

2. Register this property file to MMM options

Options

Property files: | Sfworkspace_loctest/credentials.properties}

3. Usethis option in a settings file

38
39 <credentials host="artifactory.corp” realm="Artifactory Realm” username="${artifactory.username}” passwd="$§{artifactory.password}” />
4/

Atypical usage in a module description file is for factorizing dependency versions across multiple modules projects:

1. Declare an option in a properties file

=| versions.properties &3

=l
14# Specify the EDC wersion used in this workspace
2 edc.version=1.3.8

pu

2. Register this property file to MMM options

Options

Property files: | S{workspace_loc:test/versions.properties)

3. Use this option in a module description file

22 <dependencies:

23 ol--

24 Use the EDC version defined by MMM configuration

25 -

26 <dependency org="ej.api" name="edc" rev="%{edc.version}" /»
27 </dependencies:

28 ¢/ivy-module:
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Resolution Logs

Resolution logs of module projects imported in the workspace are available from the console view:
« Select Windows > ShowView > Console ,
« In the Console view, click on the console window icon and select vy console :

Bl Consale 532

Mo consoles to display at this time.

4

Omfle © ol
i
0

1 New Console View

2 Addon Processor Console
3 C/C++ Build Console
4 Host 05G1 Console

5 vy Console

b Java Stack Trace Console

7 SenarLint Conscle

'

To enable the verbose mode:

« Inthe Ivyconsole view, click on the debugicon and select debug instead of info (defaults):

& Console i3 ﬂ#;gv| =NE =

vy Error
| found ej.api#edc;1.3.3 in aaaa-ivyde-workspace-chain-resclver (@-server)

[1.3.3] ej.apiftedc;[1.3.3-RC,1.3.4-RC[ warning
:: resclution report :: resclve 821ms :: artifacts dl 9ms » info
_____________________________________________________________________ .
[ | modules || artifacts | verhosE
| conf | number| search|dwnlded|evicted|| number|dwnlded| | debug
| default | » | e | & | @ || © | @& | IvyDE error
| provided | | e | @ | e || 1 | @ | lvyDE warning
| platform | & | e | & | e || e | e | ]
Py +  |wyDE info
IvyDE verbose
IvyDE debug

This triggers the full workspace resolution with verbose mode enabled.

3.8.6 Module Build

In the SDK, the build of a MicroEJ module project can be started as follows:

« In the Package Explorer, right-click on the project,

« Select Build Module .
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Fig. 14: Module Build

The build of a module can take time depending on
« the module nature to build,
« the number and the size of module dependencies to download,
« the repository connection bandwidth, ...

The module build logs are redirected to the integrated console.

Alternatively, the build of a MicroEJ module project can be started from the build history:
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Fig. 15: Module Build History

3.8.7 Build Kit

The Module Manager Build Kit is a consistent set of tools, scripts, configuration and artifacts required for build-
ing modules in command-line mode. Starting from SDK 5.4.0, it also contains a Command Line Interface (CLI).
The Build Kit allows to work in headless mode (e.g. in a terminal) and to build your modules using a Continuous
Integration tool.

The Build Kit is bundled with the SDK and can be exported using the following steps:*

+ Select File > Export > MicroEJ > Module Manager Build Kit ,
+ Choose an empty Target directory ,

+ Clickonthe Finish button.
Once the Build Kit is fully exported, the directory content shall look like:

/
— bin
F mmm
L mmm.bat
— conf
— lib
— microej-build-repository
F ant-contrib
F com
t ivysettings.xml
— microej-module-repository
L ivysettings.xml
- release.properties

« Add the bin directory of the Build Kit directory to the PATH environment variable of your machine.

« Make sure the JAVA_HOME environment variable is set and points to a JRE/JDK installation or that java
executable isin the PATH environment variable (Java 8 is required)

+ Confirm that the installation works fine by executing the command mmm --version . The result should
display the MMM CLI version.

The mmm tool can run on any supported Operating Systems:

2 |If using SDK versions lower than 5. 4.0, please refer to the following section.
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+ on Windows, either in the command prompt using the Windows batch script mmm.bat orin MinGW environ-
ments such as Git BASH using the bash script mmm .

» on macOS and Linux distributions using the bash script mmm.

The build repository (microej-build-repository directory) contains scripts and tools for building modules. It is
specific to a SDK version and shall not be modified by default.

The module repository ( microej-module-repository directory) contains a default Settings File for importing
modules from Central Repository and this local repository (modules that are locally built will be published to this
directory). You can override with custom settings or by extracting an offline repository.

To go further with headless builds, please consult the next chapter for command line builds, and this tutorial to
setup MicroEJ modules build in continuous integration environments.

3.8.8 Command Line Interface
Starting from version 5.4.0, the SDK provides a Command Line Interface (CLI). Please refer to the Build Kit section
for installation details.
The following operations are supported by the MMM CLI:
« creating a module project
« cleaning a module project
+ building a module project
« running a MicroEJ Application project on the Simulator

+ publishing a module in a module repository

Usage

In order to use the MMM CLI for your project:
+ go to the root directory of your project

+ run the following command

mmm [OPTION]... [COMMAND]

where COMMAND is the command to execute (for example mmm build). The available commands are:
« help:display help information about the specified command
« init:create a new project
« clean: clean the project
« build: build the project
+ publish: build the project and publish the module
« run: run the MicroEJ Application project on the Simulator
The available options are:
+ ——help (-h): show the help message and exit
« —-version (-V): printversion information and exit

o —-build-repository-settings-file (-b): path of the lvy settings file for build scripts and tools. Defaults
to ${CLI_HOME}/microej-build-repository/ivysettings.xml.
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« ——module-repository-settings-file ( -r ): path of the Ivy settings file for modules. Defaults to
${CLI_HOME}/microej-module-repository/ivysettings.xml.

« ——ivy-file (-f): path of the project’s vy file. Defaults to ./module.ivy.
« ——verbose (-v): verbose mode. Disabled by default. Add this option to enable verbose mode.
« -Dxxx=yyy : any additional option passed as system properties.

When no command is specified, MMM CLI executes Easyant with custom targets using the --targets (-t ) option
(defaults to clean,package).

Shared configuration

In order to share configuration across several projects, these parameters can be defined in the file ${user.home}/
.microej/.mmmconfig . This file uses the TOML format. Parameters names are the same than the ones passed
as system properties, except the character _ is used as a separator instead of - . The parameters defined in the
[options] section are passed as system properties. Here is an example:

build_repository_settings_file = "/home/johndoe/ivy-configuration/ivysettings.xml”
module_repository_settings_file = "/home/johndoe/ivy-configuration/ivysettings.xml”
ivy_file = "ivy.xml”
[options]
my.first.property = "valuel”
my.second.property = "value2”

Warning:

« TOML values must be surrounded with double quotes

« Backslash characters ( \ ) must be doubled (for example a Windows path
C:\\Users\\johndoe\\ivysettings.xml)

Command line options take precedence over those defined in the configuration file. So if the same option is defined
in both locations, the value defined in the command line is used.

Commands
init
Thecommand init creates a new project (executes Easyant with skeleton:generate target). The skeleton and
project information must be passed with the following system properties:
+ skeleton.org: organisation of the skeleton module. Defaults to com.is2t.easyant.skeletons.
« skeleton.module : name of the skeleton module. Mandatory, defaults to microej-javalib.

+ skeleton.rev : revision of the skeleton module. Mandatory, defaults to + (meaning the latest released
version).

« project.org: organisation of the project module. Mandatory, defaults to com.mycompany .
« project.module : name of the project module. Mandatory, defaults to myproject.
« project.rev: revision of the project module. Defaultsto 0.1.0.

« skeleton.target.dir: relative path of the projectdirectory (created ifit does not exist). Mandatory, defaults
to the current directory.
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For example

mmm init -Dskeleton.org=com.is2t.easyant.skeletons -Dskeleton.module=microej-javalib -Dskeleton.rev=4.2.
—8 -Dproject.org=com.mycompany -Dproject.module=myproject -Dproject.rev=1.0.0 -Dskeleton.target.
—dir=myproject

If one of these properties is missing, it will be asked in interactive mode:

$ mmm init -Dskeleton.org=com.is2t.easyant.skeletons -Dskeleton.module=microej-javalib -Dskeleton.rev=4.
2.8 -Dproject.org=com.mycompany -Dproject.module=myproject -Dproject.rev=1.0.0

-skeleton:check-generate:

[input] skipping input as property skeleton.org has already been set.

[input] skipping input as property skeleton.module has already been set.

[input] skipping input as property skeleton.rev has already been set.

[input] The path where the skeleton project will be unzipped [/home/tdelhomenie/microej/working/
—skeleton]

To force the non-interactive mode, the property skeleton.interactive.mode must be setto false. In non-
interactive mode the default values are used for missing non-mandatory properties, and the creation fails if manda-
tory properties are missing.

$ mmm init -Dskeleton.org=com.is2t.easyant.skeletons -Dskeleton.module=microej-javalib -Dskeleton.rev=4.
2.8 -Dproject.org=com.mycompany -Dskeleton.target.dir=myproject -Dskeleton.interactive.mode=false

* Problem Report:

expected property 'project.module': Module name of YOUR project

clean

The command clean cleans the project (executes Easyant with clean target). For example

mmm clean

cleans the project.
build

The command build builds the project (executes Easyant with clean,package targets). For example

mmm build -f ivy.xml -v

builds the project with the Ivy file ivy.xml and in verbose mode.
publish

The command publish buildsthe project and publishes the module. This command accepts the publication target
as a parameter, amongst these values:

+ local (defaultvalue): executesthe clean,publish-local Easyanttarget, which publishes the project with
the resolver referenced by the property local.resolver inthe Settings File.

+ shared: executesthe clean,publish-shared Easyant target, which publishes the project with the resolv